Jump to content


Photo
- - - - -
Resolved

Mixed Content Error / Ssl/ Google Fonts

ssl google fonts

  • Please log in to reply
19 replies to this topic

#1 gayatriom

gayatriom

    Advocate

  • Members

  • 559 posts
  • Country: Country Flag

Posted 16 November 2012 - 02:42 PM

Hi. My entire site is secure, except for the google fonts
I'm getting a mixed content error because of google fonts.
How can I remedy this?

#2 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 16 November 2012 - 02:45 PM

Can you provide a url?

#3 gayatriom

gayatriom

    Advocate

  • Members

  • 559 posts
  • Country: Country Flag

Posted 17 November 2012 - 02:56 PM

justseti.com/order

#4 gayatriom

gayatriom

    Advocate

  • Members

  • 559 posts
  • Country: Country Flag

Posted 17 November 2012 - 03:01 PM

i get randomly.

#5 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 17 November 2012 - 04:31 PM

Impossible to test as you have OMG cache installed and running.

#6 gayatriom

gayatriom

    Advocate

  • Members

  • 559 posts
  • Country: Country Flag

Posted 17 November 2012 - 07:25 PM

OMG cache?
I have w3total cache and mzxcdn.
About to switch out w3total cache with super cahce.
the whole site is way too slow without them.

i can turn off w3total cache for a bit.

#7 gayatriom

gayatriom

    Advocate

  • Members

  • 559 posts
  • Country: Country Flag

Posted 17 November 2012 - 07:28 PM

turned off w3totalcache.

#8 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 17 November 2012 - 07:34 PM

Cant find any non ssl links there

#9 gayatriom

gayatriom

    Advocate

  • Members

  • 559 posts
  • Country: Country Flag

Posted 17 November 2012 - 08:28 PM

so odd.
they come and go. will do a screenshot the next time it happens.

#10 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 18 November 2012 - 12:04 AM

Okay, keep us posted.

#11 gayatriom

gayatriom

    Advocate

  • Members

  • 559 posts
  • Country: Country Flag

Posted 18 November 2012 - 10:51 PM

You can close this for now. Will reopen if I encounter it again.

#12 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 18 November 2012 - 10:55 PM

The topic was marked as resolved.

#13 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 18 November 2012 - 10:57 PM

The topic was marked as resolved.

#14 gayatriom

gayatriom

    Advocate

  • Members

  • 559 posts
  • Country: Country Flag

Posted 01 December 2012 - 06:42 PM

Ah. So now the google font just doesn't load at all. 

It defaults to something else. Perhaps times new roman?

So with ssl the google font doesn't load because it loads with http:// not https// . 

how can i fix this?



#15 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 01 December 2012 - 07:22 PM

Your page is http:// not ssl, the google font link is

Please Login or Register to see this Hidden Content

and is loading ok.

 

Where are you using the font?



#16 gayatriom

gayatriom

    Advocate

  • Members

  • 559 posts
  • Country: Country Flag

Posted 01 December 2012 - 08:15 PM

hmm. no the entire site is

Please Login or Register to see this Hidden Content

 

Please Login or Register to see this Hidden Content



#17 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 01 December 2012 - 08:20 PM

No it isnt, your site_url etc in settings is set to non-ssl 

Please Login or Register to see this Hidden Content



#18 gayatriom

gayatriom

    Advocate

  • Members

  • 559 posts
  • Country: Country Flag

Posted 01 December 2012 - 09:31 PM

hmm this is what i have. 

<a href=""><img src="" alt="" title="Hosted by imgur.com" /></a>



#19 gayatriom

gayatriom

    Advocate

  • Members

  • 559 posts
  • Country: Country Flag

Posted 01 December 2012 - 09:31 PM



#20 gayatriom

gayatriom

    Advocate

  • Members

  • 559 posts
  • Country: Country Flag

Posted 02 December 2012 - 12:09 AM

ok. 

it seems that the problem is not there anymore. grr. so weird! 

pops up sometimes and sometimes not! 

but have a new problem. 

will open a new ticket. 

mark this as resolved for now.