Jump to content


Photo
- - - - -

Help My Site Is Loading So Slow!

slow

  • Please log in to reply
15 replies to this topic

#1 lakersalex

lakersalex

    Super Member

  • Members
  • 102 posts
  • LocationLos Angeles
  • Country: Country Flag

Posted 15 November 2012 - 08:47 PM

I'm just starting work on a new website and am having slowness already. Please have a look:

Please Login or Register to see this Hidden Content



"Pagelines Compiled CSS" is taking a second just "waiting" and is almost 200k in size? That's huge for a CSS file, no?

#2 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 15 November 2012 - 08:52 PM

Did you try adding the code from the other post you commented in?

#3 lakersalex

lakersalex

    Super Member

  • Members
  • 102 posts
  • LocationLos Angeles
  • Country: Country Flag

Posted 15 November 2012 - 08:53 PM

no what does it do?!

#4 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 15 November 2012 - 08:57 PM

Its tells the framework to use a file instead of a dynamic url for the css, so its written to an actual css file which can be cached by the browser/cdn/isp/moonbase whatever.

#5 lakersalex

lakersalex

    Super Member

  • Members
  • 102 posts
  • LocationLos Angeles
  • Country: Country Flag

Posted 15 November 2012 - 09:19 PM

As you suggested, I added this line of code to wp-config.php

define( 'LESS_FILE_MODE', true );

I ran the test again and the speed is improved but the slowest thing to load is still the CSS, which is 197k in size.

Please Login or Register to see this Hidden Content



Is there something else going on?

#6 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 15 November 2012 - 09:20 PM

Your server might not be compatible, enable debug mode under the advanced tab

#7 lakersalex

lakersalex

    Super Member

  • Members
  • 102 posts
  • LocationLos Angeles
  • Country: Country Flag

Posted 15 November 2012 - 09:31 PM

debug enabled.

#8 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 15 November 2012 - 09:48 PM

No reason there why it shouldn't work, where did you add the define line?

#9 lakersalex

lakersalex

    Super Member

  • Members
  • 102 posts
  • LocationLos Angeles
  • Country: Country Flag

Posted 15 November 2012 - 09:57 PM

in wp-config.php at the bottom of the file.

#10 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 15 November 2012 - 09:59 PM

ok, right at the bottom? Below the do not edit below this line?

#11 lakersalex

lakersalex

    Super Member

  • Members
  • 102 posts
  • LocationLos Angeles
  • Country: Country Flag

Posted 15 November 2012 - 10:30 PM

looking closely now.

Here's the bottom of the wp-config.php file:


/* That's all, stop editing! Happy blogging. */

/** Absolute path to the WordPress directory. */
if ( !defined('ABSPATH') )
define('ABSPATH', dirname(__FILE__) . '/');

/** Sets up WordPress vars and included files. */
require_once(ABSPATH . 'wp-settings.php');

I had originally pasted the code below these lines. now I just pasted the line above the line that reads


/* That's all, stop editing! Happy blogging. */

#12 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 15 November 2012 - 10:39 PM

Yes its working now

#13 lakersalex

lakersalex

    Super Member

  • Members
  • 102 posts
  • LocationLos Angeles
  • Country: Country Flag

Posted 15 November 2012 - 10:44 PM

thanks, the css file is still nearly 200k. Is that normal?

#14 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 15 November 2012 - 10:48 PM

200k is fine. Its loaded once and stored, thats the idea.

#15 lakersalex

lakersalex

    Super Member

  • Members
  • 102 posts
  • LocationLos Angeles
  • Country: Country Flag

Posted 15 November 2012 - 10:50 PM

i see. tests now range between 3 and 6 seconds now. it is faster for sure. anything else I could be doing? I checked the box to Enable CSS minification

#16 James B

James B

    Advocate

  • Moderators
  • 4985 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 16 November 2012 - 03:51 AM

Hi there, take a look at this post, it has some other suggestions on speeding up the load time

Please Login or Register to see this Hidden Content







Also tagged with one or more of these keywords: slow