Jump to content


Photo
- - - - -

Adding Less To Pagelines Base Theme

less

  • Please log in to reply
11 replies to this topic

#1 glennyboy

glennyboy

    Super Member

  • Members

  • 156 posts
  • Country: Country Flag

Posted 13 November 2012 - 09:58 PM

Hi

I have found a similar post to this, but am starting a new post in the hope that you will resolve lack of documentation on adding .less to a Pagelines Base / Templates Theme. You say .less is great, but then leave us with scant any info on how to implement.

I have added a style.less file to the theme folder (same place as style.css) and tried some .less, but nothing happens whosoever. Can you please advise on necessary steps to add .less to base theme.

Regards

Glennyboy

#2 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 13 November 2012 - 10:22 PM

The LESS code will only be added to the main css, if there are no errors, tell us the code you are adding to the file.

#3 glennyboy

glennyboy

    Super Member

  • Members

  • 156 posts
  • Country: Country Flag

Posted 13 November 2012 - 10:24 PM

I'm not getting errors - I'm not getting anything. To add .less to the base theme what do I do please? What should the .less file be called and where should it be placed?

I should say I was just trying some test .less to apply to body and then li and then a few other elements.

#4 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 13 November 2012 - 10:31 PM

Create a file style.less in the base theme folder. Thats all there is to it.

#5 glennyboy

glennyboy

    Super Member

  • Members

  • 156 posts
  • Country: Country Flag

Posted 13 November 2012 - 10:32 PM

I did that and got nothing. Perhaps you can provide some .less that I can use as a definitive test on the theme?

#6 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 13 November 2012 - 10:42 PM

well just add some css...

Please Login or Register to see this Hidden Content



#7 glennyboy

glennyboy

    Super Member

  • Members

  • 156 posts
  • Country: Country Flag

Posted 13 November 2012 - 11:18 PM

OK so I tried some basic css:-

body {
display:none;
}

Obviously I expected to see a blank screen, but all the content remained?

#8 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 13 November 2012 - 11:53 PM

perhaps provide a url so we can see?

#9 glennyboy

glennyboy

    Super Member

  • Members

  • 156 posts
  • Country: Country Flag

Posted 14 November 2012 - 01:13 PM

Can I PM you? I don't want to provide a link to the site in development.

#10 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 14 November 2012 - 01:19 PM

If you added the url as private in your user settings, only moderators can see it anyway

#11 glennyboy

glennyboy

    Super Member

  • Members

  • 156 posts
  • Country: Country Flag

Posted 14 November 2012 - 01:22 PM

Sorry how do I do that?

#12 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 14 November 2012 - 01:34 PM

Click your name at the top of this page, and click my settings then change your site url. You already have a url there.





Also tagged with one or more of these keywords: less