Jump to content


Photo
- - - - -
Open

Brandvan Section Hilight In Wrong Place



  • Please log in to reply
16 replies to this topic

#1 quinntinm

quinntinm

    Super Member

  • Members
  • 121 posts
  • Country: Country Flag

Posted 13 November 2012 - 10:48 AM

Hi there.

I have just finished the site i have been working on with the custom post type and custom fields and i wanted to thank all of those who assisted me. I really appreciate it.

There is one item that i cannot seem to work out how to fix.

When i click on "About" http://www.deependfilms.co.za/about/ the navigation highlights as it should.
When i click on "films" and follow one of the sub nav items e.g. "Completed" http://www.deependfilms.co.za/completed-films-by-deepend-films/ the navbar seems to highlight the "News" tab and not the film tab.

Can anyone assist me in this?

Thank you.

#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 16313 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 13 November 2012 - 10:57 AM

Hi,

This isn't happening for me?

Please Login or Register to see this Hidden Content



#3 quinntinm

quinntinm

    Super Member

  • Members
  • 121 posts
  • Country: Country Flag

Posted 13 November 2012 - 11:19 AM

Hi Danny, please click on one of those posters, the next page is the problem.
It highlights the news item in a light grey block...

#4 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 13 November 2012 - 03:14 PM

I clicked on all the subnav items under "Films" and the "Films" tab is highlighted each time (the "News" tab isn't highlighted at all). I'm viewing this on both Firefox and Chrome for Mac. Did this issue get resolved or are you still seeing it?

#5 quinntinm

quinntinm

    Super Member

  • Members
  • 121 posts
  • Country: Country Flag

Posted 14 November 2012 - 07:20 AM

Hi Catrina, hope you are well.

Sorry, i have upgraded the grid portfolio section/plugin and it has broken the site completely...

Is there a way to go into the database and revert back to the previous version or switch it off so i can at least get back into the admin and get the clients website up again.

I cannot access the admin or the front end...

#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 16313 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 14 November 2012 - 08:01 AM

I replied to your topic regarding the issue with Grid Portfolio.

Please Login or Register to see this Hidden Content



#7 quinntinm

quinntinm

    Super Member

  • Members
  • 121 posts
  • Country: Country Flag

Posted 14 November 2012 - 06:03 PM

Catrina, do you mean on these pages the menu item for "FILMS" is highlighted?

Please Login or Register to see this Hidden Content


Please Login or Register to see this Hidden Content



In all those cases i get the attached screengrab.


Mac OSX 10.6.8
- Firefox 16.0.2
- Safari 5.1.7
- Chrome 23

Attached Files



#8 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 14 November 2012 - 06:15 PM

Oddly, now I see the News item highlighted. Can you please take a screenshot of your page hierarchy under "Pages" on Dashboard?

#9 quinntinm

quinntinm

    Super Member

  • Members
  • 121 posts
  • Country: Country Flag

Posted 14 November 2012 - 06:18 PM

Here you go.

Attached Files



#10 quinntinm

quinntinm

    Super Member

  • Members
  • 121 posts
  • Country: Country Flag

Posted 14 November 2012 - 06:22 PM

Catrina, remember also that the "Film" pages are custom post types which are not under pages but films.

#11 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 16 November 2012 - 04:31 AM

It seems to think those items are ancestors of the blog so it's highlighting the relative link in the nav.

You can turn it off with this css, shouldn't affect the other pages as they seem to be set using different css. If the below doesn't work and affects other areas on the nav we'll have to look at a way to make it more specific.

Please Login or Register to see this Hidden Content



#12 quinntinm

quinntinm

    Super Member

  • Members
  • 121 posts
  • Country: Country Flag

Posted 16 November 2012 - 07:16 AM

Hi James, i will try that.
How do i get the Films nav to be highlighted though?

#13 Danny

Danny

    Is Awesome!

  • Moderators
  • 16313 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 16 November 2012 - 07:23 AM

OK from what I can see the images on the Films page for example,

LIGHT AND DARK / DOCUMENTARY

This isn't a page but a post, which is part of your Blog. It looks as though you have created a News page and set this as your Post Page in Settings > Reading.

If this is the case, then there is no issue and the menu is working as intended.

If you wish to for the films menu to be active when viewing your these films. I suggest you use child pages and not posts.

#14 quinntinm

quinntinm

    Super Member

  • Members
  • 121 posts
  • Country: Country Flag

Posted 16 November 2012 - 07:52 AM

Hi there. It is a custom post type. Can they only be posts or can they be pages too?

Sorry, this is the first time i have ever worked with custom post types and i am not a programmer so it's all new for me :-)

#15 Danny

Danny

    Is Awesome!

  • Moderators
  • 16313 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 16 November 2012 - 08:07 AM

Custom Post Types, are post based and can not be pages. Like I mentioned above if you wish to contain your navigation, you will need to use pages.

#16 quinntinm

quinntinm

    Super Member

  • Members
  • 121 posts
  • Country: Country Flag

Posted 16 November 2012 - 11:50 AM

Is there a custom Page option?

#17 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 16 November 2012 - 03:26 PM

There is a custom page template option:

Please Login or Register to see this Hidden Content