Jump to content


Photo
- - - - -

How do I relink an entire site?


This topic has been archived. This means that you cannot reply to this topic.
2 replies to this topic

#1 catchjorge

catchjorge

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 03 December 2009 - 03:27 PM

I built my client's website at www.latinexito.com (hosted and domain registered with bluehost). The client's previous website was hosted and domain registered at Networksolutions. His URL is www.mauroguerra.com. I now pointed A records from mauroguerra.com to the files hosted at bluehost. When you go to mauroguerra.com it goes directly to the right files hosted at bluehost. However, when you start surfing the site, all of the other links in the URL start to appear as www.latinexito.com/seminarios, for example. How do I relink the entire site so that it all uses mauroguerra.com domain without changing one link at a time. Also, when I add new pages, they probably become latinexito links, so I have to fix something in the settings perhaps. Any advice greatly appreciated!!! ;) Jorge in Miami

#2 arpowers

arpowers

    Founder

  • Administrators
  • 3270 posts

Posted 03 December 2009 - 05:35 PM

You need to change WordPress' root URL for the site, also there might be links 'hard-coded' in the WP content that you'll need to change manually. Unfortunately, moving servers/domain names isn't a walk in the park.

#3 catchjorge

catchjorge

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 04 December 2009 - 09:12 PM

Thanks!! I actually found the place to do this (proceed at your own risk). If you go to SETTINGS>GENERAL in the admin area, you will find a spot where you can specify: WordPress address (URL) Blog address (URL) like you say. I changed these to the new domain and it automatically re-linked the entire site as I wanted it! BE AWARE: I had to reset my password and admin login settings because it no longer allowed me to login through www.the-old-domain/wp-admin. Bluehost had a way to reset this so that www.new-domain/wp-admin worked after resetting this feature.