Jump to content


Photo
- - - - -

Sidebar Not Displaying Properly In Explorer

explorer sidebar

  • Please log in to reply
30 replies to this topic

#1 theresacs

theresacs

    Member

  • Members
  • 19 posts
  • Framework Version:2.3.5
  • Country: Country Flag

Posted 06 November 2012 - 01:28 PM

For some reason, the columns for my site,

Please Login or Register to see this Hidden Content

are not displaying properly in Explorer.

The main content column is taking up the whole screen, and my righthand sidebar is being pushed to the bottom of the page.

This is not a problem in Firefox or Safari.

I'd appreciate any help or suggestions.

Many thanks.
Theresa

#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 06 November 2012 - 05:05 PM

Please make sure you're using the latest version of Internet Explorer and post screenshots of your site here (I don't have IE so I can't check it out).

#3 theresacs

theresacs

    Member

  • Members
  • 19 posts
  • Framework Version:2.3.5
  • Country: Country Flag

Posted 08 November 2012 - 12:06 AM

Thank you Catrina! I am using the most recent version of Explorer, here are the screenshots from IslandVittles.com

Posted Image
Posted Image

#4 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 08 November 2012 - 01:31 AM

Hi there, first if you have any third party plugins please disable them and see if the layout resolves, just in case there's a plugin conflict.

Have you added any css or custom code to the sidebar or content area at all?

#5 theresacs

theresacs

    Member

  • Members
  • 19 posts
  • Framework Version:2.3.5
  • Country: Country Flag

Posted 08 November 2012 - 08:56 PM

James! Thank you for your help...I have disabled all plugins, but this did not resolve the issue.

I have not added css or custom code to either the side bar or content area.

any thoughts are much appreciated! Thank you!

theresa

#6 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 09 November 2012 - 12:42 AM

I've just got another member of staff who has IE to test in IE9 and it's displaying ok in there. Do you have compatibility mode on at all? Can you confirm exactly which version of IE you're on for us.

#7 theresacs

theresacs

    Member

  • Members
  • 19 posts
  • Framework Version:2.3.5
  • Country: Country Flag

Posted 09 November 2012 - 10:58 AM

I am using Explorer 9 and I do not have compatibility mode on. I just checked the display here, and the sidebar is still getting pushed down to the bottom.
Thank you,
Theresa

#8 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 09 November 2012 - 03:27 PM

Please try turning compatibility mode on (if you haven't done so already). Also, are you using any custom CSS?

#9 theresacs

theresacs

    Member

  • Members
  • 19 posts
  • Framework Version:2.3.5
  • Country: Country Flag

Posted 09 November 2012 - 04:35 PM

I'll try turning it on right now...no custom CSS.

thank you!

#10 theresacs

theresacs

    Member

  • Members
  • 19 posts
  • Framework Version:2.3.5
  • Country: Country Flag

Posted 09 November 2012 - 04:38 PM

Compatibility mode is now turned on -- it doesn't look like it's fixed the problem though.

#11 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 10 November 2012 - 12:26 AM

Hi there, I'm not sure what's causing this, i can only assume that some padding it being added somewhere which is causing the sidebar to stack in IE. Could you try adding the following code into Pagelines>Site Options>Custom code. Let us know if this moves the sidebar up in the correct space.

Please Login or Register to see this Hidden Content



#12 theresacs

theresacs

    Member

  • Members
  • 19 posts
  • Framework Version:2.3.5
  • Country: Country Flag

Posted 10 November 2012 - 09:50 PM

Thank you, James.

I pasted the code into the Custom code box below the line with the body {} - I`m afraid that didn`t work either.

theresa

#13 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 10 November 2012 - 10:30 PM

Theresa,

I can see the site fine in IE9. Looking at the screenshot you provided, I'm compelled to concur that your site does have a problem, but I'm going to have to presume that it's a setup issue or a conflict.

When sidebars appear below a certain point, it usually means that there's a configuration, layout or setup error somewhere. Since this seems to be browser specific (which I can't see), I don't quite know where to look for it. Often, it might be that the Content section is missing in the Page Templates, but that doesn't seem to be the case here.

Is WordPress updated to 3.4.2? Is PL at the latest version (2.3.5)?

#14 theresacs

theresacs

    Member

  • Members
  • 19 posts
  • Framework Version:2.3.5
  • Country: Country Flag

Posted 12 November 2012 - 12:47 AM

Hi Rob,

Wordpress is 3.4.2 and PL is the latest version too. I appreciate your input here.

#15 Danny

Danny

    Is Awesome!

  • Moderators
  • 17139 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 12 November 2012 - 07:48 AM

Hi Theresa,

I already informed you last week in Live chat, what is causing your issue.

The Sidebar is most likely being pushed below your content due to incorrect HTML, which you have added to your posts.

To make sure this is not the case, please create a test post, that contains only text no HTML, no images but text only. Once this post has been created, view the post in IE and see if the sidebar has been pushed underneath the content area. If the sidebar is below the content area, then disable all active plugins, remove any custom CSS or custom scripts and then view the post again.

If you still have an issue, we can investigate further.

#16 theresacs

theresacs

    Member

  • Members
  • 19 posts
  • Framework Version:2.3.5
  • Country: Country Flag

Posted 12 November 2012 - 11:10 AM

Danny,

I created a test post just as you described after our Live Chat conversation, and found that the lack of html in a post it did not fix the problem, so I came in here to request help.

To demonstrate this to you, I have created another test post, disabled all plugins and removed all custom CSS -- screenshots below.

The sidebar is still below the content area. I would appreciate any further suggestions.

theresa

Posted Image
Posted Image

#17 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 12 November 2012 - 11:27 AM

Turn off IE compatibility mode.

#18 theresacs

theresacs

    Member

  • Members
  • 19 posts
  • Framework Version:2.3.5
  • Country: Country Flag

Posted 12 November 2012 - 11:37 AM

IE compatibility mode has been turned on and off, with no change to the display.

theresa

#19 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 12 November 2012 - 11:42 AM

can u post a screenshot with it turned off?

#20 theresacs

theresacs

    Member

  • Members
  • 19 posts
  • Framework Version:2.3.5
  • Country: Country Flag

Posted 12 November 2012 - 01:10 PM

Simon,

Those most recent screen shots are with IE Compatibility turned off...shall I post screen shots with it turned back on?

Theresa





Also tagged with one or more of these keywords: explorer, sidebar