Jump to content


Photo
- - - - -

2.3.5 Update Broke Vanilla Integration

vanilla pagelines

Best Answer christopher_a , 23 November 2012 - 12:42 PM

Thanks, that helped point me towards the .htaccess file, but not actually a deletion issue. I found on the Vanilla community forums that there was an Apache update for BlueHost that requires a change in the .htaccess file in the Vanilla install directory:

 # RewriteBase /

should be edited to

 # RewriteBase /forum


I'm not with Bluehost, but editing the .htaccess file fixed this on my host, so perhaps they too rolled out a similar update which requires a more direct path?

However I updated Vanilla before the v2.3.5 update was available and everything was working smoothly, so either updating to v2.3.5 freaked it out, my webhost's Apache update changed something, or there's something else I broke somewhere. Go to the full post


  • This topic is locked This topic is locked
10 replies to this topic

#1 christopher_a

christopher_a

    Advanced Member

  • Members
  • 35 posts
  • Country: Country Flag

Posted 04 November 2012 - 12:49 AM

Just updated to 2.3.5 and Vanilla is broken. No forum pages will load, every thread brings up a 404 error. Also the "log-in with wordpress" via js connect is now broken and loads a 404 'page not found error' too.

#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 04 November 2012 - 01:35 AM

Usually a 404 error indicates an out-of-place permalink setting. Simply go to Dashboard > Settings > Permalinks and without changing any settings, just click the Save button. This will update the permalinks and should correct the 404 errors.

If not, please let us know.

#3 christopher_a

christopher_a

    Advanced Member

  • Members
  • 35 posts
  • Country: Country Flag

Posted 05 November 2012 - 03:16 AM

Tried that before I posted the issue here, but I did it once more for you, and still 404'd.

After I tried switching permalinks from 'post name' back to 'default' which directs all forum thread links to the default Wordpress posts page. Changed it back, and threads = 404 again.

#4 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 08 November 2012 - 04:10 AM

Hi there, I've just checked your site to see if we can assist further and the forum seems to be displaying. Did you manage to resolve this issue or do you need further help. Please let us know

#5 James B

James B

    Advocate

  • Members

  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 08 November 2012 - 04:13 AM

ah take that back, just tried to go into it and saw the 404.

I've not used Vanilla before so I'm just gonna suggest some things which instantly come to mind, they might not be relevant to this situation, but might make sense somewhere etc.

Is everything published, nothing holding as a draft/preview anywhere? No slugs changed on any of the pages? In the admin area, can you see the content which is bringing up the 404 anywhere?

#6 christopher_a

christopher_a

    Advanced Member

  • Members
  • 35 posts
  • Country: Country Flag

Posted 20 November 2012 - 06:26 PM

I can't even get to the Vanilla dashboard, it seems like anything beyond the main forum index results in a 404 error.

There is nothing saved as a draft/preview in Wordpress.

#7 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 20 November 2012 - 10:04 PM

I suspect in this case, that you may have updated Vanilla as well resulting in the unintentional deletion of Vanilla's .htaccess file.

Contact your host and ask them for a restoration of your server from before you made the change. It's really not related to PL's update.

#8 christopher_a

christopher_a

    Advanced Member

  • Members
  • 35 posts
  • Country: Country Flag

Posted 23 November 2012 - 12:42 PM   Best Answer

Thanks, that helped point me towards the .htaccess file, but not actually a deletion issue. I found on the Vanilla community forums that there was an Apache update for BlueHost that requires a change in the .htaccess file in the Vanilla install directory:

Please Login or Register to see this Hidden Content


should be edited to

Please Login or Register to see this Hidden Content



I'm not with Bluehost, but editing the .htaccess file fixed this on my host, so perhaps they too rolled out a similar update which requires a more direct path?

However I updated Vanilla before the v2.3.5 update was available and everything was working smoothly, so either updating to v2.3.5 freaked it out, my webhost's Apache update changed something, or there's something else I broke somewhere.

#9 Danny

Danny

    Is Awesome!

  • Moderators
  • 17532 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 23 November 2012 - 01:44 PM

Hi,

Is this issue now resolved ?

#10 carl007

carl007

    Advanced Member

  • Members
  • 37 posts
  • Country: Country Flag

Posted 30 January 2013 - 12:20 AM

I had the same problem, followed the instruction on Vanilla forum to fix the issue by changing some details on the .htacces file but i was unsuccessful. I have to reinstall the forum and start afresh.



#11 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 30 January 2013 - 12:35 AM

Carl,

 

Thank you for letting us know.

 

If you need additional assistance, please open a new topic.