Jump to content


Photo
- - - - -

Iblog Pro 5 Menu Issues


  • Please log in to reply
6 replies to this topic

#1 hireconrad

hireconrad

    Super Member

  • Members
  • 155 posts
  • Country: Country Flag

Posted 03 November 2012 - 11:06 PM

Hi,
i have a few questions regarding the menu:

1) since updating the iblog pro theme, the text of the menu bar fades in from the top (some kind of effect) (as seen when using Safari or Chrome, not Firefox).. How do I disable this?

Solution:

#page .main_nav {
-webkit-animation:showMenu 0s;

Regarding the child menu items under "Listings"

2) when you click on one of the child links, the top level Listing Button is a light grey colour. ( i want this to look dark like when you visit any of the other pages on my site)
I believe this is due to the fact that the parent button (listings) is not considered "current-menu-item"
How do i resolve this?

3) child menu items do not react to mouse hover like my other buttons do. How can I fix this?
4) whats the best way to make the Listings Button just drop down the child pages? I dont want people getting confused thinking that the Listings Button actually takes you to a separate page. I want it to function as a button to show the child menu buttons.
5) is there a way to have the child menu buttons display in an animated way rather then just pop out all at once?



*** I am using firebug to try and figure this out. I have been using it exclusively trying to fix the theme, and have already added a lot of custom css into pagelines customize to make the site look the way i want

#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 04 November 2012 - 12:10 AM

Hi,

1. The easiest fix is to replace the menu in Dashboard > PageLines > Drag & Drop > Header from NavBar to Nav Classic. The latter has no gradient effect.

2. The Nav Classic works with Simple CSS Lite plugin, available in our store, free, which allows you to set colors for backgrounds, hover effects, etc. This plugin only works with Nav Classic, not NavBar.

3. This problem is resolved by the change to Nav Classic. NavBar uses Twitter Bootstrap, which is not used in Nav Classic, fixing issues of static parent level links, link backgrounds, etc.

4. Create the button/link without an href link by placing # in the URL field in a Custom Link created in Dashboard > Appearance > Menus > Custom Links.

5. I don't think it's easy, but certainly not impossible to create some kind of animation with CSS. Unfortunately, that's a customization that would require a Pro.

Hope these answers helped.

#3 hireconrad

hireconrad

    Super Member

  • Members
  • 155 posts
  • Country: Country Flag

Posted 04 November 2012 - 12:20 AM

I am already using Nav Classic, so your solution for 1 doesn't apply. I dont have an issue with the gradient effect of the Nav bar, i have an issue with the animation (as seen when using Safari or Chrome, not Firefox).

I have tried Simple CSS Lite Plugin, however using it has caused additional problems: when I set the "Background Color of Active Menu Item" I loose the gradient that is normally found originally on active pages.
I have selected a colour for "Background Color of Menu Items on Hover" and the child buttons in "Listings" dont react to mouse hover…. i.e. not working.

#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 04 November 2012 - 01:13 AM

If the site you're talking about is:

Please Login or Register to see this Hidden Content

then that's NavBar (default with iBlog5), not Nav Classic. Additionally, Nav Classic does not have any gradient in the background, so it's impossible to have a gradient and Nav Classic at the same time by default.

Please provide a screenshot of the Active Sections in Dashboard > PageLines > Drag & Drop > Header.

#5 hireconrad

hireconrad

    Super Member

  • Members
  • 155 posts
  • Country: Country Flag

Posted 04 November 2012 - 01:18 AM

Posted Image

Nav classic and I have the gradient on my bar.

#6 hireconrad

hireconrad

    Super Member

  • Members
  • 155 posts
  • Country: Country Flag

Posted 04 November 2012 - 03:21 AM

i figured out all my issues (except for how to animate the child buttons)

#7 Danny

Danny

    Is Awesome!

  • Moderators
  • 15215 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 04 November 2012 - 12:31 PM

Hi,

Not sure what you mean by animate the child theme buttons ?

Can you provide more information please.