Archived

This topic is now archived and is closed to further replies.

  • 0

Resolved Category Templates & Customise Homepage

Question

Posted · Report post

I'm new to pagelines and am trying to figure out of this is possible:

1. Is it possible to have different categories (e.g. ?cat=15) governed by different templates? I want each category to have its own look and feel but as far as I can tell there is only one meta for categories pages.

2. Is there a way to pull posts into a page? For example using a shortcode. I want to be able to pull blog posts into my static homepage

Thanks

Share this post


Link to post
Share on other sites

8 answers to this question

Posted · Report post

Sorry, I am not clear on this as it is not working.

  1. I created a static page (homepage) and selected a template (5) and made some adjustments.
  2. I created another static page (blog) and selected a template (4) and made some adjustments. I'm not sure what is meant by nothing in the field. Does this mean no page content?
  3. am Changed Reading settings to static page - frontpage=homepage, posts page=blog

Am I doing something wrong? All I see on the homepage is the static homepage.

Share this post


Link to post
Share on other sites

Posted · Report post

I'm getting somewhere slowly with question 2.

As far as I can tell if I use the solution above the homepage meta comes from the blog posts meta - i.e. I cannot have the homepage configured uniquely without it copying the standard blog template. Is this correct?

Question 1 remains an issue. In fact it is related to above. Is it possible to have different categories (e.g. ?cat=15) governed by different templates?

Share this post


Link to post
Share on other sites

Posted · Report post

here is an image to illustrate the problem. All my homepage meta settings are been ignored in favour of the generic blog page template.

I need to be able to keep individual page meta.

Is this a bug?

blogpage.PNG

Share this post


Link to post
Share on other sites

Posted · Report post

Please try deactivating all active plugins to see if the problem persists.

Share this post


Link to post
Share on other sites

Posted · Report post

I think I figured out out. When I republished the page the issue went away.

I installed Anything Boxes to get the posts in a page functionality.

Share this post


Link to post
Share on other sites

Posted · Report post

Okay, awesome.

Share this post


Link to post
Share on other sites

Posted · Report post

The topic was marked as resolved.

Share this post


Link to post
Share on other sites