Jump to content


Photo
Resolved

Background



This topic has been archived. This means that you cannot reply to this topic.
40 replies to this topic

#1 iems

iems

    Advanced Member

  • Members
  • PipPipPip
  • 58 posts

Posted 02 November 2012 - 02:20 AM

Forgive me if I've already asked this as I am still searching to no avail - the following code...

#site .content, #footer .content { background: rgba(0, 0, 0, 0.5); }

How do I enable this in IE8?

Thank you.

#2 James B

James B

    Advocate

  • Members

  • 5126 posts

Posted 02 November 2012 - 03:07 AM

Hi there, in IE8 you'll need to use a solid color as it doesn't support transparencies. A solid color like #dddddd etc, otherwise save a transparent png in an image editor and apply as a bg.

#3 iems

iems

    Advanced Member

  • Members
  • PipPipPip
  • 58 posts

Posted 02 November 2012 - 03:29 AM

So for IE8 only, what do I need to add to set the background to solid and leave it transparant for IE9?

#4 James B

James B

    Advocate

  • Members

  • 5126 posts

Posted 02 November 2012 - 04:08 AM

You'd need to look into some form of browser specific css, as far as I'm aware there's no way you can target IE8 separately though.

http://www.impressiv...-ie8-css-hacks/

#5 iems

iems

    Advanced Member

  • Members
  • PipPipPip
  • 58 posts

Posted 02 November 2012 - 12:30 PM

ok....

#6 catrina

catrina

    Advocate

  • Members
  • 12345 posts

Posted 02 November 2012 - 02:53 PM

Do you need further assistance with this or have you figured it out?

#7 iems

iems

    Advanced Member

  • Members
  • PipPipPip
  • 58 posts

Posted 02 November 2012 - 04:22 PM

I've done a search, and still cannot find the css hack to set the background to solid in IE8 only and still allow it to be semi-transparant in all other browsers. It is for ccbsi.com

#8 catrina

catrina

    Advocate

  • Members
  • 12345 posts

Posted 02 November 2012 - 05:08 PM

For IE8-specific CSS, try adding the CSS inside this code:

 <!--[if gte IE 8]>
<style>
(your style here)
</style>
<![endif]-->


#9 iems

iems

    Advanced Member

  • Members
  • PipPipPip
  • 58 posts

Posted 02 November 2012 - 06:14 PM

<p><!--[if gte IE 8]><style>#site .content {background: #000000} </style><![endif]-->

This turns the screen white with a black box in the middle. What did I miss?

#10 Danny

Danny

    Is Awesome!

  • Moderators
  • 17945 posts

Posted 04 November 2012 - 12:07 PM

Hi,

Please use our free plugin Browser Specific CSS and use this to add CSS that will only work for IE8.

#11 iems

iems

    Advanced Member

  • Members
  • PipPipPip
  • 58 posts

Posted 05 November 2012 - 07:35 PM

Danny, I've installed the plug. Thank you for this info. Dumb question (sorry to ask), what do I do with it? In other words, how do I impliment what I am wanting to do - set the background to solid when I've already implimented a css hack for transparant everywhere else in the custom code section of PageLines?

Also, I am looking for a CSS hack to enable font-smoothing. Specifically for non-IE browsers. I don't suppose you have a resource for that do you?

Thank you in advance.

#12 iems

iems

    Advanced Member

  • Members
  • PipPipPip
  • 58 posts

Posted 05 November 2012 - 07:48 PM

Ok - panic mode. I just tried to add the custom code above and I'm getting a parse error. The admin screen in white and I cannot get to anything to change it back. Undo?
It's the same issue as here - http://www.pagelines...-compile-error/
I cannot get back to the screen to under the css I just added. How do I fix?

#13 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts

Posted 05 November 2012 - 07:50 PM

Ok - panic mode. I just tried to add the custom code above and I'm getting a parse error. The admin screen in white and I cannot get to anything to change it back. Undo?

Where did you add the code?

#14 iems

iems

    Advanced Member

  • Members
  • PipPipPip
  • 58 posts

Posted 05 November 2012 - 07:58 PM

custom css

#15 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts

Posted 05 November 2012 - 08:07 PM

What code did you add exactly?

#16 iems

iems

    Advanced Member

  • Members
  • PipPipPip
  • 58 posts

Posted 05 November 2012 - 08:11 PM

<!--[if gte IE 8]>
<style>
(background: #dddddd)
</style>
<![endif]-->


I think. My site is hosted with GoDaddy. I can get to the files via their ftp. How do I know which css file I need to edit like the other guy did?

#17 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts

Posted 05 November 2012 - 08:22 PM

Right yea, you cant add that kind of stuff to customcss, next version strips all that stuff out, as it breaks the backend as you can see ;)

Anyway, super easy fix:

In FTP create a new folder, wp-content/mu-plugins/
create a file in there and paste this into the file:
 <?phpadd_action( &#39;admin_init&#39;, function() { plupop( &#39;customcss&#39;, &#39;&#39; ); } );?>

then load wp-admin a couple of times, it will clear the custom css, then delete the file again, or it will keep deleting it ;)

Next install the (free) base theme, its a blank child theme, add your quirky css to the style.css in there and activate the child theme.

#18 iems

iems

    Advanced Member

  • Members
  • PipPipPip
  • 58 posts

Posted 05 November 2012 - 08:46 PM

Oof - it wasn't working. I tried a simple restore of files as they were earlier this week....still panicking

#19 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts

Posted 05 November 2012 - 08:51 PM

Restoring files wont make a difference, the option is stored in the database, just follow the simple instructions above ^^

#20 iems

iems

    Advanced Member

  • Members
  • PipPipPip
  • 58 posts

Posted 05 November 2012 - 08:55 PM

From the wordpress forum "
Ok, I figured it out. All this data is stored it database, I found the code there and deleted the section that produced the error. Now everything's working fine again."
Where is the database in the ftp folder and what file do I need to modify as restore hasn't resolved the issue yet?