Archived

This topic is now archived and is closed to further replies.

  • 0

Unable To Upgrade Past 2.2.5

Question

Posted · Report post

Hi,

I'm currently running 2.2.5 - I've not been able to update to the more recent editions because it breaks the site, (all page structure vanishes and I'm just left with a long list of text).

I'm just wondering what steps I need to take to try and stop this from happening, (I'm not a developer!), as I want to keep up to date with Pagelines, but I'm unable to at the moment.

What information can I provide so that I can get some help with this? FYI, the site is an intranet so I can't provide you with access to it.

Many thanks

Share this post


Link to post
Share on other sites

26 answers to this question

Posted · Report post

Right well thats the css, go to pagelines advanced, enabled the debug option, then reload that css url, scroll right to the bottom, should be a comment about memory.

Would that be:


CSS was compiled at Tue, 30 Oct 12 07:29:43 +0000 and took 0.84711 seconds using 53.26MB of unicorn dust.

Share this post


Link to post
Share on other sites

Posted · Report post

So sorry it's taken me so long to get back to you on this.

 

How does one enable the CSS file mode? I'm not sure what you mean by that?

 

Uploads is already CHMOD 777 and owned by Apache and I added that line to the wp-config but still nothing I'm afraid...

 

Also just tried upgrading to 2.3.7 but still nothing - formatting of the page goes wonky :(

Share this post


Link to post
Share on other sites

Posted · Report post

So its only the ie users affected?

could be compatibility mode.

 

 

Add to the headerscripts area: <meta http-equiv="X-UA-Compatible" content="IE=edge" />

Share this post


Link to post
Share on other sites

Posted · Report post

Add to the headerscripts area: <meta http-equiv="X-UA-Compatible" content="IE=edge" />

 

Thanks Simon... where do I go to find the headerscripts area?

Share this post


Link to post
Share on other sites

Posted · Report post

pagelines settings.. custom code

Share this post


Link to post
Share on other sites

Posted · Report post

*sigh*

Still not working I'm afraid...

Share this post


Link to post
Share on other sites

Posted · Report post

If you added the define for no dynamic urls ( page 1 ) and when you view the source of the page, the css url is something like http://myhostname/?pageless=1 and IE9 atill does not load it, the only thing i can think of is either:

 

IE security restrictions is blocking it.

IE compatibility mode is on.

 

The file mode will never work as you have opted to run php as user apache, so you can forget that.

 

Unfortunately debugging someone elses LAN setup is impossible, we could go on until doomsday suggesting stuff.

 

My best advice, setup the linux box properly, running php as user apache is not a good idea anyway, as all the files have to be owned by apache, not the user.

Depending on the linux type, checkout suPHP, mod_itk, mod_fcgid all those run php as the user not apache.

 

Best of luck.

Share this post


Link to post
Share on other sites

Posted · Report post

After you enabled debug, there will be a "more info" link on the right. Can you paste what's at that link?

Share this post


Link to post
Share on other sites

Posted · Report post

This is a localhost dev site is it? with 67 active plugins?!? Do you really need all of them?

What OS is it? windows? osx? Your server is running with the username 'apache', guessing thats not your name ;) So all the files will have to be read/write to the user apache. If your using osx, use MAMP and run the server as your own username, then you wont get these stupid file permission errors.

I've knocked a few of the plugins away. We use the site as an Intranet. It's run on Red Hat and is accessed by users of OS X, Win XP and Win 7.

It's the Windows 7 users, (explorer 9), that are having the problem. It's absolutely fine, and then as soon as I hit upgrade, it all goes to cock. (Thankfully we have Veamm so I can roll back instantly)... The apache username is just left as it is. As I said, I'm no developer, but it's ran fine like this for the past couple of years...

Share this post


Link to post
Share on other sites

Posted · Report post

Only thing i can think of the is to enable the css file mode, make sure the uploads dir is chmod 777, and owned by apache, the add this to wp-config.php

define( 'LESS_FILE_MODE', true );

Share this post


Link to post
Share on other sites

Posted · Report post

Hmmm... So I completely removed the theme from my Wordpress installation and re-installed the latest Framework, and it all worked with no bother on Safari, but IE 9 still not playing? All Custom CSS and plugins have been deactivated...

Share this post


Link to post
Share on other sites

Posted · Report post

Sometimes it can break your install if you have a child theme and you don't update both the theme and the framework. Best bet is to disable all plugins, make a backup, and then update. This can help ensure a successful transition.

Share this post


Link to post
Share on other sites

Posted · Report post

Sometimes it can break your install if you have a child theme and you don't update both the theme and the framework. Best bet is to disable all plugins, make a backup, and then update. This can help ensure a successful transition.

Thanks Anthony. I am not using child themes though, (I don't think). I've disabled all plugins, backed up and upgraded, but IE just won't render correctly... It's as if the CSS just isn't there?

Share this post


Link to post
Share on other sites

Posted · Report post

To check if you are using a child theme, go to Appearance > Themes and look at the theme that's activated.

Share this post


Link to post
Share on other sites

Posted · Report post

Pagelines Framework, (So I'm assuming I don't have a child theme activated?)

Share this post


Link to post
Share on other sites

Posted · Report post

Is your private url a LAN url or you just dont want it public? Only moderators can see it to try and help you.

Share this post


Link to post
Share on other sites

Posted · Report post

It's a LAN URL, which is a pain, I know...

Share this post


Link to post
Share on other sites

Posted · Report post

Well its probably a permalink issue.

Add to wp-config.php:


define( 'PL_NO_DYNAMIC_URL', true );
[/CODE]

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks Simon, the situation remains I'm afraid - is there perhaps something I can put on here to show you? Code of some sort?

Share this post


Link to post
Share on other sites

Posted · Report post

Ok, so what do you get if you go to http://yoururl/?pageless=1

Quite a lot of code, too much to post on here apparently... :-/

Share this post


Link to post
Share on other sites

Posted · Report post

Right well thats the css, go to pagelines advanced, enabled the debug option, then reload that css url, scroll right to the bottom, should be a comment about memory.

Share this post


Link to post
Share on other sites

Posted · Report post

Gosh, thanks all for your help so far!

Jenny, the info given at that link:

WordPress Version : 3.4.2

Multisite Enabled : No

Current Role : Administrator

Framework Path : /var/www/html/intranet/wp-content/themes/pagelines

Framework URI : http://motion/intran...hemes/pagelines

Framework Version : 2.3.5

Framework Build : 2.3.5

PHP Version : 5.3

Mysql version : 5.0.95

PHP type : Apache2handler

PHP User : Apache

OS : Linux

Launchpad : Logged in ( ianrob84 )

Licence : Pro

Plugins : 67

admin-menu-editor/menu-editor.php

auto-post-thumbnail/auto-post-thumbnail.php

bbpress-integration/bbpress-integration.php

bbpress/bbpress.php

blog-in-blog/blog-in-blog.php

category-posts-widget/widget_cat_posts.php

category-posts/cat-posts.php

co-authors/co-authors.php

comment-reply-notification/comment-reply-notification.php

configure-login-timeout/configure-login-timeout.php

csv-user-import/csv-user-import.php

customize-meta-widget/customize-meta-widget.php

easy-iframe-loader/easy-iframe-loader.php

email-alerts/email-alerts.php

embedded-video-with-link/embedded-video.php

exclude-pages/exclude_pages.php

fcc-ribbon-manager/fcc_ribbon.php

flv-embed/flv-embed.php

formidable/formidable.php

fpw-category-thumbnails/fpw-category-thumbnails.php

generate-post-thumbnails/generate-post-thumbnails.php

get-the-image/get-the-image.php

global-admin-bar-hide-or-remove/global-admin-bar-hide-or-remove.php

ie9-mode/ie9-mode.php

indicate-fresh-post/ifp_plugin.php

insere-iframe/insereIframe.php

login-with-ajax/login-with-ajax.php

mappress-google-maps-for-wordpress/mappress.php

mingle-forum-guest-info/wpf-guestinfo.php

nextgen-gallery/nggallery.php

ninja-page-categories-and-tags/ninja_page_cats_tags.php

pagelines-bbpress/pagelines-bbpress.php

pagelines-customize/pagelines-customize.php

pagelines-sections/pagelines-sections.php

peters-login-redirect/wplogin_redirect.php

polldaddy/polldaddy.php

post-types-order/post-types-order.php

printfriendly/pf.php

quick-pagepost-redirect-plugin/page_post_redirect_plugin.php

simple-image-link/simple-image-link.php

simplemodal-login/simplemodal-login.php

smart-youtube/smartyoutube.php

special-recent-posts/special-recent-posts.php

stream-video-player/stream-video-player.php

strictly-autotags/strictlyautotags.class.php

subscribe2/subscribe2.php

substitute-displayname/substitute_displayname.php

thethe-tabs-and-accordions/thethe-tabs-n-accordions.php

top-10/top-10.php

twitter-for-wordpress/twitter.php

ultimate-category-excluder/ultimate-category-excluder.php

user-avatar/user-avatar.php

widgets-on-pages/widgets_on_pages.php

wordpresspdf/wp-pdf-view.php

wp-editor-fontsize/wp-editor-fontsize.php

wp-email-login/email-login.php

wp-flash-countdown/countdown.php

wp-hide-dashboard/wp-hide-dashboard.php

wp-jquery-lightbox/wp-jquery-lightbox.php

wp-pagenavi/wp-pagenavi.php

wp-password-generator/wp-password-generator.php

wp-popup-scheduler/wp-popup-scheduler.php

wp-print/wp-print.php

wpcat2tag-importer/wpcat2tag-importer.php

wptouch/wptouch.php

yd-recent-posts-widget/yd-recent-posts-widget.php

youtube-shortcode/youtube-shortcode.php

Thanks everyone for your help with this!

Share this post


Link to post
Share on other sites

Posted · Report post

And, FYI, it doesn't work even if I disable plugins and upgrade.

Share this post


Link to post
Share on other sites

Posted · Report post

Did you already check with your host to see if there are any problems there?

Share this post


Link to post
Share on other sites