Archived

This topic is now archived and is closed to further replies.

  • 0

Resolved Custom Code Error Simbol '>'

Question

Posted · Report post

I am having a problem with the new version of pagelines and I replaced the '>' by '>' and this makes me not run custom code for example:

. dropdown-menu li> a: hover,. dropdown-menu li> a: focus,. dropdown-submenu: hover> a,. dropdown-menu-menu-item li.current> a {

text-decoration: none;

color: # 828282; / * font color * /

background-color: # e6e6e6;

background-color: # e6e6e6;

background-image:-moz-linear-gradient (top, # e6e6e6, # e6e6e6);

background-image:-ms-linear-gradient (top, # e6e6e6, # e6e6e6);

background-image:-webkit-gradient (linear, 0 0,0 100%, from (# e6e6e6), to (# e6e6e6));

background-image:-webkit-linear-gradient (top, # e6e6e6, # e6e6e6);

background-image:-o-linear-gradient (top, # e6e6e6, # e6e6e6);

background-image: linear-gradient (top, # e6e6e6, # e6e6e6);

background-repeat: repeat-x;

filter: progid: DXImageTransform.Microsoft.gradient (startColorstr = '# e6e6e6', endColorstr = '# e6e6e6', GradientType = 0);

}

is replaced by:

. dropdown-menu li > a: hover,. dropdown-menu li > a: focus,. dropdown-submenu: hover > a,. dropdown-menu-menu-item li.current > a {

text-decoration: none;

color: # 828282; / * font color * /

background-color: # e6e6e6;

background-color: # e6e6e6;

background-image:-moz-linear-gradient (top, # e6e6e6, # e6e6e6);

background-image:-ms-linear-gradient (top, # e6e6e6, # e6e6e6);

background-image:-webkit-gradient (linear, 0 0,0 100%, from (# e6e6e6), to (# e6e6e6));

background-image:-webkit-linear-gradient (top, # e6e6e6, # e6e6e6);

background-image:-o-linear-gradient (top, # e6e6e6, # e6e6e6);

background-image: linear-gradient (top, # e6e6e6, # e6e6e6);

background-repeat: repeat-x;

filter: progid: DXImageTransform.Microsoft.gradient (startColorstr = '# e6e6e6', endColorstr = '# e6e6e6', GradientType = 0);

}

how i can resolve this problem?

Regards

Share this post


Link to post
Share on other sites

10 answers to this question

Posted · Report post

The topic was marked as resolved.

Share this post


Link to post
Share on other sites

Posted · Report post

Looks to me like a problem with your editor. What browser are you currently using?

Share this post


Link to post
Share on other sites

Posted · Report post

its happening in Firefox 16.0.2 , Chrome 22.0.1229.94 m and Ie9

When I load the site I replaced the> by > and then appear LESS errors :-(

Its happening since i updated the framework to last version 2.3.4

Regards

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

This is a issue with the editor and HTML code being added to the CSS/LESS editor as far as I am aware, doing the following should resolve your issue.

Change line 489 of class.render.css.php to this:


$custom = stripslashes( ploption( 'customcss' ) );
[/CODE]

Share this post


Link to post
Share on other sites

Posted · Report post

not run :-(

I put the code that showed up, I get this error

Custom PageLines LESS / CSS error.

Parse error: Failed at `a: hover, # site. dropdown-menu li> a: focus, # site. dropdown-submenu: hover> a, # site. dropdown-menu-menu-item li.current> a {` line: 1183

And then in the custom code changed out the '>' to '>' is weird because I use this code in more places and that never happened, happened since the upgrade framework

Share this post


Link to post
Share on other sites

Posted · Report post

Can anyone tell me which file. Lss o. I can find this style css to edit me directly?

Share this post


Link to post
Share on other sites

Posted · Report post

I had to fix it by installing the plugin my custom css, i dont understand why the custom css editor pagelines longer accepts certain styles, I hope for the following versions can be solved and to function as version 2.3.3

regards

Share this post


Link to post
Share on other sites

Posted · Report post

Do you need further assistance with anything else?

Share this post


Link to post
Share on other sites

Posted · Report post

Your css even with the fix would never compile. you have bad selectors ( . dropdown should be .dropdown ) and bad colors ( # 666 should be #666 )

Share this post


Link to post
Share on other sites

Posted · Report post

I will review the custom code

Thanks

Regards

Share this post


Link to post
Share on other sites