Archived

This topic is now archived and is closed to further replies.

  • 0

Changing squared thumbnails in carousel to landscape format ?

Question

Posted · Report post

Hi all, i would like to present my carousel pictures from nextgen gallery in the carousel of EcoPro as landscape shape and not as square ... at least not squeezed like they look now ... tried sevral ways, now way to change that :-( Any help ? Here: www.sascharoesner.de

Share this post


Link to post
Share on other sites

9 answers to this question

Posted · Report post

Hi cmunns, yes, in Gellery>Options>thumbnails I do have 150x100 pixels. No changes yet. Thank ya ! Sascha

Share this post


Link to post
Share on other sites

Posted · Report post

Okay we have to override the inline styling. Add this to your THEME OPTIONS > CUSTOM CODE > CUSTOM CSS ` .carouselcontainer ul li { width:100px !important; margin-bottom:30px; } .carouselcontainer ul li img { width: 90px; } .carouselcontainer .content {height:125px;overflow:hidden;} ` It may need some tweaking to get it right, but this is what I came up with

Share this post


Link to post
Share on other sites

Posted · Report post

I changed the carousel.css with the following settings: .carouselcontainer { width: 780px; position: relative; color: #ddd; font-size: 10px; padding: 30px 67px 25px; overflow: hidden; } .carouselcontainer ul li{ float: left; text-align: center; width: 100px; height: 72px; margin: 0 10px; position: relative; } .carouselcontainer ul li img { width: 100px; border: 1px solid #89AF5B; } However, no I van`t manage to set the right arrow outside the thumbnails ... is there a style which defines how many img/thumbs are shown ?! Thanks Sascha see: http://www.sascharoesner.de

Share this post


Link to post
Share on other sites

Posted · Report post

We are almost there and it looks great! If you edit init_carousel.php inside of the CORE > INITS folder then you can set the visible number of thumbs near the bottom of the code.

Share this post


Link to post
Share on other sites

Posted · Report post

This seems to break when updating with the latest version of EcoPro? How is this working with Platform Pro?

Share this post


Link to post
Share on other sites

Posted · Report post

inside of the theloop.php you'll see this line of code: `<?php the_post_thumbnail('thumbnail');?>` (line 15) If you change it to read something like this it should get you what you want. `<?php the_post_thumbnail( array(100,70) );?>` where 100 is 100px width and 70 is 70px height

Share this post


Link to post
Share on other sites

Posted · Report post

Hey cmunns, thanks for your help. But I couldn`t find "theloop.php" nor "loop.php" containing the code line you mentioned. Howver, in the template_carousel.php is a similar area which already contains these settings, I guess. Here: <a class="carousel_image_link" href="<?php echo get_permalink($rpost->ID); ?>"> <?php if(has_post_thumbnail()): ?> <?php the_post_thumbnail(array( 105, 70 ),array( 'class' => 'list_thumb list-thumb' ));?> <?php else: ?> <img class="list_thumb list-thumb" src="<?php echo CORE_IMAGES;?>/post-blank.jpg" width="105" height="70" class="sidebar_thumb" /> <?php endif;?> <span class="list-title"><?php echo $rpost->post_title; ?></span> </a> But doesn`t work out. Any other ideas/suggestions ?! Thank you so much ! Sascha

Share this post


Link to post
Share on other sites

Posted · Report post

chaka ! Here we go ! Thank you for the great and valuable support ! Sascha

Share this post


Link to post
Share on other sites

Posted · Report post

First of all I had a mental lapse and you were definitely modifying the correct file. Also, I didn't realize that you were using the NextGen Gallery which doesn't use the_post_thumbnail function. Did you go to the gallery options and set the thumbnail size etc? If you did that and are still having problems I'll take another look.

Share this post


Link to post
Share on other sites