Jump to content


Photo
- - - - -

iBlog Pro - Social Media Icons


This topic has been archived. This means that you cannot reply to this topic.
10 replies to this topic

#1 bethzimmerman

bethzimmerman

    Advanced Member

  • Members
  • 37 posts

Posted 11 August 2010 - 03:13 AM

I'd like the Social Media Icons to sit on the Nav Bar (rather than above it on the Header). Is it possible to do that through CSS?

Please Login or Register to see this Hidden Content



#2 bethzimmerman

bethzimmerman

    Advanced Member

  • Members
  • 37 posts

Posted 11 August 2010 - 03:44 AM

Another option that would be okay with me would be to have them stacked vertically (on top of where the rss feed button is now) at the fasr right hand side of the header. Thanks!

#3 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts

Posted 11 August 2010 - 04:24 PM

Your nav bar is looking wacky. Let's start with that. It looks to me like you recently upgraded to WP3.0. If that's the case you'll need to re-create the menu using WP3.0 menus panel. Then when that's fixed I'll take a look at getting those icons on the nav bar.

#4 bethzimmerman

bethzimmerman

    Advanced Member

  • Members
  • 37 posts

Posted 11 August 2010 - 05:13 PM

I JUST added the iBlog theme yesterday. LOVE it (except for my wacky navbar) so I had WP3 before I had iBlog. Not sure what you mean by recreate menu. What menu?

#5 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts

Posted 11 August 2010 - 05:21 PM

for some reason our themes require the re-creation of the menu using the new feature from WP3.0 It's actually very easy. You just need to create a menu in WP ADMIN > APPEARANCES > MENUS and assign it to the main_nav location.

#6 bethzimmerman

bethzimmerman

    Advanced Member

  • Members
  • 37 posts

Posted 11 August 2010 - 05:28 PM

I just figured that one out and did it! I had figured out the footer ones yesterday by searching forums! So much helpful info! I think I'm ready for moving the icons now but you can look and tell me if I did this (repairing the nav menu) correctly.

#7 bryan-hadaway

bryan-hadaway

    Advocate

  • Members
  • PipPipPipPipPip
  • 3697 posts

Posted 12 August 2010 - 12:39 AM

No, looks like you accidentally set all of the pages/tabs as subpages.

So back in:

Appearance > Menus

What you want to do is drag each tab slightly to the left, so it locks in to the left so they become top level pages. If that's already done, you're going to have to limit how many top level tabs/pages you have or it will never look right.

If you can manage to categorize (in your mind) any of the current pages as subpages that would be best, you should then drag the subpages under their parent page and indent them just to the right so it looks something like this:

- Parent
? ? ? - Sub
? ? ? - Sub

For the icons, the solution is pretty simple, from your Theme Options, add this to Custom Code > Custom CSS:

`
#header{z-index:2000}

#header .icons{
position:relative;
top:45px;
margin-right:5px;
z-index:1000}
`
Thanks, Bryan

#8 bethzimmerman

bethzimmerman

    Advanced Member

  • Members
  • 37 posts

Posted 12 August 2010 - 01:43 AM

Almost perfect. But it dropped the navbar leaving white space between navbar and header. Can I eliminate that?

#9 bethzimmerman

bethzimmerman

    Advanced Member

  • Members
  • 37 posts

Posted 12 August 2010 - 01:43 AM

Sorry. My comment posted twice.

#10 bethzimmerman

bethzimmerman

    Advanced Member

  • Members
  • 37 posts

Posted 12 August 2010 - 01:48 AM

Actually, I decided that since I need to limit the options in the NavBar I'd rather keep Search there and just leave the icons where they are. Thanks for helping me figure out the NavBar! I didn't even know it was screwy! :)

#11 bryan-hadaway

bryan-hadaway

    Advocate

  • Members
  • PipPipPipPipPip
  • 3697 posts

Posted 12 August 2010 - 03:48 AM

Looks good, a few pointers...

- If you want the header graphic to go all the way across it should be 960px wide

- If you want the dropdown menu to work, go to:

Theme Options > Header and Nav > Enable dropdown menus? - check that box and save

Thanks, Bryan