Jump to content


Photo
- - - - -
Resolved

Ssl Issue

sslhttps

  • Please log in to reply
21 replies to this topic

#1 jsharpe2001

jsharpe2001

    Member

  • Members
  • 21 posts
  • LocationBrooklyn, NY
  • Framework Version:2.4.4
  • Country: Country Flag

Posted 25 October 2012 - 02:43 PM

Hi folks,

I've read through the other posts in this forum referencing SSL issues and can't resolve. Any thoughts on the following error:

I have my site at sustainablesummer.org setup to force HTTPS and SSL only on certain pages. I have been using Google Chrome Developer Tools to diagnose and I'm getting these errors:

[blocked] The page at

Please Login or Register to see this Hidden Content

ran insecure content from

Please Login or Register to see this Hidden Content

.

[blocked] The page at

Please Login or Register to see this Hidden Content

ran insecure content from

Please Login or Register to see this Hidden Content

.

The pages in question are sustainablesummer.org/apply/ and sustainablesummer.org/apply/apply-now/

Despite the errors, the pages are secure in Google Chrome, but not in Safari or Firefox (haven't tested any other browsers yet).

I am able to get a secure connection on my /login/ and /admin/ pages in Safari and Firefox.

I added this function provided by Simon in a previous post to get Chrome working:

// this function forces ssl
add_filter( 'pless_vars', 'make_ssl_vars' );
add_action( 'pl_force_ssl', '__return_true' );

function make_ssl_vars( $vars ) {

$vars['plSectionsRoot'] = str_replace( 'http://', 'https://' $vars['plSectionsRoot'] );
$vars['plRoot'] = str_replace( 'http://', 'https://' $vars['plRoot'] );
return $vars;
}

However, when I did this it made most pages in my admin back-end, which were previously secure, not secured.

Relevant plugins are: Better WP Security and Simple 301 Redirects

Any thoughts on solutions?

Thanks!

Jeff

#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 25 October 2012 - 02:56 PM

Can you please try deactivating all other active plugins to see if the issue persists?

#3 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 25 October 2012 - 03:42 PM

This is the problem when you use a plugin to 'fake' an SSL page in wordpress. The framework uses the native enqueue system for styles and scripts, so as far as wordpress knows its non-ssl so just loads the scripts http:// You might try googling around or even asking the plugin author if there is a filter to change all enqueued scripts/styles on your 'SSL' page.

#4 jsharpe2001

jsharpe2001

    Member

  • Members
  • 21 posts
  • LocationBrooklyn, NY
  • Framework Version:2.4.4
  • Country: Country Flag

Posted 25 October 2012 - 03:43 PM

Thanks Catrina. I deactivated and the errors disappeared. Upon reactivation, there's also no sign of the errors when I open in Chrome even though I'm still using all the same plugins. Which is good, I suppose. However, the site is still only partically encrypted in other browsers. I thought this might be due to a caching issue, but I tried from another computer and wiped the browsers history and receive the partially enrcrypted warning in Firefox. When I open the pages in question in Firefox and Safari, the secure padlock icon appears briefly and then disappears. I don't know if this is a Pagelines issue or something else entirely. Any further thoughts?

#5 jsharpe2001

jsharpe2001

    Member

  • Members
  • 21 posts
  • LocationBrooklyn, NY
  • Framework Version:2.4.4
  • Country: Country Flag

Posted 25 October 2012 - 03:51 PM

Thanks Simon. Even when I turn off the plugins that are forcing SSL on a page and instead set the site to https for all pages in the wordpress general settings, I still get the partially encrypted errors.

#6 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 25 October 2012 - 03:56 PM

View the page source now and search for http:// every one is either an image in your content or internal links, all scripts and css is now ssl because wordpress is ssl.

#7 jsharpe2001

jsharpe2001

    Member

  • Members
  • 21 posts
  • LocationBrooklyn, NY
  • Framework Version:2.4.4
  • Country: Country Flag

Posted 25 October 2012 - 04:12 PM

There are 2 http:// links that I can't seem to get rid of. One is in my Google analytics tracking code and the other is this very strange link:

Please Login or Register to see this Hidden Content

I have no idea what the latter is and it seems like the Analytics code shouldn't be an issue. Any ideas? Thanks so much for your help with this!

#8 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 25 October 2012 - 04:29 PM

The xfn link is a wordpress link, there is a fllter/action you can use to turn it off.

#9 jsharpe2001

jsharpe2001

    Member

  • Members
  • 21 posts
  • LocationBrooklyn, NY
  • Framework Version:2.4.4
  • Country: Country Flag

Posted 25 October 2012 - 05:03 PM

From some research on the xfn link, it sounds like this would not cause an SSL error. I can't seem to get this resolved, but it doesn't look like it's a Pagelines issue. Thanks for your help.

#10 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 25 October 2012 - 05:32 PM

Have you already checked with your host?

#11 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 25 October 2012 - 05:37 PM

Please Login or Register to see this Hidden Content



#12 jsharpe2001

jsharpe2001

    Member

  • Members
  • 21 posts
  • LocationBrooklyn, NY
  • Framework Version:2.4.4
  • Country: Country Flag

Posted 25 October 2012 - 05:40 PM

Hi Catrina, It occured to me after my initial post that I should probably check with my host first. So, hopefully I can resolve through them. Thanks for the help.

#13 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 25 October 2012 - 06:54 PM

Let us know what happens!

#14 jsharpe2001

jsharpe2001

    Member

  • Members
  • 21 posts
  • LocationBrooklyn, NY
  • Framework Version:2.4.4
  • Country: Country Flag

Posted 26 October 2012 - 03:29 PM

My host is saying there's unsecured content on the page. I checked Google Chrome again and I am still getting this error:

Please Login or Register to see this Hidden Content

ran insecure content from

Please Login or Register to see this Hidden Content

.

When I view the source code there are no links to images or files via the http protocol. Everything is https. Any thoughts on how to resolve? I suppose a better question is:

What is best practice for SSL in wordpress if I want to run just a couple of pages in HTTPS? Should I be modifying .htaccess? Something like this:

RewriteRule ^page1(.*)

Please Login or Register to see this Hidden Content

{SERVER_NAME}/page1$1 [R,L]

#15 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 26 October 2012 - 03:41 PM

Did you purchase an SSL certificate from your host? Usually when one needs SSL protection, a certificate needs to be purchased.

#16 jsharpe2001

jsharpe2001

    Member

  • Members
  • 21 posts
  • LocationBrooklyn, NY
  • Framework Version:2.4.4
  • Country: Country Flag

Posted 26 October 2012 - 03:49 PM

Of course! I have the certificate and I'm able to use the https protocol on all pages. No problems there whatsoever. The issue is with "partial encryption" on the pages that I want to open in https. For instance,

Please Login or Register to see this Hidden Content

I get an error that I am running insecure content from a pagelines theme stylesheet. I either need to figure out how to make that stylesheet a relative link so it opens in https or force it to https. I don't know what the best practice is for this process. I have read through dozens of forums trying to find an answer to this question and still don't know what to do. Thanks for your help!

#17 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 26 October 2012 - 10:57 PM

Let us know if this is resolved.

#18 jsharpe2001

jsharpe2001

    Member

  • Members
  • 21 posts
  • LocationBrooklyn, NY
  • Framework Version:2.4.4
  • Country: Country Flag

Posted 27 October 2012 - 12:25 PM

Still unresolved. The issues I'm experiencing are very similar to the ones described in this post:

Please Login or Register to see this Hidden Content



This file directory is the problem:
wp-content/themes/pagelines/images/
It always opens in http://, even when I disable all plugins and run the entire site in https. Maybe there's something in my Pagelines settings that's causing this issue?

#19 Danny

Danny

    Is Awesome!

  • Moderators
  • 15269 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 28 October 2012 - 10:09 AM

Hi,

Have you read this topic here, it may assist you.

Please Login or Register to see this Hidden Content



#20 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 28 October 2012 - 01:16 PM

There is no http:// links on this page

Please Login or Register to see this Hidden Content







Also tagged with one or more of these keywords: Resolved, sslhttps