Jump to content


Photo
- - - - -

Sermon Manager Template Issues

plugin templates

  • Please log in to reply
7 replies to this topic

#1 mossalot

mossalot

    Newbie

  • Members
  • 3 posts
  • Framework Version:2.3.3
  • Country: Country Flag

Posted 24 October 2012 - 04:35 PM

I am trying to use the plugin "Sermon Manager" with Pagelines, but Pagelines does not know how to template the new sermons being created. It is adding the page info above all template info and then it is putting the default template below that. Pagelines is also randomly creating new templates when new sermons are created. What can I do to get this plugin working with pagelines? Url of the problem:

Please Login or Register to see this Hidden Content



I've also attached pictures of the sermon page and the extra templates being created.

Attached Files



#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 24 October 2012 - 04:51 PM

Please try deactivating all other active plugins.

#3 mossalot

mossalot

    Newbie

  • Members
  • 3 posts
  • Framework Version:2.3.3
  • Country: Country Flag

Posted 24 October 2012 - 05:00 PM

When everything is deactivated except sermon manager the problem is still the same. Once sermon manager is deactivated the sermon disappears and the home page content shows.

#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 24 October 2012 - 11:12 PM

I have to admit a lack of knowledge about Sermon Manager, but it looks like hell on your site (pun intended).

I'm noticing however, that shortcodes have been placed in your Pricing page in visual mode, which doesn't work (usually). I can't say how you put this together, but let's see what we can come up with.

What template are you using for the page(s)? In Drag & Drop under Page Templates, what's in the template? Is "Content" there? And in the corresponding templates (Default, same one as in Page Templates and Blog Page, among others) do you still have PostLoop in Content Area?

After installing it and placing the shortcodes on a static page and saving, did you also update the Permalinks?

#5 mossalot

mossalot

    Newbie

  • Members
  • 3 posts
  • Framework Version:2.3.3
  • Country: Country Flag

Posted 25 October 2012 - 12:40 AM

Some of plugins being used for the shortcodes on the pricing page were deactivated. So that was causing it to look like..well to look like I used visual mode.

As far as pages. To my knowledge, I do not choose a template for the sermon manager pages. It looks like the plugin is automatically creating or applying some sort of template as I create sermons. I use a side administrative menu (picture below) to create each sermon.

All pages still have the PostLoop inside of the content area.

When I first created a sermon the sermon linked to a 404. So I put permalinks back to default and then saved them back to "Post Name". After that change the sermons linked to an actual page, but I was left with the mess you now see:

Please Login or Register to see this Hidden Content

Attached Files



#6 James B

James B

    Advocate

  • Moderators
  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 25 October 2012 - 01:59 AM

Hi there, it does look as if it's creating a custom template. But its then placing the content above the main page template, so I'm not sure what's happening there. I think you'll need to speak to the plugin author to see if he can advise how he's set up the plugin, then we can try and see if there's a way to make it work better inside the Framework. I see they have a support forum here

Please Login or Register to see this Hidden Content



#7 bartlewis

bartlewis

    Newbie

  • Members
  • 2 posts
  • Framework Version:2.3.7
  • Country: Country Flag

Posted 06 December 2012 - 08:16 PM

What was the solution for this issue?  Trying to set it up and am getting the same problem.  I see on his test site though he has it resolved.

 

Thanks



#8 James B

James B

    Advocate

  • Moderators
  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 07 December 2012 - 01:14 AM

Hi there, from what I can remember the client contacted the plugin author and they issued a code to fix.







Also tagged with one or more of these keywords: plugin, templates