Jump to content


Photo
Resolved

Pagelines Not Working Locally Using Mamp



This topic has been archived. This means that you cannot reply to this topic.
16 replies to this topic

#1 embussy

embussy

    Member

  • Members
  • PipPip
  • 10 posts

Posted 22 October 2012 - 05:42 AM

I just found out about PL and downloaded the lite version to trial before getting the developers version but it doesn't seem to load the css.
All text is aligned left in Times font with no images except the PL logo.
I'm using MAMP pro to develop locally, never had a problem with a theme before so this is a mystery
When I click 'Customize' the theme in wordpress it tells me 'Sorry preview is disabled, enable PageLines Framework'

I used a clean install of WP with no plugins

Any ideas, am I being stupid and missing something basic?

#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 17139 posts

Posted 22 October 2012 - 08:29 AM

Hi,

I have about 50 installations of PageLines lite and Dev working on MAMP locally for testing purposes. Therefore, can you provide a list of your settings and version of MAMP. When we have this information, we will be able to assist you further.

#3 embussy

embussy

    Member

  • Members
  • PipPip
  • 10 posts

Posted 22 October 2012 - 08:46 AM

Hi Danny, I'm using MAMP PRO 2.1.1
I've only just started using MAMP so I'm not sure what you need to know

#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 17139 posts

Posted 22 October 2012 - 10:34 AM

If you're new to MAMP, have you configured the application correctly and read the Wordpress codex article on how to setup Wordpress with MAMP?

http://codex.wordpre...r_Mac_With_MAMP

#5 embussy

embussy

    Member

  • Members
  • PipPip
  • 10 posts

Posted 23 October 2012 - 05:41 AM

My MAMP IS configured exactly as it sets out in that page. I tried deleting it and setting it up again and also tried another mac but they both show the same thing.

#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 17139 posts

Posted 23 October 2012 - 08:31 AM

Hi,

Preview does not work with PageLines Framework as it is not possible to load the Compiled CSS.

To resolve your CSS issue can you add the following code to your wp-config.php please.

 define( 'PL_NO_DYNAMIC_URL', true )


#7 embussy

embussy

    Member

  • Members
  • PipPip
  • 10 posts

Posted 23 October 2012 - 10:25 AM

I added it to the wp-config.php but I still get this
I have 4 sites I'm working on with 3 themes that all work fine except this one

#8 embussy

embussy

    Member

  • Members
  • PipPip
  • 10 posts

Posted 23 October 2012 - 10:31 AM

Posted Image

#9 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts

Posted 23 October 2012 - 11:12 AM

Assuming your local url is http://localhost/ try going to http://localhost/?pageless=1 and see what happens.

#10 embussy

embussy

    Member

  • Members
  • PipPip
  • 10 posts

Posted 23 October 2012 - 11:19 AM

I get a huge list of text that starts like this...
html,
body,
div,
span,
applet,
object,
iframe,
h1,
h2,
h3,
h4,
h5,
h6,
p,
blockquote,
pre,
a,
abbr,
acronym,
address,
big,
cite,
code,
del,
dfn,
em,

#11 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts

Posted 23 October 2012 - 11:22 AM

OK, go into pagelines settings, go to advanced, and enable debug. Then visit that url again and copy/paste to http://paste.pagelines.com also vew-source of your page and paste that too.

#12 embussy

embussy

    Member

  • Members
  • PipPip
  • 10 posts

Posted 23 October 2012 - 10:55 PM

Hi, I don't get the option in 'Advanced' to enable dubug.
Have pasted the source code and jpg of site in Firefox

#13 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts

Posted 23 October 2012 - 10:58 PM

Oh right, well paste the whole of that css url anyway, i want to see if all the css is being made.

#14 embussy

embussy

    Member

  • Members
  • PipPip
  • 10 posts

Posted 23 October 2012 - 11:10 PM

I just pasted the one I think you're after, not exactly sure how to access the css url

#15 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts

Posted 23 October 2012 - 11:17 PM

Yea its not a complete file by the looks of it.

MAMP has a default of 32M of memory, and its probably maxing out.

Things to try:

1. Make sure you have php 5.4 selected, it uses way les memory.
2. edit the config file: http://screencast.com/t/rXSTJ0JP line 233, change the memory limit to 64 or 128 then restart MAMP

#16 embussy

embussy

    Member

  • Members
  • PipPip
  • 10 posts

Posted 23 October 2012 - 11:44 PM

BRILLIANT!!! Thank you Simon its all working perfectly, I'll buy the developers package now :-)

#17 James B

James B

    Advocate

  • Members

  • 5126 posts

Posted 24 October 2012 - 12:33 AM

The topic was marked as resolved.