Archived

This topic is now archived and is closed to further replies.

  • 0

Resolved Morefoot Right Widget Displaying Incorrectly On Phone Device

Question

Posted · Report post

Hi,

I recently added some widgets to the Morefoot area of my blog - www.absolutelymerle.com

The Problem

I have widgets in Morefoot Left, Morefoot Middle and Morefoot Right. Everything displays fine on a computer, but when I brought up the website on my iPhone, the text widget (labelled "Disclaimer") in Morefoot right is cut off down the middle - the right half of the text (and the widget border is missing).

I do not own an android, so I have no idea how it displays on other phone devices.

Background Info

In my layout settings I use the following options for my site: "Static with Pixel Width" and "Fixed-width Mode".

When setting up this site, I used the CSS plugin to alter the appearance of the widgets - in particular, adding a grey background to the widget headers and specifying its size and length in terms of pixels. For example:

h3.widget-title {

background-color: #f2f2f2 !important;

padding-bottom: 6px !important;

padding-left: 6px !important;

padding-right: 35px !important;

padding-top: 6px !important;

}

My incorrect solution

With much regret, I altered the option on my site from "Static Pixel Width" to "Responsive With Pixel Width". The problematic widget suddenly displayed in its entirety, but it created a new problem. For all the widgets on my site, the grey title background extended to the right, beyond each widget's right border........ So I changed the pixel-padding to x.em value instead. Still no luck!

My question

Is there any way of getting the Morefoot Right text widget to display correctly on a phone device whilst keeping the "Static Pixel Width" option? (I much prefer "Static Pixel Width" to the other alternatives.) In fact, is there a way of getting the problematic widget to to display correctly so that it works with all three layout handling options in PageLines?

Many thanks in advance!!!

Share this post


Link to post
Share on other sites

2 answers to this question

Posted · Report post

HI,

I have just tested this and it does indeed appear to be a minor layout bug. I have reported this for you on our tracker.

1 person likes this

Share this post


Link to post
Share on other sites

Posted · Report post

The topic was marked as resolved.

Share this post


Link to post
Share on other sites