Jump to content


Photo
- - - - -
Open

Critical Sidebar Problem! :( Tried Everything



  • Please log in to reply
15 replies to this topic

#1 saltman

saltman

    Member

  • Members
  • 22 posts
  • Country: Country Flag

Posted 20 October 2012 - 11:25 PM

Ok,

I'm typing now after much testing using over 4 x 3rd party plug in's to give me the respective widgets appearing on respective pages.

Whether i select "show by default" on the PRIMARY and SECONDARY sidebars or not while using any conditional logic code (via plug-in), i still get nothing. If i'm lucky i'll get the default wordpress sidebar output widgets which is no use.

I then threw all the plug ins out, deleted and thought ok....i'll use the pagelines UNIVERSAL and TIERTIARY sidebars to show what i need (even though this does not give much scope for the future doing it this way). So i went through the process of disabling the default view of each sidebar and then activating on only my shop page. Again.......NOTHING SHOWS!! :( Not even...the calendar widget, when i was desperate enough to try that........madness

I've also tried setting the shop page with the different default pagelines page templates to check that there were no issues with the one i was testing on. Same outcome. No widgets.

Mega frustrated monkey, any help greatly appreciated :)

#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 21 October 2012 - 12:09 AM

Hi which site is this (link, please) and which pages are you experiencing the problem on?

If necessary, I will ask you to provide me with login credentials via PM.

I suspect your template is incorrectly set up.

#3 saltman

saltman

    Member

  • Members
  • 22 posts
  • Country: Country Flag

Posted 21 October 2012 - 08:31 AM

Hi! thanks :)

The sandbox env is

Please Login or Register to see this Hidden Content



Try the shop page, currently still setup as described above

let me know if you want me to send you the WP admin credentials via pm

Cheers again, must be something really silly i'm sure

Mark

#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 15120 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 21 October 2012 - 10:47 AM

Hi,

Can you provide screenshots of the following:


• Shop template in Drag and Drop both Page Template and Content Area please.
• As well as a screenshot of your SB1/SB2 active sections please.
• A screenshot of your Shops PageLines Meta Settings please.

Can you also PM with your admin username and password as well please.

#5 saltman

saltman

    Member

  • Members
  • 22 posts
  • Country: Country Flag

Posted 22 October 2012 - 10:12 PM

Hey Danny thanks man,

Sorry for the delay

I've attached the screenshots.

Not sure how to pm, cant see the option?

Cheers

Mark

Attached Files

  • Attached File s1.jpg   67.31KB  12 downloads
  • Attached File s2.jpg   65.96KB  14 downloads
  • Attached File s3.jpg   64.55KB  9 downloads
  • Attached File s4.jpg   64.42KB  8 downloads
  • Attached File s5.jpg   74.89KB  9 downloads
  • Attached File s6.jpg   81.45KB  8 downloads


#6 James B

James B

    Advocate

  • Moderators
  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 23 October 2012 - 05:07 AM

Hi there, according to the screen shots you're working on 'template two' in the drag and drop. As you're using jigoshop the jigoshop template will take over and you'll have to edit the 'special pages templates' in Page Options instead of template two.

You'll need to edit the layout of the page in Pagelines>Page Options>Product Archive. They'll you'll see the various layout options, click on the one with the required sidebar layout and hit save options. See the attached screenshot.

Please Login or Register to see this Hidden Content



#7 saltman

saltman

    Member

  • Members
  • 22 posts
  • Country: Country Flag

Posted 23 October 2012 - 11:33 PM

Hi James,

That's how i started out config wise, the final thing i tried was the universal and tertiary sidebar option - which is how you see the screenshots configured now.

In the beginning, i was using the product template "out the box" if you like - but had no luck there

IF you check the 5th screenshot you will see that i have those sidebars already selected, and have tried it with the standard primary and secondary sidebars, and also how i have it now.

am i missing something blatantly obvious? :|

Thing is, no matter what 3rd party conditional logic widget plug in i use....nothing shows. Only the general sprawl of the generic sidebar listing when there are no widgets set by default

Velly strange

#8 James B

James B

    Advocate

  • Moderators
  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 24 October 2012 - 03:25 AM

Hi there, I think you'll need to PM us some login details so we can take a look.

If you hover over one of our usernames a box will pop up showing our profile details, they'll be a 'send message' button. Set up an admin level user on your test site and send us the credentials through, we'll take a look at what's happening and try to sort it out for you.

#9 saltman

saltman

    Member

  • Members
  • 22 posts
  • Country: Country Flag

Posted 25 October 2012 - 09:49 AM

Cool thanks man,

You've got PM

Cheers

Mark

#10 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 25 October 2012 - 02:53 PM

Two moderators and I looked at your settings but we can't find anything that could be causing the issue. Some more poking around would need to be done. Not sure what could be wrong! :\

#11 saltman

saltman

    Member

  • Members
  • 22 posts
  • Country: Country Flag

Posted 25 October 2012 - 07:43 PM

I know, i've tried so many variations now. Super frustrating as this is a pretty standard thing to do

Really need to get to the bottom of this, very strange

Where to from here? I cant trash the site, and any more troubleshooting is really putting me out of pocket on this one

#12 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 26 October 2012 - 01:37 AM

Hi,

After working intensely with James to find a resolution/cause, we've discovered:
1. Many of your Jigo pages do not have a selected template. Please select a template and save.
2. All those pages do not have the PageLines Meta Settings for the layout and sidebar options checked.

As soon as I selected Default Template and checked the boxes for all the sidebars and saved, they appeared perfectly on the Thank You page.

Simply finish setting up your pages and your sidebars will work accordingly.

#13 saltman

saltman

    Member

  • Members
  • 22 posts
  • Country: Country Flag

Posted 26 October 2012 - 02:18 AM

This is what i have tried in every variation for the main SHOP page. I did try another page as i recall but i focused mainly on the SHOP page. Please can you check this one out as i have defined a template, and different ones along the way testing - with the same blank results. if you check out the SHOP page without loggin in even you will see.

All of this testing using base pagelines sidebars came after trying 3+ widget logic plug ins to show respective widgets on respective sidebar within certain page. Again no luck.

I can see that you are able to show the main sidebar widgets on the Thank You page but i'm failing to see why it will not show ANY sidebar entries on the SHOP page no matter what i do.

Also using the default template alone will give absolutely no scope going forward. Which is why i ultimately want to use widget logic or similar

#14 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 26 October 2012 - 03:54 AM

Hello again Mark,

I've been unable to even identify which page corresponds to the Shop link in the menu. There's no page of that name, no post, and while the Product Template pulls up in the WP navigation, it does not in Page Templates or Content Area. If there's a static page of a different name, please let me know which it is. I suspect that it is a 'special page' created dynamically by Jigo. Special pages are very difficult to customize.

If that's the case, I'm afraid there's little else I could do save to recommend you engage a

Please Login or Register to see this Hidden Content

with Jigo experience. Unfortunately, their support even in a paid mode is less than stellar.

One last thought, I see you have many Jigo-based plugins. It's possible one or more may conflict with PageLines. Keep in mind we did have to create an integration for Jigo because it did not work 'out of the box' in Framework, as opposed to ECWID or CartPress. I am loath to recommend deactivating them and don't believe it will help, however you may wish to try it, paring down the plugins to Jigoshop and Jigo for PageLines. There's always the remote chance that might help.

#15 saltman

saltman

    Member

  • Members
  • 22 posts
  • Country: Country Flag

Posted 30 October 2012 - 08:13 PM

Ohh nooooo


Oh no man :| this was a fresh install of every component from scratch.

I've had Jigoshop support come back to me now as-well saying it must be a Pagelines problem, and visa versa for yourselves. Buck...rodgers :P

So all in i think i've spent over $400 on

- Pagelines Framework
- Pagelines plug-ins
- Jigoshop Bundle Plug-in pack
- Jigoshop support contract

And now i have to chose another framework and e-commerce solution and start again. whaaaaa, this isnt music to my ears.

I guess i wouldnt mind so much if i was trying to achieve some form of new online coding breakthrough....but i just want a pre-made widget internal to Jigo & pagelines plug in show, on a specific page.

I'll go and have a little man cry and i might feel better

#16 Jenny

Jenny

    Advocate

  • Unicorn Store Dev

  • 2924 posts
  • LocationWV
  • Country: Country Flag

Posted 31 October 2012 - 01:55 PM

Have you tried disabling all other plugins except:

pagelines sections
jigoshop
jigoshop for pagelines

.. and see if that helps?