Jump to content


Photo
- - - - -

"Features" slider bug when resizing browser window in Pagelines 2.3.3

Features Pagelines 2.3.3

  • Please log in to reply
7 replies to this topic

#1 pageliner

pageliner

    Member

  • Members
  • 13 posts
  • Country: Country Flag

Posted 20 October 2012 - 08:23 AM

Hi,

I recently installed Pagelines 2.3.3 on a local MAMP (Macintosh, Apache, MySQL, PHP) installation using wordpress 3.4.2.

I created a "Features" slider with text on the bottom (Black text, light feature background, no overlay). When I load the page the first time, it renders as expect. The problem occurs when the browser window is increased in size.

The problem:
When the size of the browser window is increased, the text that is to be part of the feature disappears.

If you gradually increase the size of the window, you can watch the text slowly disappear as you increase the size of the window. Eventually, if you resize the window large enough, all the text disappears as you are left with the textured background that pagelines provides.

This behavior does not happen when you are decreasing the size of the browser window. It only occurs when you are increasing the size. After increasing the size of the browser window, if you decrease it back to the size it was when the page loaded, the text appears again. After you increase the size of the browser window, if you reload the page, the text renders correctly. But if you increase the size of the window, it starts to disappear again.

The problem occurs when I do any of the following:
- Increase the size of the browser window using trackpad (dragging the edges of browser window).
- Increase the size of the browser window using the "zoom" option in Safari.
- Increase the size of the browser window using 3rd party window management tools in OSX.

The problem repro's everytime with the following browsers:
- Firefox 15.0.1
- Safari 6.0.1

Is there a problem with the settings that causes this? Or is this a legitimate bug?

The feature is set to use "Aspect Height", and the ratio is 1.77. But this problem repro's regardless of the ratio or height.

Also note, that this problem does not occur with previous versions of pagelines (such as 2.1.6)

#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 20 October 2012 - 05:25 PM

Since you're on MAMP and not live, I can't see this slider, but it's possibly caused by the slides being of different original size. Alternatively, it could be caused by custom CSS, insufficient or broken CSS, a javascript or jquery conflict... etc.

I'd suggest starting by insuring the original images are all the same size.

We also provide a plugin that might help if this is browser specific -

Please Login or Register to see this Hidden Content



If it's a conflict, I'd recommend checking the compatibility of your plugins with WP 3.4.2.

#3 pageliner

pageliner

    Member

  • Members
  • 13 posts
  • Country: Country Flag

Posted 21 October 2012 - 05:18 AM

Thank you for your reply.

The two feature background images, are identical in size.
I have tried this with the exact same image on both slides.
I have tried images that are : 1000x500 (for both slides), and also 1000x330 (for both slides) and the problem repro's in both cases.
I do not use custom CSS, and I have made no changes to the CSS that comes with a default installation of page lines.
I have not written any javascript or jquery code.
As I just started this project, there are just a handful of pages, most of which have absolutely nothing on them.
I have a 3 boxes on the same page as the slider.
This pagelines installation does not have any code changes done by me.

The only plugins I have installed are:

Contact Form 7 (version 3.3.1). This is used on another page. It is not on the same page as the features slider.
Pagelines Sections (Versions 1.0)
Post Types Order (Version 1.5.4)

I use the "Base Theme" versions 1.0.2 provided by pagelines, as I would like to make custom templates.

#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 16555 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 21 October 2012 - 09:53 AM

HI,

I am not able to recreate this, therefore can you install a free application called JIng and then record the issue so we can review the clip.

Please Login or Register to see this Hidden Content



#5 pageliner

pageliner

    Member

  • Members
  • 13 posts
  • Country: Country Flag

Posted 21 October 2012 - 02:37 PM

How can I send it to you? The recording will be over 500K ?

#6 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 21 October 2012 - 04:34 PM

When replying, click the "More Reply Options" button at the bottom, right of the edit field here. You'll see an option to upload files.

#7 pageliner

pageliner

    Member

  • Members
  • 13 posts
  • Country: Country Flag

Posted 22 October 2012 - 03:38 AM

What I meant to say was, the size of the file will be larger than 500K. This forum seems to allow me to add attacments only upto 374.2K. Which means I cannot attach the video unless there is some alternate means.

#8 Danny

Danny

    Is Awesome!

  • Moderators
  • 16555 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 22 October 2012 - 10:24 AM

Hi,

The Jing recording can be uploaded to your Screencast account, once uploaded a link to the recording will be added to your clipboard, simply copy and paste the recording link to your reply.





Also tagged with one or more of these keywords: Features, Pagelines 2.3.3