Archived

This topic is now archived and is closed to further replies.

  • 0

iPhone/iPad view mess up my site

Question

Posted · Report post

Hi!

At my site "webbdo . se" the CSS messes up the page when I look at it whit iphone/ipad. The 3 feature´s are getting "black". And at the bottom of the page´s there are getting black aswell. Why is this?

It seams like when i go to the site whit computer it looks OK, but now whit iphone/ipad?

Regards P

Share this post


Link to post
Share on other sites

19 answers to this question

Posted · Report post

I´ve tried this already, but it didn´t work neither...

Share this post


Link to post
Share on other sites

Posted · Report post

I have the same problem with the site fips.soundquadrat . de. I´m using iBlogPro 5 and disabled mobile view in the layout editor, but it didn´t work. Is there anything else I can do? Thank you! :)

Share this post


Link to post
Share on other sites

Posted · Report post

What are you layout settings ?

Share this post


Link to post
Share on other sites

Posted · Report post

Dont want to upgrade to 5. Good whit 4 and all the designs in it. But now whit the black spots when looking in iphone.

Any other ideas?

Share this post


Link to post
Share on other sites

Posted · Report post

Layout Handling: Static with Pixel Width

Site Design Mode: Full-Width Sections

Mobile View: Disabled

Global Content Width: 924 px

Thanks!

Share this post


Link to post
Share on other sites

Posted · Report post

iBlogPro 4 is now free via Github: https://github.com/pagelines/iBlogPro4

As far as I know, the black areas are caused by the gradient images, you can do one of two things, either update the images or replace the CSS for images and use a gradient generator and override the image CSS.

Share this post


Link to post
Share on other sites

Posted · Report post

Please try deactivating all active plugins.

Share this post


Link to post
Share on other sites

Posted · Report post

Where do i Deactivate Mobile view, cant find it?

Share this post


Link to post
Share on other sites

Posted · Report post

There is no Disable Mobile View option in iBlogPro 4, Rob must have assumed you were using iBlogPro 5.

If you upgrade to PageLines Framework and iBlogPro 5, your posts/pages will remain as they're stored in the database. However, your overal site design will take on the design and layout of iBlogPro 5.

Share this post


Link to post
Share on other sites

Posted · Report post

For layout handling, please enable responsive.

Share this post


Link to post
Share on other sites

Posted · Report post

It shouldn't.

But did you also try to Deactivate Mobile View? That worked for me.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

You have W3 Total Cache enabled and you have also made changes to iBlogPro 4 style.css. You're also using version 4.2.3, the latest version is 4.2.6. I recommend you update to the latest version and see if this resolves your issue.

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks, did what user "rodgerzeislernet" said. from 1x268 to 2x268! Worked very good!

Share this post


Link to post
Share on other sites

Posted · Report post

I changed this, too. It still doesn´t work. I can´t figure out the problem...

Share this post


Link to post
Share on other sites

Posted · Report post

Do you also have a cache plugin? If so, did you deactivate it?

Share this post


Link to post
Share on other sites

Posted · Report post

gradient generator? Can you post the new omage CSS for me please?

Share this post


Link to post
Share on other sites

Posted · Report post

I don´t have cache plugins. And my problem is that the inverting not only happens with pictures but also with, for example, the half of a content field. It seems absolutely arbitrary and I can´t recognise a pattern...

Share this post


Link to post
Share on other sites

Posted · Report post

Hi!

I have tryed to disable W3C but it not helping.

If I upgrade, will it delete some of my installs on WP?

Regards Pierre

Share this post


Link to post
Share on other sites