Jump to content


Photo
- - - - -
Resolved

Use of undefined constant SECTION_ROOT

2.3.3 break

  • Please log in to reply
3 replies to this topic

#1 ksnyde

ksnyde

    Super Member

  • Members
  • 177 posts
  • Framework Version:2.3

Posted 17 October 2012 - 01:42 PM

After upgrading to 2.3.3 I now get error messages on every page (admin and frontend) that say:

Notice: Use of undefined constant SECTION_ROOT - assumed 'SECTION_ROOT' in [LOCAL_FILE_PATH]/production/wp-content/themes/[CHILD_THEME_DIR]/sections/nav_plus/section.php on line 28

Has anything changed that would create this problem? The actual line that it is referring to is a block of code that I used from a Pagelines example and looks like this:

Please Login or Register to see this Hidden Content


It's never been changed but it looks like the const SECTION_ROOT is no longer being defined?

#2 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 17 October 2012 - 01:45 PM

We had to namespace the constants

Add PL_ in front

#3 ksnyde

ksnyde

    Super Member

  • Members
  • 177 posts
  • Framework Version:2.3

Posted 17 October 2012 - 04:16 PM

That worked.

#4 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 17 October 2012 - 04:22 PM

The topic was marked as resolved.





Also tagged with one or more of these keywords: Resolved, 2.3.3, break