Jump to content


Photo
- - - - -
Open

Layout with Main Column and Sidebar 2



This topic has been archived. This means that you cannot reply to this topic.
7 replies to this topic

#1 jjohnson

jjohnson

    Newbie

  • Members
  • 6 posts

Posted 17 October 2012 - 03:40 AM

Simple question... how do I set up pages with Main column (left) and Sidebar 2 (right) ? I see main and sidebar 1, but I just want sidebar 2 there instead.. I have sidebar 2 styled a certain way, the widgets I want are in it, and I want it to stay just like the 3 column layout, on the right side. I don't want sidebar 1 on the right.

| | |
| | |
| main column | sidebar 2 |
| | |
| | |

#2 James B

James B

    Advocate

  • Members

  • 5126 posts

Posted 17 October 2012 - 04:34 AM

Hi there, if I understand you correctly then try the following.

Select the three column layout: Main Column>Sidebar 1>Sidebar 2 in the page layout. Then via the page meta settings, go in to the page setup tab and check 'hide primary sidebar' and save meta settings. This should result in the look you have described above.

#3 jjohnson

jjohnson

    Newbie

  • Members
  • 6 posts

Posted 17 October 2012 - 05:20 PM

That is the solution I ended up figuring out... but it doesn't look right. For some reason, white space shows up to the right of sidebar 2, which is weird, since sidebar 2 extends to the right edge of the drag and drop layout.

#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts

Posted 17 October 2012 - 11:33 PM

The blank space is simply the result of an empty DIV, which expected to see SB1. The solution is very easy. Go to Dashboard > PageLines > Site Options > Website Setup and look for "Remove Default Sidebars When Empty" just check the box to hide sidebars when empty. This removes the empty div, allowing SB2 to occupy the full space.

However, if you add a sidebar to SB1, it will show up as long as you have a widget in the sidebar.

#5 jjohnson

jjohnson

    Newbie

  • Members
  • 6 posts

Posted 25 October 2012 - 04:33 PM

This didn't work, because, as I said, the space is to the right of the sidebar 2, not the left (where sidebar 1 would be). Also, I do have stuff in sidebar 1, but I hid it on the page level. Still a strange white space to the right of sidebar 2. Oh well. I think I will have to get rid of sidebar 1 and hard code it onto the home page, where I wanted it... then use a different template on all my pages... such a pain! Pagelines - you need to add a template like I put in the original post!

#6 catrina

catrina

    Advocate

  • Members
  • 12345 posts

Posted 25 October 2012 - 05:31 PM

Do you need further assistance with hard coding it?

#7 jjohnson

jjohnson

    Newbie

  • Members
  • 6 posts

Posted 25 October 2012 - 09:30 PM

I put what was in sidebar 2 into sidebar 1, and then I put what I had in sidebar 1 and hard coded it to float left on the home page... that works for the home page, but it stinks I can't leave it as a sidebar for the purpose of using widgets, etc.

#8 Danny

Danny

    Is Awesome!

  • Moderators
  • 17003 posts

Posted 26 October 2012 - 09:00 AM

Hi,

What you can do is this:
  • Go to Drag and Drop and in SB1, drag the Secondary Sidebar section to the Active Sections, so that you have Primary and Secondary in SB1.
  • Then click on the Options button on Secondary Sidebar and check "Hide by default", so that it is not active on all your pages/posts.
  • Now go to Appearance Widgets, add whatever Widgets you wish to have in your Secondary Sidebar.
  • Once this has been completed, go to the Wordpress Admin Dashboard > Pages and select the Page which you would like to have the Secondary Sidebar active on.
  • Scroll down to the PageLines Meta Settings and then Hide Primary Sidebar and then check the box to show Secondary Sidebar.

If you view your page now, you will have the Secondary Sidebar active on this page.

However, a easier method in my opinion, would be to use the plugin Widget Logic, this plugin allows you to display Widgets on a per post/page basis.