Jump to content


Photo
- - - - -
Resolved

Site loads slow

loading slow

  • Please log in to reply
19 replies to this topic

#1 yemoonyah

yemoonyah

    Super Member

  • Members

  • 143 posts
  • Framework Version:always the latest
  • Country: Country Flag

Posted 13 October 2012 - 12:53 PM

Hi,

so my site is slow and I read up in the forums and did the following:

- W3 Cache was already installed (Minify, Browser Cache, CloudFlare and CDN enabled)
- installed CloudFlare
- installed MaxCDN

the site was still slow.

So I added the following code to wp-config.

Please Login or Register to see this Hidden Content


That helped a lot but unfortunately made my site crash for some users so had to delete it again.

Now I increased php.ini to 256mB (BlueHost).

My site is still slow. What am I missing? And why made the above code make my site crash?

This is driving me nuts. Any suggestions are very welcome.

Thanks

#2 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 13 October 2012 - 02:25 PM

Crash how? Why are you using cloud flare and max cdn they are both cdn providers


#3 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 13 October 2012 - 06:05 PM

Hi, Simon's correct, CloudFlare and MaxCDN are the same thing, so you're duplicating things. That alone could cause problems in that your site is looking for components in two places and effectively loading them twice.

I know this is going to sound crazy, but the problem with the crash may have come from copying and pasting. Some computers will tack on hidden things when doing so. It's always best, I say, to paste it first to a text file, to ensure nothing is hidden (like a space, paragraph or other element). Then copy from the text file. That make's sure you have a clean copy and equally clean paste.

LESS_FILE_MODE can easily become LESS FILE MODE, which would be incorrect.

#4 yemoonyah

yemoonyah

    Super Member

  • Members

  • 143 posts
  • Framework Version:always the latest
  • Country: Country Flag

Posted 13 October 2012 - 07:52 PM

Ok, back to scratch.
I deactivated both CloudFlare and MaxCDN and reinserted the less file code in my wp-config.php file:

Please Login or Register to see this Hidden Content


This is what happened:

Please Login or Register to see this Hidden Content



Here is my website link:

Please Login or Register to see this Hidden Content



#5 batman

batman

    Bat Learning

  • Members

  • 1733 posts
  • LocationBuenos Aires, Argentina
  • Framework Version:DMS
  • Country: Country Flag

Posted 13 October 2012 - 08:22 PM

Hi yemoonyah
Just to let you know... your site is broken now

#6 batman

batman

    Bat Learning

  • Members

  • 1733 posts
  • LocationBuenos Aires, Argentina
  • Framework Version:DMS
  • Country: Country Flag

Posted 13 October 2012 - 08:27 PM

I see this with firefox and safari
Posted Image

#7 yemoonyah

yemoonyah

    Super Member

  • Members

  • 143 posts
  • Framework Version:always the latest
  • Country: Country Flag

Posted 14 October 2012 - 12:18 AM

Yes, I know. and I can't login anymore!
I tried resetting my password, clearing my cache, moving w3t cache to another folder (although that seemed to have restored my site).
Nothing works. I'm super frustrated...

but thanks for the heads up.

#8 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 14 October 2012 - 02:02 AM

Yemoonyah,

This may seem drastic, but it's the sure-fire way to fix it. Ask your host to implement a backup from several days ago.

If they do not have one, then restore your wp-config to where it was prior, then download and unzip the latest version of WP to your local machine.

Via FTP, upload the wp-admin and wp-includes folders, and all files in the root of the unzipped folder. Don't overwrite the wp-content folder. It will have no effect.

Then, go to wp-content/themes and locate the folder pagelines. Delete it. This will not remove anything you've customized *(unless you did it wrong).

Login to www.pagelines.com/launchpad and download the latest version of PageLines Framework. Unzip it locally to your desktop. Via FTP, upload the pagelines folder back to wp-content/themes.

Go to Dashboard > Appearance > Themes and activate the proper theme (a child if that's what you're using). You may need to go to Appearance > Menus and select the default menu on the left, top of the menu area and save.

Your site should be fully restored.

#9 yemoonyah

yemoonyah

    Super Member

  • Members

  • 143 posts
  • Framework Version:always the latest
  • Country: Country Flag

Posted 14 October 2012 - 03:42 PM

Ha, I managed to log in. I did everything mentioned in this WP doc before taking drastic steps like described by One Smart Egg (thanks for the tips though!):

Please Login or Register to see this Hidden Content



Nothing helped.

But then I decided to try it using Firefox and that worked! I can also do it by opening an incognito window in Chrome.

Maybe it's because I just re-uploaded my wp-login.php.

I did clear my browser cache and cookies but it still won't work in Chrome (non-incognito). But at least I can log in again :)

#10 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 14 October 2012 - 06:22 PM

Well, you're making progress. That's a good sign.

#11 yemoonyah

yemoonyah

    Super Member

  • Members

  • 143 posts
  • Framework Version:always the latest
  • Country: Country Flag

Posted 25 October 2012 - 09:29 AM

I'm back working on the slow loading time of my site. I have W3 Cache and CloudFlare installed but my site takes up to 8 sec to load.
I also tried using the following code again but it keeps breaking my site (see for screenshot above).

Please Login or Register to see this Hidden Content



#12 Danny

Danny

    Is Awesome!

  • Moderators
  • 12929 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 25 October 2012 - 10:10 AM

Hi,

I am not sure what is going on, when I view your page source, it appears to have all the <div stripped from it.

Can you please disable all non-PageLines plugins and then view your page source again and see if the <div returns to your page source.

#13 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 25 October 2012 - 10:40 AM

The file mode is not working, we cannot help you until you disable w3 cache.

#14 yemoonyah

yemoonyah

    Super Member

  • Members

  • 143 posts
  • Framework Version:always the latest
  • Country: Country Flag

Posted 25 October 2012 - 02:55 PM

Ok, I disabled all plugins, no <div
I kept W3 disabled so you can have a look but will activate again soon as now my site takes 15 sec to load.
Thanks.

#15 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 25 October 2012 - 04:02 PM

So can you add the LESS_FILE_MODE line again, and show me a screenshot of that section of the config

#16 yemoonyah

yemoonyah

    Super Member

  • Members

  • 143 posts
  • Framework Version:always the latest
  • Country: Country Flag

Posted 26 October 2012 - 09:47 AM

I added the LESS_FILE_MODE again. You can have a look now.

Screenshot is attached.

Attached Files



#17 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 26 October 2012 - 10:35 AM

and its working as expected

#18 yemoonyah

yemoonyah

    Super Member

  • Members

  • 143 posts
  • Framework Version:always the latest
  • Country: Country Flag

Posted 26 October 2012 - 05:22 PM

It was Maxcdn that did not like the LESS_FILE_MODE.
Now I activated W3 again and my site is finally loading a bit faster.
Will play with the different options and see what helps and what doesn't.

Thanks for the help so far!


#19 yemoonyah

yemoonyah

    Super Member

  • Members

  • 143 posts
  • Framework Version:always the latest
  • Country: Country Flag

Posted 28 October 2012 - 02:56 AM

Ok, so I enabled W3 Cache with page cache, browser cache and minify and als activated CloudFlare again. Now my site loads in 2-3 sec again :)

this thread can be closed.

Thanks for all the help!

#20 Danny

Danny

    Is Awesome!

  • Moderators
  • 12929 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 28 October 2012 - 10:16 AM

The topic was marked as resolved.





Also tagged with one or more of these keywords: Resolved, loading, slow