Archived

This topic is now archived and is closed to further replies.

  • 0

Drop-down menus not appearing

Question

Posted · Report post

I have a couple of sub pages that should be appearing as drop down options under "cooking with the Kegleys." For some reason they do not show up at all. Any ideas what I am doing wrong? Thanks.

www.jenniferkegley.com

Share this post


Link to post
Share on other sites

17 answers to this question

Posted · Report post

Chasenet,

Thank you for your comment. I logged out of my administrative mode and the menus work as they should (though they are still ugly). That helps me very much. I was going a little batty trying to figure that one out.

James B,

Yes, I do have some custom code to center my nav bar. Is it possible to align the drop-down menu items to fit the centered nav bar? Thank you for any help you can provide. :) Oh and I have looked at the page in both Safari and Firefox.

Share this post


Link to post
Share on other sites

Posted · Report post

James,

Yes I did disable the menus for the moment. They were distracting and not functioning correctly. I checked my Appearance>Menu settings and they are correct. Thank you for that clarification. Do you have any suggestions?

Share this post


Link to post
Share on other sites

Posted · Report post

I'm having the same issue at http://www.memorialvein.com ... additionally, my home page features is messed up when viewing in Firefox. I've checked all the setting above and still having issues. Any other ideas? I appreciate the help.

Share this post


Link to post
Share on other sites

Posted · Report post

OK ... I think I figured it out ... it looks like Use Google Libraries plugin was causing the issue. Do you know why that would have been? It only affected this one website, not others.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Jennifer, yes you'll be able to apply css to the style out the sub menus, add color/padding/margins and align them better etc. Its hard to tell you exactly what that you be as the links aren't displaying on the site at the moment. If you have firebug you can go in and check the below selectors/classes and play around with the css to change the styles.


ul.sf-shadow

ul.sub-menu,

ul.sf-shadow

ul.children

.sf-menu li ul li:last-child

.sf-menu li ul li

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

Can you follow the below instructions please.

1. Make sure you have created a custom Wordpress Menu, which has drop down menus which are indented to the parent menu item, for more information on how to create a Wordpress Menu see here - http://codex.wordpre...Menu_User_Guide

2. Once you have created your custom Wordpress Menu, in Appearances > Menus, on the left hand side, there is a section called Theme Locations, in the "Primary Website Navigation", select your menu in the drop down and click save.

3. Go to PageLines > Site Options > Header & Footer and then check the box for the option "Enable Drop Down Navigation?"

If the above, doesn't display you drop down menus correctly, then your images for your menu items are getting in the way and you will need to adress this issue.

Share this post


Link to post
Share on other sites

Posted · Report post

It's difficult to say what could be the reason behind a plugin conflict on a specific site (there could be one small, hidden reason that's not immediately detectable). :\

Share this post


Link to post
Share on other sites

Posted · Report post

Moderator,

I followed your instructions. I realized that because I have graphic elements listed in my primary menu, my sub items were appearing under a graphic rather than were they belong. I fixed that problem. I am afraid that I do not know what you are referring to when you say "Theme Locations." I don't see that anywhere in the dashboard. I now have sub menu items under Cooking with the Kegleys. However, they do not work correctly. You have to click on Cooking with the Kegleys and then let go. The sub menus appear. Then you can select a sub menu item. I want these to work as is typical, you hover over the a main menu and you see the sub pages, you move down and select a sub menu item. Even if you selected a main menu item and could see the sub menus and select one of them without letting up on the cursor that would be a more typical functionality. As it appears now, it is frustrating and unsightly. Any suggestions would be greatly appreciated.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi there Jennifer, I've just checked the link and I can't see any drops downs on that link. Have you disabled them? Rob refers to theme locations in Appearance>Menus. Top left hand of that screen you have a series of drop downs which enable you to assign your navigation to a particular menu area on the site.

Share this post


Link to post
Share on other sites

Posted · Report post

Danny,

I have followed all of those instructions. I even removed my graphics. None of it made any difference. The drop-down menus are there. They just don't operate correctly. You should be able to click and slide down the menu options and then release to go to the highlighted option. Alternatively, you should be able to hover over the parent item to see the sub-menus, scroll to the sub menu item you want and then click to select that item. Neither of those are true on my page. Check it out at www.jenniferkegley.com.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

First, let's go to Dashboard > PageLines > Site Options > Header & Footer and check the boxes under "Nav Classic & BrandNav Section - Drop Down Handling"

This makes sure that the drop down function is enabled.

Next, please visit Dashboard > Appearance > Menus.

Make sure your child menu items are indented one notch only from the parent.

It should look like:

Cooking with the Kegleys

->First child1

->First child2

->First child3

If you have it set to ---> (two or three notches) instead of -> (one notch), it may not show.

Next, as long as your menu is named (a saved menu name like Primary), make sure that in "Theme Locations", that named menu is selected as Primary Site Navigation.

Save all your settings.

Your menu should now display the drop down list.

Share this post


Link to post
Share on other sites

Posted · Report post

James B,

Thank you for the information. I will give it a try.

Share this post


Link to post
Share on other sites

Posted · Report post

James B,

I have put my menu items back where they belong so will be able to see them on my site now. Unfortunately, I am having some trouble looking at the code with Firebug. It all looks like gobledygook to me. Any suggestions would be very helpful. I want the items to line up correctly and also to not be transparent (it looks messy when you can see the underlying text through the menu items). Can you help me?

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Jennifer

Which browser are you using? They are coming up in firefox and safari for me. http://screencast.com/t/tg2ogoFNzeM0

They are out of alignment slightly, have you applied any custom css to the nav menu at all?

Share this post


Link to post
Share on other sites

Posted · Report post

I had a similar problem with drop down menus not working ... they seem to work fine when you view the site while logged out of WP

Share this post


Link to post
Share on other sites

Posted · Report post

@chasenet Which browser are you using?

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Jennifer, try the below Css, let me know if it works. Change the hex color to the one you like.


To Change the menu color

ul.sf-menu ul.sub-menu, ul.sf-menu ul.children {

background: #dddddd;}


To align menu

#nav_row ul ul {

left: none;

}

Share this post


Link to post
Share on other sites