Jump to content


Photo
- - - - -

Can't get blog to show up

blog

  • Please log in to reply
4 replies to this topic

#1 thebeej

thebeej

    Newbie

  • Members
  • 3 posts

Posted 06 October 2012 - 12:03 PM

I can't seem to get the blog to show up on anything other than the default page, and even at the I have to have the home page status selected to see the lastest posts.

I'm sure I'm missing something simple - your help would be appreciated!

#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 06 October 2012 - 06:24 PM

Hi,
First let's go to Dashboard > PageLines > Drag & Drop and click on "Page Templates" (under 1. Select Template Area)
Make sure that in Blog, Blog Post, Template 1, 2, 3, 4 and 5, Tags, Archive, Category, Search and Author, you have Content in the template.

Next, in Drag & Drop, click "Content Area" (also under 1. Select Template Area).
There, for each of the same templates as above, you must make sure PostLoop is present.

Now check your blog page and see if it's showing.

If you created a static homepage and corresponding blog page, make sure that in Dashboard > Settings > Reading under Front page displays you have selected "A static page (select below)" and beneath that, in the top selection list, you've chosen the static homepage for the Front page and in the second list (Posts page), you've selected the blog page you created. Save the settings.

Let us know if this works.

#3 thebeej

thebeej

    Newbie

  • Members
  • 3 posts

Posted 06 October 2012 - 07:26 PM

Thank you for your help. I've done as you've instructed, and it the blog does show up under the "blog" page. However, I would also like it to show up under my "home" page, which I have set in the dashboard > Reading as the the front page to display. However it's blank. Any thoughts?

#4 thebeej

thebeej

    Newbie

  • Members
  • 3 posts

Posted 06 October 2012 - 07:38 PM

Also, the "quick" slider is showing up, but I don't have it active on any of the templates, or on the blog page settings, or the individual settings.....

#5 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 07 October 2012 - 05:36 AM

Okay, if you created a static homepage, I'm presuming it would have static content and not need to list the blog entries. That, after all, is what the blog page is for.

However, if you want the homepage to be a blog page too, just go back to Dashboard > Settings > Reading and change the option from static pages to "Your latest posts". WordPress, which controls this, isn't really designed to have both a blog page AND a homepage with posts, by default, to protect your site from duplications and confusion.

However, if you insist on having both, leave the current setup and implement a plugin called Special Recent Posts on your homepage. This requires the writing of a customized, complex shortcode that you add to the homepage.

If you look through Dashboard > PageLines > Drag & Drop, under Page Templates, you will doubtlessly find the Quickslider in one of the templates. Most likely, under Default or Blog. All you need to do is drag it from Active to Available Sections (left to right sides). Once removed, you won't see it.