Jump to content


Photo
- - - - -

Errors after activating iBlogPro_dev


This topic has been archived. This means that you cannot reply to this topic.
11 replies to this topic

#1 pagelines704

pagelines704

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 06 August 2010 - 04:07 PM

I get this after I activate iBlogPro_dev: ------------ Warning: include(/home/sketchucat/domains/sketchucation.com/public_html/wp-content/themes/iblogpro4_dev/core/globals.php) [function.include]: failed to open stream: No such file or directory in /home/sketchucat/domains/sketchucation.com/public_html/wp-content/themes/iblogpro4_dev/core/init_core.php on line 22 Warning: include() [function.include]: Failed opening '/home/sketchucat/domains/sketchucation.com/public_html/wp-content/themes/iblogpro4_dev/core/globals.php' for inclusion (include_path='.:/usr/local/lib/php') in /home/sketchucat/domains/sketchucation.com/public_html/wp-content/themes/iblogpro4_dev/core/init_core.php on line 22 Warning: include_once(THEME_CONFIG/config_theme.php) [function.include-once]: failed to open stream: No such file or directory in /home/sketchucat/domains/sketchucation.com/public_html/wp-content/themes/iblogpro4_dev/core/init_core.php on line 25 Warning: include_once() [function.include]: Failed opening 'THEME_CONFIG/config_theme.php' for inclusion (include_path='.:/usr/local/lib/php') in /home/sketchucat/domains/sketchucation.com/public_html/wp-content/themes/iblogpro4_dev/core/init_core.php on line 25 Fatal error: Call to undefined function pagelines_localize() in /home/sketchucat/domains/sketchucation.com/public_html/wp-content/themes/iblogpro4_dev/core/init_core.php on line 34 ------------ Please tell me what I can do to fix this.

#2 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts

Posted 06 August 2010 - 05:08 PM

I'm trying to duplicate this problem...I downloaded the most recent dev version 4.1.5 and installed on my local machine with no problems. Are you up to date and what version of WP are you using?

#3 pagelines704

pagelines704

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 06 August 2010 - 05:59 PM

3.01 and 4.1.5

#4 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts

Posted 06 August 2010 - 08:14 PM

Is it possible to disable plug-ins and try reinstalling the theme?

#5 pagelines704

pagelines704

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 06 August 2010 - 09:47 PM

No plug-ins are active at the time of activating the theme. Note that our site is using the multi-site feature of WP3.0. What do you think may be causing this? Also, just asking, will support here continue during the weekend? I will would really like to resolve this as soon as possible. Thanks for the help so far!

#6 cmunns

cmunns

    Advocate

  • Members

  • 6537 posts

Posted 06 August 2010 - 09:57 PM

It's got to be an incomplete installation. How did you install the theme? If you use ftp make sure to unzip first, if you use wordpress uploader then use the .zip

#7 arpowers

arpowers

    Founder

  • Administrators
  • 3270 posts

Posted 06 August 2010 - 09:58 PM

Support slows in the weekend, but we try and stay on top of it. I'm suspecting either an incomplete upload or an incorrect install with the theme.. How did you install it? Multi site shouldn't be a problem, but we havent tested with every known config. Finally, the theme shouldn't be showing you warnings like that... Do you have any debug PHP going?

#8 pagelines704

pagelines704

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 06 August 2010 - 10:28 PM

I have uploaded this theme using both methods, via FTP (after unzipping the files) and through the WP theme install admin, the 2nd try I also completely reinstalled WP. I do not know what debug PHP is nor if it's running.

#9 pagelines704

pagelines704

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 06 August 2010 - 10:58 PM

Maybe this can help: The first error says "No such file or directory in /home/sketchucat/domains/sketchucation.com/public_html/wp-content/themes/iblogpro4_dev/core/init_core.php on line 22". When I check that file on line 22 it says "include(CORE.'/globals.php');". Now I did a search in the theme's folder for a globals file and it didn't find one. So either this file is not included in the theme, or it is referring to a WordPress file, or something else is going on.

#10 arpowers

arpowers

    Founder

  • Administrators
  • 3270 posts

Posted 10 August 2010 - 06:49 AM

It seems you might have something strange going on around PHP 'globals'.. All those capital letters you are getting in the warnings are actual global variables used for filenames, directory settings, etc... it seems like your server is set not to use them for some reason, could you ask your host for us if there is any setting in Apache or PHP that could cause this? Also, if you want, post a screenshot of your install configuration in FTP... this way we can tell if you installed correctly and got all the right files :)

#11 pagelines704

pagelines704

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 10 August 2010 - 03:56 PM

Hi again, After much trouble today with our database I have re-uploaded everything once more and for some reason it's working now. Thank you very much for the support. I'm out of the woods!

#12 bryan-hadaway

bryan-hadaway

    Advocate

  • Members
  • PipPipPipPipPip
  • 3697 posts

Posted 11 August 2010 - 01:12 AM

Good to hear you got it working. Sometimes, just the smallest missed settings can bring the whole empire down. Thanks, Bryan