Jump to content


Photo
- - - - -

Sidebar content is not showing

primary sidebar

  • Please log in to reply
23 replies to this topic

#21 ginnywills

ginnywills

    Advanced Member

  • Members
  • 39 posts
  • Country: Country Flag

Posted 04 October 2012 - 05:59 PM

I have not heard from him but I have noticed that the sidebar is showing again. It seems to be running over into the main content area, so I am hoping he is still working on it. I am very curious to learn what went wrong or what I had done to cause the issue!

#22 ginnywills

ginnywills

    Advanced Member

  • Members
  • 39 posts
  • Country: Country Flag

Posted 04 October 2012 - 07:13 PM

Is there a way to make the sidebar scroll when I scroll through the content? By the time I get to the end of the content, the footer is sitting on top of the sidebar.

#23 James B

James B

    Advocate

  • Moderators
  • 4979 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 05 October 2012 - 03:55 AM

The issue was that your sidebar was set in the css to a width of 0px. I've overridden this now for you in the custom css box and it's displaying on your site.

The problem with the display on mobile devices seems to be to do with your custom css. The responsive design will move the sections to suit the width of the browser and rearrange them. However, some of the sections you've fixed with Css, and adjusted-removed some of the padding/line spacing which is why it isn't reacting very well on the mobile screen. You can adjust the css for mobile devices only, so you could correct it manually if you like the set up you have on the larger screens.

#24 James B

James B

    Advocate

  • Moderators
  • 4979 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 05 October 2012 - 04:01 AM

Hi Ginny, sorry I've just seen your other comments. Yes the sidebar will scroll normally, but someone has set some custom css in Pagelines>Site Options>Custom Code which has made it fixed. If you remove this, the sidebar will scroll as normal.

Alot of the issues relating to the mobile layout are also down to some of the css in the custom code box. Its obviously been put there for a reason originally, so I'd suggest you get the person who made the alterations to go back in there double check it to make sure its required still :-)

Let us know if you require any further assistance





Also tagged with one or more of these keywords: primary sidebar