Jump to content


Photo
- - - - -
Resolved

Style Sheet Missing

Style Sheet

  • Please log in to reply
29 replies to this topic

#1 brightgreenhomes

brightgreenhomes

    Advanced Member

  • Members
  • 43 posts
  • Framework Version:2.0

Posted 27 September 2012 - 02:32 PM

Hi,
I have a site - www.bhesco.co.uk - and when performing an update yesterday it seems that the style sheet has gone missing.

I have checked my hosting file manager online and all the folders seem to still be there?

The site doesn't load, and re-installing pagelines framework 2.0 doesn't work because it is already installed?

I am not a developer, so have pretty average skills - but this seems to be a problem that occured when I upgraded... please help... this is a new venture and i REALLY need this website up asap...

Alex

Attached Files



#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 27 September 2012 - 02:38 PM

What specific stylesheet are you referring to? Is it the style.css file in either PageLines Customize or the base theme?

#3 brightgreenhomes

brightgreenhomes

    Advanced Member

  • Members
  • 43 posts
  • Framework Version:2.0

Posted 27 September 2012 - 03:10 PM

Hi,
its pagelines framework - just went to upgrade it yesterday from 2.5 to 2.3 and the website has just stopped working?
now all i have is a blank page and when you visit the themes section in the dashboad it says that the stlysheet is missing (as I tried to show in the tiff?)

#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 28 September 2012 - 12:24 AM

Three things can cause this:
1. Bad plugins - check all, make sure they're up to date.
2. Bad code in a functions.php file. - make sure the function.php is up to date.
3. Bad installation of 2.3 - remove wp-content/themes/pagelines and reinstall via FTP to the same location. Do not attempt to overwrite the files. This won't always work. (NOTE: No customizations properly made will be lost!)

#5 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 28 September 2012 - 12:27 AM

White screen, thats a PHP error, open wp-config.php and uncomment WP_DEBUG line, and set to true.

Id say the theme folder is missing and wordpress is throwing a fatal error.

#6 brightgreenhomes

brightgreenhomes

    Advanced Member

  • Members
  • 43 posts
  • Framework Version:2.0

Posted 28 September 2012 - 08:36 AM

Hi,
I have tried all the plugins, disabled them all and tried to reload - again nothing?
I have also amended the wp-config.php file to 'true' and nothing again?
I have been to my host and made sure that the .php configuration is up to date...
Not entirely sure how I go about removing wp-content/themes/pagelines folder - I can deleter it via FTP, but what do I repace it with? the pagelines.zip file that I used to install 2.0 doesn't have a pagelines folder? or is this whole unzipped file the 'theme'?

Please bear with me as I am not a developer - rather a self taught amateur...

Thanks - Alex

#7 Danny

Danny

    Is Awesome!

  • Moderators
  • 13060 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 28 September 2012 - 10:15 AM

Hi,

Can you take a screenshot of your file and directory structure please. So we can make sure you have everything installed correctly.

#8 brightgreenhomes

brightgreenhomes

    Advanced Member

  • Members
  • 43 posts
  • Framework Version:2.0

Posted 28 September 2012 - 11:14 AM

Everything was working perfectly correctly when I pressed the button to upgrade pagelines 2.5 to 3.0

Since then it is not. So - it is reasonable to assume that it is something to do with the upgrade?

I only have 44.78kb of file space to upload to - when I reduce the picture size to <50kb the res is so bad you can't read it - should i start this thread again so I have the full amount of space again? The original tiff I uploaded showed that on the home page of WP dashboad it says in red:

ERROR: The themes directory is either empty or doesn’t exist. Please check your installation.
You are using WordPress 3.4.2.

and on the themes page:
Broken Themes

The following themes are installed but incomplete. Themes must have a stylesheet and a template. Name Description pagelines Stylesheet is missing. twentyeleven Stylesheet is missing. twentyten Stylesheet is missing.

#9 Danny

Danny

    Is Awesome!

  • Moderators
  • 13060 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 28 September 2012 - 11:26 AM

Ok, but can you load up your FTP client navigate to the Wordpress directory, open the wp-content folder as well as the themes folder and take a screenshot please.

Also, there is no possible way as far as I am aware that our update process can remove the Wordpress default themes.

#10 brightgreenhomes

brightgreenhomes

    Advanced Member

  • Members
  • 43 posts
  • Framework Version:2.0

Posted 28 September 2012 - 11:47 AM

yes - but as I said the trouble is that this support forum says I can only upload a screenshot of maximum 44.78kb of files - and the screenshot of any decent resolution is unreadable. So how would you like me to upload this?

#11 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 28 September 2012 - 11:49 AM

Why are you saving screenshots as tiff files? I dont even know what a tiff is!!

Upload you screenshots to imgur.com and please use jpegs

#12 brightgreenhomes

brightgreenhomes

    Advanced Member

  • Members
  • 43 posts
  • Framework Version:2.0

Posted 28 September 2012 - 11:49 AM

shall we start a new thread if this allows me to begin with the full complement of space for an upload?

#13 brightgreenhomes

brightgreenhomes

    Advanced Member

  • Members
  • 43 posts
  • Framework Version:2.0

Posted 28 September 2012 - 11:51 AM

ok - go here

#14 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 28 September 2012 - 11:51 AM

No please dont start a new thread, you can manage your attachments in your user settings. Just dont upload tiffs ( whatever they are )

#15 Danny

Danny

    Is Awesome!

  • Moderators
  • 13060 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 28 September 2012 - 12:01 PM

Ok, those images are poor in quality I cant see the text properly. Therefore, can you PM me and send me your FTP details so we can take a closer look please.

#16 brightgreenhomes

brightgreenhomes

    Advanced Member

  • Members
  • 43 posts
  • Framework Version:2.0

Posted 28 September 2012 - 04:09 PM

now all i am seeing is:
Fatal error: Call to undefined function pl_default_setting() in /content/Hosting/b/h/bhesco.co.uk/web/wp-content/themes/pagelines-mud/functions.php on line 26

this is really starting to confuse and frustrate me... this is a new venture we are launching and having the site down is a major problem and I am at a loss for what to do? please help?

#17 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 28 September 2012 - 05:09 PM

Did you edit the functions.php file at any point?

#18 brightgreenhomes

brightgreenhomes

    Advanced Member

  • Members
  • 43 posts
  • Framework Version:2.0

Posted 28 September 2012 - 06:09 PM

no - i haven't edited that file.
I pressed update from pagelines 2.5 to pagelines 3.0 - then the theme style sheets became deleted and the site stopped working...
thats it.
  • stebac likes this

#19 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 28 September 2012 - 06:45 PM

Updating a theme would not cause the 2010 and 2011 theme folders to become empty.

I have looked on your FTP, both wordpress theme folders are empty, and the pagelines folder only has an empty admin folder and an empty css folder.

You need to start by downloading to 2010 theme and the 2011 theme from wordpress.org, unzip them and FTP the contents into the empty dirs.

Then download pagelines.zip from your members area and do the same, making sure ALL files transfer properly. Clearly your host will not let you use the wordpress inbuilt upgrader without destroying itself.

#20 stebac

stebac

    Newbie

  • Members

  • 5 posts
  • LocationManchester, UK.
  • Country: Country Flag

Posted 28 September 2012 - 08:11 PM

Hi all.

I have had the exact same problem as brightgreenhomes tonight. Everything he has mentioned in this thread has happened to me in the exact same way. I went to update to pagelines 3.0 and something went wrong and the stylesheet has gone missing and site vanished. I originally got a white screen with a short maintenance message on it asking to check back in a few minutes.

I am also a self taught amateur and not a developer so i cant rely contribute with a solution, only add to the confusion and frustration :unsure:

I use GoDaddy hosting applications to set up Wordpress.

Luckily i was setting up a new site when it happened so i deleted everything within my hosting and started again, unfortunately it has happened the second time of trying.

I like the last post though, installing the files manually will probably be a better idea. I have a friend a little more knowledgeable than me to help me with that fortunately so i will be giving that a go.

I just thought i should post to highlight that this is not an isolated incident.





Also tagged with one or more of these keywords: Resolved, Style Sheet