Jump to content


Photo
- - - - -
Resolved

How do I hide the content titles?



This topic has been archived. This means that you cannot reply to this topic.
8 replies to this topic

#1 davidabrahamovitch

davidabrahamovitch

    Newbie

  • Members
  • 1 posts

Posted 27 September 2012 - 02:25 PM

Since upgrading, the Title of the page now shows above the content. If i delete the title, it also deletes the page name.... how do i stop it showing?

Site is shoreditchgrind.com

Thanks,
David

#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts

Posted 27 September 2012 - 02:42 PM

To hide page titles go to PageLines > Site Options > Website Setup > Page Titles

#3 lasjoh

lasjoh

    Member

  • Members
  • 12 posts

Posted 28 September 2012 - 02:31 PM

Hi. I know that this is the option to put Title's on or off on all pages. But what if I default want to show the page title, but not on the static home page? There isn't an option per page to set this on or off.

#4 theTimHunter

theTimHunter

    Advanced Member

  • Members
  • 53 posts

Posted 28 September 2012 - 03:34 PM

Hi. I know that this is the option to put Title's on or off on all pages. But what if I default want to show the page title, but not on the static home page? There isn't an option per page to set this on or off.


Use firebug to find the component then use the following code :

Please Login or Register to see this Hidden Content


...where xx is your specific home page id and .title-selector is the what ever css attribute the titles are assigned. hope this helps.

#5 catrina

catrina

    Advocate

  • Members
  • 12345 posts

Posted 28 September 2012 - 03:49 PM

Thanks for posting a solution, Tim.

@David: Please use Firebug and follow these instructions to find the selectors you need -

Please Login or Register to see this Hidden Content



#6 lasjoh

lasjoh

    Member

  • Members
  • 12 posts

Posted 28 September 2012 - 06:49 PM

Hi Tim, no, it didn't work.
In Firebug (or Chrome Inspector, that doesn;t make any difference) I see the following:



<body class="home page page-id-74 page-parent page-template-default custom responsive pagelines default full_width navbar_fixed prettify-on">
<div class="fullwidth" id="site">

So I guess the line:

body.page-id-74 .title-selector {display:none;}

added to the custom CSS should do it. But no, the title is still shown.


John

#7 catrina

catrina

    Advocate

  • Members
  • 12345 posts

Posted 28 September 2012 - 06:53 PM

John, you need to replace .title-selector with the selector for the title (which is probably h1.page-title). However, when I look at your site, I don't see the title there.

#8 lasjoh

lasjoh

    Member

  • Members
  • 12 posts

Posted 28 September 2012 - 07:02 PM

Catrina, thanks. The pagetiltle was 'Home' and that was displayed. But indeed, it's

<h1 class="entry-title pagetitle">Home</h1>

so

body.page-id-74 .pagetitle {display:none;}

dit it,

thanks both

#9 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts

Posted 28 September 2012 - 10:30 PM

The topic was marked as resolved.