Jump to content


Photo
- - - - -

Unwanted padding wen using fixed menu

menu layout

This topic has been archived. This means that you cannot reply to this topic.
7 replies to this topic

#1 sciamannikoo

sciamannikoo

    Member

  • Members
  • PipPip
  • 14 posts

Posted 27 September 2012 - 01:47 PM

Here is the real case:

Please Login or Register to see this Hidden Content



I've enabled a fixed top menu to the site, but I see an extra 50px top padding added by /wp-content/themes/pagelines/pagelines-compiled-css-1_1348751764/

To be more precise:



body.navbar_fixed .page-canvas {
  • padding-top: 50px;

}


I know I could disable it from custom CSS, but I believe that this must be disabled by pagelines itself when fixed menu is enabled.

#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts

Posted 27 September 2012 - 02:29 PM

Try changing the padding-top value to 0px and adding the CSS to Custom Code > Custom CSS. It should look like this:

Please Login or Register to see this Hidden Content



#3 sciamannikoo

sciamannikoo

    Member

  • Members
  • PipPip
  • 14 posts

Posted 27 September 2012 - 02:32 PM

@catrina, something's wrong with the code formatting in this forum: it mades your code almost unreadable.

However, as I've written, I already know how to solve the issue editing the CSS (in fact I did it already).

What I wanted to point out is that this should be done by PageLines itself.

Thank you by the way.

#4 catrina

catrina

    Advocate

  • Members
  • 12345 posts

Posted 27 September 2012 - 02:45 PM

I will point it out to developers.

#5 micahguller

micahguller

    Newbie

  • Members

  • 6 posts

Posted 27 September 2012 - 03:50 PM

It would be even better if there were an interface to control this within the settings tab for the navbar itself

#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 16555 posts

Posted 04 October 2012 - 09:11 AM

The Padding is included on purpose, to give sections that are added below the Fixed Navbar enough room. Removing this padding, may cause some sections in your header template to be very close the Fixed Nav and therefore, look very odd.

#7 sciamannikoo

sciamannikoo

    Member

  • Members
  • PipPip
  • 14 posts

Posted 04 October 2012 - 09:20 AM

@Danny, I understand that, but in the other hand the default behavior causes extra unwanted padding too.

#8 Danny

Danny

    Is Awesome!

  • Moderators
  • 16555 posts

Posted 04 October 2012 - 09:49 AM

Not sure what you mean, the padding-top:50px doesn't appear unless the Fixed Navigaton is enabled.