Jump to content


Photo
- - - - -

Supersize option for background image not working properly.

background

Best Answer paul_saccone , 07 April 2013 - 11:12 PM

I figured it out, but would love somebody to explain this to me.  

 

When I put CSS in my style.css using Pagelines Customize plugin it doesn't work. 

When I put the SAME code in the Pagelines Admin Custom Code section it DOES work.  Weird.

 

Here's the code I used to reveal the supersized bg image:

 
#page .page-canvas {
  	background-color: rgba(0, 0, 0, 0);
}



Go to the full post


  • Please log in to reply
13 replies to this topic

#1 brightideas

brightideas

    Advanced Member

  • Members

  • 30 posts

Posted 25 September 2012 - 03:56 PM

You all need to look at the supersize option and script. The large image is now just hiding behind the main content area when I set it to supersize.

When I uncheck supersize, it goes to the regular size which is way larger than what I want.

Here's the site with the supersize option on:

Please Login or Register to see this Hidden Content



And, yes, I have the site set to fixed width mode.

Thanks!

#2 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 25 September 2012 - 04:03 PM

There is a javascript error on the page, could be stopping the supersize as that likes to run last.

main.js something to do with maps?

#3 brightideas

brightideas

    Advanced Member

  • Members

  • 30 posts

Posted 25 September 2012 - 04:09 PM

I have the Store Locator plugin on this page that uses maps:

Please Login or Register to see this Hidden Content



Please don't tell me it's that because I have 150 locations to input for that plugin and it's the only one that could do what I needed it to do. I just updated it when I updated the theme a few minutes ago.

#4 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 25 September 2012 - 04:12 PM

I cant see any background image anywhere.

#5 brightideas

brightideas

    Advanced Member

  • Members

  • 30 posts

Posted 25 September 2012 - 04:14 PM

Yep, because it's behind the main content. I see the small sliver of it above the main content. Like I said, supersize shrunk it so you can't see it.

#6 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 26 September 2012 - 12:00 AM

Hi, I'm seeing a rather nice blue background stretched perfectly. Is this browser related or working everywhere?

#7 brightideas

brightideas

    Advanced Member

  • Members

  • 30 posts

Posted 26 September 2012 - 02:06 AM

That's because I turned the supersize off before the client saw the site and said, "WTF?" (They really wanted the tree background.) I downloaded the files this evening to move the site to a new server tomorrow and I wanted to get it in working condition before the move.

That background you see is 2400x2400 and not properly sized for the screen. The left side of the photo is a large tree trunk and it's usually a little more obivious that there's an entire forest there.

The background is cropped halfway through the tree trunk from the photo on this page:

Please Login or Register to see this Hidden Content



Unless it's a conflict with the store locator plug-in, the supersize doesn't seem to be working properly. I'll play around with it after the move to see if it corrects itself.

#8 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 26 September 2012 - 03:16 AM

Can't you temporarily deactivate the plugin to test?

#9 brightideas

brightideas

    Advanced Member

  • Members

  • 30 posts

Posted 10 October 2012 - 02:08 PM

I turned off the option for the plugin to load the javascript on every page. Still didn't fix the problem. Having another problem... gonna post that, too.

#10 James B

James B

    Advocate

  • Moderators
  • 4978 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 11 October 2012 - 12:58 AM

Hi,

I've just had a look at the site and the supersize isn't on at the moment. I've played about with the css to see if anything can help with the supersize off. Try the below, its not perfect but its sizing the picture better. Result comes out like this

Please Login or Register to see this Hidden Content



Please Login or Register to see this Hidden Content



#11 paul_saccone

paul_saccone

    Member

  • Members
  • 15 posts
  • LocationSan Francisco
  • Framework Version:2.3.8 (on dev version of site, not live yet)
  • Country: Country Flag

Posted 07 April 2013 - 10:53 PM

I'm having the same exact problem on a brand new install (local development system) with only PageLines and Simplicate installed.

 

When I check supersize the image is behind the content.  I can make the content transparent, but I shouldn't have to do that to get this to work.

 

Any ideas?

 

Thanks,

Paul

 



#12 paul_saccone

paul_saccone

    Member

  • Members
  • 15 posts
  • LocationSan Francisco
  • Framework Version:2.3.8 (on dev version of site, not live yet)
  • Country: Country Flag

Posted 07 April 2013 - 11:12 PM   Best Answer

I figured it out, but would love somebody to explain this to me.  

 

When I put CSS in my style.css using Pagelines Customize plugin it doesn't work. 

When I put the SAME code in the Pagelines Admin Custom Code section it DOES work.  Weird.

 

Here's the code I used to reveal the supersized bg image:

Please Login or Register to see this Hidden Content



#13 paul_saccone

paul_saccone

    Member

  • Members
  • 15 posts
  • LocationSan Francisco
  • Framework Version:2.3.8 (on dev version of site, not live yet)
  • Country: Country Flag

Posted 08 April 2013 - 06:00 AM

Please ignore my previous message.

 

In case anyone was wondering, the Pagelines Customize plugin works MUCH better if you actually ACTIVATE it.  Doh!



#14 Danny

Danny

    Is Awesome!

  • Moderators
  • 12944 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 08 April 2013 - 09:14 AM

Thanks for informing us that the issue has been resolved.







Also tagged with one or more of these keywords: background