Archived

This topic is now archived and is closed to further replies.

  • 0

Resolved What happend with my features tab?


Question

Posted · Report post

I just upgrade my framework to 2.3, my features tab is gone. Any ideas? is under another tab?

post-18110-0-98824900-1348512336_thumb.p

Share this post


Link to post
Share on other sites

12 answers to this question

Posted · Report post

Hi there, I know you've already deactivated everything but could you just disable 'contact form 7' and let me know what happens. Mark above had the same issue and this seemed to bring the features tab back. Let us know as we'll have to look into this further.

Share this post


Link to post
Share on other sites

Posted · Report post

I've noticed this as well. I had to deactive the readers, pricing columns, reader and/or profiles sections for features to re-appear. It seems as if there is limit on the amount to tabs that can be shown or perhaps a bug??

Yes you are 100% rigth. I deactivate only pricing and features is back. So there is only space for a number of tabs.

Share this post


Link to post
Share on other sites

Posted · Report post

Nope, 'contact form 7' has nothing to do with the isue of features tab disapering. I even upgrade de form before I tried the princing. nothing happend. markwphoto has the right answer.

Share this post


Link to post
Share on other sites

Posted · Report post

Yes you are 100% rigth. I deactivate only pricing and features is back. So there is only space for a number of tabs.

Are you also using Contact Form 7?? I noticed when I disable that plugin, everything works as it should. I installed a new contact form plugin and it works just fine.

Share this post


Link to post
Share on other sites

Posted · Report post

Yes we have seen this issue before, it is plugins insisting on using add_object_page() for their menus. http://pross.org.uk/truths-and-myths-pagelines-and-gravity-forms/ I blogged about it here when gravity forms were using it, they have since fixed the bug.

Problem is most plugin authors copy and paste code form other plugins so al lot of authors are still using the bugged function.

Share this post


Link to post
Share on other sites

Posted · Report post

Yes we have seen this issue before, it is plugins insisting on using add_object_page() for their menus. http://pross.org.uk/...-gravity-forms/ I blogged about it here when gravity forms were using it, they have since fixed the bug.

Problem is most plugin authors copy and paste code form other plugins so al lot of authors are still using the bugged function.

Thanks Simon for pointing me in the right direction. I modified the admin.php file from Contact Form 7 and replaced "add_object_page" with "add_menu_page" and now the Features Tab shows up fine and the "Contact" has been moved down below the Settings tab. Everything is showing up now.

Share this post


Link to post
Share on other sites

Posted · Report post

Ahh good, is it the latest version? Maybe contact the author with a patch?

Share this post


Link to post
Share on other sites

Posted · Report post

I just got an update to Contact Form 7 last night to the latest version and the problem still existed. I will certainly pass this on the the developer/author!

Share this post


Link to post
Share on other sites

Posted · Report post

The topic was marked as resolved.

Share this post


Link to post
Share on other sites

Posted · Report post

It should be there. Have you tried deactivating all of your active plugins?

Share this post


Link to post
Share on other sites

Posted · Report post

Yes I did that, deactivate and activate plug in and theme and still is not there. How I can debug?

Share this post


Link to post
Share on other sites

Posted · Report post

I've noticed this as well. I had to deactive the readers, pricing columns, reader and/or profiles sections for features to re-appear. It seems as if there is limit on the amount to tabs that can be shown or perhaps a bug??

1 person likes this

Share this post


Link to post
Share on other sites