Archived

This topic is now archived and is closed to further replies.

  • 0

Resolved Customising metabar info


Question

Posted · Report post

How do I customise how the metabar information is shown?

For instance:

- The list of categories is separated by commas? Can I change that?

- Can I make it show only one category? (my previous theme did this, with lower ID number getting priority)

- Can I use CSS to style different parts of the information. This:


<strong>[post_categories]</strong> <em> [post_date]</em>

doesn't work, but I'd like something like that.

Share this post


Link to post
Share on other sites

13 answers to this question

Posted · Report post

Thanks Rob. This hasn't been answered:

but what/where is the post loop file? Can I add code to functions.php in my base theme, or do I need to add a separate file with the same name as the post loop file?

There has to be a file somewhere in the framework that deceides that there should be a comma separating categories trough the the_category-function (BTW: default is space, not comma according to WP Codex), and I wonder if anyone know what file this is. Half the documentation for the Framework on the wiki is unfinished so it's hard to figure this out by myself.

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks Danny.

Share this post


Link to post
Share on other sites

Posted · Report post

The topic was marked as resolved.

Share this post


Link to post
Share on other sites

Posted · Report post

  1. Categories are separated by commas in WP by default. In WP, the format is changed in the category list template tag itself, which is discussed here: http://codex.wordpre...ing_Categories. The location of your category template tag should be in the post loop file, so you'd need to use the base theme to make the adjustment in that file.

Thanks, but what/where is the post loop file? Can I add code to functions.php in my base theme, or do I need to add a separate file with the same name as the post loop file?

Share this post


Link to post
Share on other sites

Posted · Report post

Please dont edit core files! The solutions was actually simple ;)

Most shortcodes accept attributes:


[post_categories sep=&nbsp;]
[/CODE]

2 people like this

Share this post


Link to post
Share on other sites

Posted · Report post

Simon: Great, that should be added to some documentation somewhere....

1 person likes this

Share this post


Link to post
Share on other sites

Posted · Report post

regarding 3. it seems like the categories class governs how the [post_categories] metainformation is shown, but I can only get the comma separator to change color with CSS:


.categories {color:#f77c0a;}

I tried adding an "a.", but it doesn't help. Any idea on why it doesn't work?

Share this post


Link to post
Share on other sites

Posted · Report post

solved 3. with Chrome Inspector

Share this post


Link to post
Share on other sites

Posted · Report post

The topic was marked as resolved.

Share this post


Link to post
Share on other sites

Posted · Report post

it's not really resolved yet.

Share this post


Link to post
Share on other sites

Posted · Report post

  1. Categories are separated by commas in WP by default. In WP, the format is changed in the category list template tag itself, which is discussed here: http://codex.wordpress.org/Separating_Categories.'>http://codex.wordpress.org/Separating_Categories. The location of your category template tag should be in the post loop file, so you'd need to use the base theme to make the adjustment in that file.
  2. I think you can show only one category by using code to exclude certain other ones. You'll need to see the WordPress Codex: http://codex.wordpress.org/
  3. You'll need to use Firebug or Chrome Development to inspect the elements in your metabar and see what customizations can be made then Custom Code > Custom CSS in Site Options to make those customizations (http://www.pagelines.com/wiki/Custom_CSS).
1 person likes this

Share this post


Link to post
Share on other sites

Posted · Report post

Try Dashboard > PageLines > Site Options > Blog And Posts

Scroll down to "Full Width Post Meta" where you'd edit the shortcodes in the same format shown.

I restored this topic to Open. Please explain further what needs to be done. Thanks.

1 person likes this

Share this post


Link to post
Share on other sites