Jump to content


Photo

Problem with custom css area

custom css

This topic has been archived. This means that you cannot reply to this topic.
3 replies to this topic

#1 Leonardo da Vinci

Leonardo da Vinci

    Super Member

  • Members

  • 158 posts

Posted 20 September 2012 - 08:15 AM

Hi guys

I hope you are fine

I have problem with custom css area , that happened after change wordpress language from (left to right to) (right to left)
I can write on it but the problem is when I write a code all symbols like (/ , . , . : ' " ) goes to beginning of code line .like

} #care {width:20px ;


The ( } ) goes to beginning of code line

but if I keep writing , the ( } ) return to right place but the code I think will be wrong


#care {width:20px ;}w


Please could you help me to solve this problem

Thanks

#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 17580 posts

Posted 20 September 2012 - 09:23 AM

Hi,

If you're using a child theme, can you add the following code please to your child themes style.css

 
.CodeMirror pre {
text-align: left !important;
}

See if that resolves the issue.

#3 Leonardo da Vinci

Leonardo da Vinci

    Super Member

  • Members

  • 158 posts

Posted 20 September 2012 - 12:32 PM

Thanks Danny

But I am using Pagelines theme
I would like to create an Arabic website (right to left ) , so I installed an Arabic version of wordpress to my PC after that I uploaded it to my sub domain , after that I went to dashboard and i saw all things start from right to left ( that is what I want )
but after apply pageline theme all thing good but when i would like to put some codes to custom css area the codes do not arrange in right way
I think the problem in RTL , The css custom code area should keep its L to R Form . How can do that .

By the way what do you mean by ! important , it is a code or just a note

Thanks a lot

#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 17580 posts

Posted 21 September 2012 - 12:09 PM

Can you try this please:

 
.CodeMirror pre {
text-align: right !important;
}

If the code I gave you doesn't resolve your issue then it may well be a bug with new code editor when RTL is enabled like you said. If you can reply and confirm this I will reported this to our developers for you.