Archived

This topic is now archived and is closed to further replies.

  • 0

Resolved Excerpts and thumbnails


Question

Posted · Report post

We use the custom excerpt field; most of our posts also have an image / thumbnail. But Pagelines is not displaying the thumbnail and it's using an auto-generated excerpt.

What can I do to display the excerpt field+thumbnail?

I have adjusted settings in Blog and Posts.

Example: http://www.wemedia.com/blog

Thanks.

Share this post


Link to post
Share on other sites

5 answers to this question

Posted · Report post

Thanks. That seemed to do it. All of that had been set previously. The only change was on the feed - I had been using full posts.

(I also had some lag in seeing the changes, probably due to cache issues).

I think I've solved the thumbnail mystery as well, but I don't like it. It appears that Pagelines uses the Featured image for the thumbnail. My previous theme had used the first image to set the thumbnail (or I could set a unique thumbnail via custom field.

Is there a way to set a thumbnail that's different from the Featured image?

Share this post


Link to post
Share on other sites

Posted · Report post

Thanks, this helped me figure out that Pagelines uses the Featured Image for thumbnail. My previous theme(s) used the first image in the post to set a thumbnail - and I could also change the thumbnail with a custom field.

Share this post


Link to post
Share on other sites

Posted · Report post

If you go to Dashboard > PageLines > Site Options > Blog And Posts and scroll down to Post Thumbnail Placement and make sure that you have Posts/Blog Page and Single Posts (if you want them there) checked, for thumbnails.

For excerpts, scroll to Post Excerpt or Summary Handling and make sure the checkbox is ticked for Posts/Blog Page.

Scroll even further down to Excerpt Length and remove the default 55, leaving it blank.

Save settings.

Now go to Dashboard > Settings > Reading and make sure that for For each article in a feed, show you have Summary selected. Save.

Go to Dashboard > Settings > Media and make sure you have an image size selected (the default is 150 wide and 150 high). Save.

Finally, go to Dashboard > Settings > Permalinks. Change nothing. Simply save.

Check and you should have thumbnails and excerpts working properly.

Share this post


Link to post
Share on other sites

Posted · Report post

The topic was marked as resolved.

Share this post


Link to post
Share on other sites