Jump to content


Photo
- - - - -
Resolved

Recently an error occurred while creating the CSS / JS minify cache: Unable to cache remote file: "/?pageless=1"

W3 Total Cache

  • Please log in to reply
20 replies to this topic

#1 zouleo

zouleo

    Super Member

  • Members
  • 165 posts
  • LocationStockholm
  • Country: Country Flag

Posted 16 September 2012 - 09:12 AM

I'm getting this error more frequently from the W3 Total Cache plugin

Recently an error occurred while creating the CSS / JS minify cache: Unable to cache remote file: "

Please Login or Register to see this Hidden Content



It seems as if pageless is very slow. What can I/you do to fix?

#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 17977 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 16 September 2012 - 11:07 AM

Hi,

The PageLines compiled CSS file isn't a file and is generated. This means that W3 Total Cache can not minify it, if you wish to remove all the white space in the file. Please use the Minify option in PageLines > Site Options > Advanced > Minify.

Also, You PageLines Compiles CSS loads instantly, if your site is loading slow, this is most likely related to either your content (images), plugins or custom code (google, facebook) etc...

Please Login or Register to see this Hidden Content

<== Loads super fast!

#3 zouleo

zouleo

    Super Member

  • Members
  • 165 posts
  • LocationStockholm
  • Country: Country Flag

Posted 16 September 2012 - 11:43 AM

I want to combine the Pagelines CSS with other CSS files. It should be possible even if it is generated.

No, it's not superfast. It's slow. Wait: 1,29 seconds.

Please Login or Register to see this Hidden Content



Anyway - all I want is to W3 Total Cache to work. Any recommendations?

#4 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 16 September 2012 - 12:07 PM

Check the 2.2.2 release notes in the announcements forum ;)

#5 zouleo

zouleo

    Super Member

  • Members
  • 165 posts
  • LocationStockholm
  • Country: Country Flag

Posted 16 September 2012 - 12:12 PM

Thank you!

Can you explain how to use LESS_FILE_MODE with W3 Total Cache? Most importantly, is the filename of the .css file permanent so that I can include it in W3 Total Cache? I didn't see a mention of this in the release notes.

Should I use PL_NO_DYNAMIC_URL or not?

#6 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 16 September 2012 - 12:15 PM

LESS_FILE_MODE simply creates a real css file, not a dynamically loaded one. W3 cache does not 'include' css files, unless your using the minifier, which breaks javascript btw, just a free warning there.

#7 zouleo

zouleo

    Super Member

  • Members
  • 165 posts
  • LocationStockholm
  • Country: Country Flag

Posted 16 September 2012 - 12:27 PM

I'm combining css files using W3 cache. LESS_FILE_MODE seems to be what I'm looking for. Where is the file located, including file name, please?

I'm not using CSS or Javascript minification. Only CSS combine. So I guess your warning doesn't apply?

Thank you for your help.

#8 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 16 September 2012 - 12:29 PM

Enable the mode, you will see the filename in your pagesource.

#9 zouleo

zouleo

    Super Member

  • Members
  • 165 posts
  • LocationStockholm
  • Country: Country Flag

Posted 16 September 2012 - 12:31 PM

I did. But it seems as if the file name is dynamic compiled-css-1347482654.css? So I can't use it with W3 Total Cache?

#10 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 16 September 2012 - 12:33 PM

Guess not then unless the file box allows wildcards. Maybe a question for the plugin author?

#11 zouleo

zouleo

    Super Member

  • Members
  • 165 posts
  • LocationStockholm
  • Country: Country Flag

Posted 16 September 2012 - 12:34 PM

So if I use PL_NO_DYNAMIC_URL it will not help?

#12 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 16 September 2012 - 12:35 PM

No, that will use the ?pageless=nnnn url, and make it dynamic again

#13 zouleo

zouleo

    Super Member

  • Members
  • 165 posts
  • LocationStockholm
  • Country: Country Flag

Posted 16 September 2012 - 12:37 PM

Ok. Thank you. You are very helpful!

Could you please tell me how often you are refreshing the file in the cache?

#14 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 16 September 2012 - 12:38 PM

Your site has 100 http requests, and a payload of nearly 2Mb you should try and cut that down or use a CDN, combining css isnt going to make that much difference.

#15 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 16 September 2012 - 12:40 PM

Ok. Thank you. You are very helpful!

Could you please tell me how often you are refreshing the file in the cache?

Whenever you click save in the options it is recompiled.

#16 zouleo

zouleo

    Super Member

  • Members
  • 165 posts
  • LocationStockholm
  • Country: Country Flag

Posted 16 September 2012 - 12:40 PM

Yes. I will do that also. Thank you.

Can you tell me how often you refresh the cached css file please?

#17 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 16 September 2012 - 01:02 PM

The topic was marked as resolved.

#18 zouleo

zouleo

    Super Member

  • Members
  • 165 posts
  • LocationStockholm
  • Country: Country Flag

Posted 16 September 2012 - 01:36 PM

Why?

#19 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 16 September 2012 - 03:52 PM

Well, Your question was answered wasnt it?

#20 mtaus

mtaus

    Super Member

  • Members

  • 137 posts
  • Country: Country Flag

Posted 14 September 2013 - 05:23 PM

I'm getting slow load times on the dynamically generated file, as well. I added define( 'LESS_FILE_MODE', true ); to my wp-config.php, but it appears that my the dynamic version is still loading in source.

 

The

Please Login or Register to see this Hidden Content

 are a bit ambiguous. It reads:  "Now every time you save the PageLines settings a new file will be written out."

 

Does this mean that I should hit "Publish"? If so, I've done this and I'm still getting the generated version.

 

Please Login or Register to see this Hidden Content







Also tagged with one or more of these keywords: Resolved, W3 Total Cache