Jump to content


Photo
- - - - -
Resolved

Max Post Size: Please Help!

post size url url too long link too long

  • Please log in to reply
11 replies to this topic

#1 iamtheeverydaygirl

iamtheeverydaygirl

    Advanced Member

  • Members
  • 79 posts

Posted 14 September 2012 - 12:46 AM

Hi there,

So I'm having an issue! Since upgrading -- each time I hit "save" or "update" in my back end, I go to an error page that is telling me that the URL link is too long (2000+ characters).

Mentioned it on another question here -- and someone directed me to tell my hosting company. Did that, they made some changes, but the problem still remains. My hosting company is directing me back here because they cannot understand why the links would be SO long.

The problem is that I cannot make ANY changes to my website because I cannot click "save" or "update" anywhere on the site. It's driving me bonkers.

Does anyone here have any idea why the links would be SO long and what I can do find a solutions???

Thank you SO much!!

Jennifer

#2 iamtheeverydaygirl

iamtheeverydaygirl

    Advanced Member

  • Members
  • 79 posts

Posted 14 September 2012 - 12:56 AM

My hosting company (Site5) has told me that they cannot lengthen the URL on the server.

Is this normal?

#3 iamtheeverydaygirl

iamtheeverydaygirl

    Advanced Member

  • Members
  • 79 posts

Posted 14 September 2012 - 01:57 AM

Site 5 has requested I provide you with the following:

Hello Jennifer,

Can you please provide Pagelines with this error:

[14-Sep-2012 01:04:26] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') WHERE p.post_date > '2012-02-14 21:32:45' AND p.post_type = 'attachment' AND p' at line 1 for query SELECT p.* FROM wp_posts AS p INNER JOIN wp_term_relationships AS tr ON p.ID = tr.object_id INNER JOIN wp_term_taxonomy tt ON tr.term_taxonomy_id = tt.term_taxonomy_id AND tt.taxonomy = 'category' AND tt.term_id IN () WHERE p.post_date > '2012-02-14 21:32:45' AND p.post_type = 'attachment' AND p.post_status = 'publish' AND p.ID != '919' ORDER BY p.post_date ASC LIMIT 1 made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/pagelines/single.php'), setup_pagelines_template, pagelines_template_area, do_action('pagelines_template'), call_user_func_array, PageLinesTemplate->print_section_html, PageLinesTemplate->buffer_template, PageLinesSection->section_template_load, PageLinesContent->section_template, pagelines_template_area, do_action('pagelines_main'), call_user_func_array, PageLinesTemplate->print_section_html, PageLinesTemplate->buffer_template, PageLinesSection->section_template_load, PageLinesPostNavCat->section_template, next_post_link, adjacent_post_link, get_adjacent_post

This seems to be the cause of this issue.

PageLines Custom LESS/CSS error.
parse error: failed at `/”> ` line: 845

Thanks,

Florin Martinica

Please advise on how to move forward.

#4 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 14 September 2012 - 01:21 PM

Hi Florin, you have 3 problems here.

1. your POST size is too low, i think the default for PHP is 2M, it is not the url length its the amount of data the browser can send to the server using POST method.
your host is confusing it with url length.

2. Because of the confusion above they picked a random database error that is completely unrelated to confuse you, PageLines does not make any direct database calls, it uses the wordpress options methods.

3. you have a syntax error in your css causing the LESS CSS compiler to throw that error, run your css through a css validation page, W3C host one.

#5 iamtheeverydaygirl

iamtheeverydaygirl

    Advanced Member

  • Members
  • 79 posts

Posted 14 September 2012 - 06:26 PM

Hi Simon:

I've been working with Site5 (my hosting company) and they shared with me that it's not on their end, it's Pagelines .... basically, the two are not compatible.

They are saying that it is NOT the post size -- they upped it to 64M and the problem still exists. I'm going to copy what they've said below. I'm a little lost -- wondering if pagelines has a compatibility issue with hosting companies?? If you could please take a look at their message ... and I copied and pasted the problem url at the bottom. They thought that the PageLine developers they should be able to better review the matter to see what may of caused their script to generate such a long URI.

Thanks for your help!



From Site5:
***********************************
The issue at hand is that your plugin is creating an extremely long URI which can't be processed by the server. By URI, I mean the address that is showing in your browsers address bar. You are located on an Apache based server. There is a limit of URI characters allowed, which is 8190 as outlined here:

Please Login or Register to see this Hidden Content



The above is the specific limit you are hitting. This limit is called the LimitRequestLine. When your plugin, PageLines, tries to submit data (when you hit Save, Update, etc) it's sending a request to the server via a URI that is over 9500 in size. As you can see, this limit is well over the allowed number of 8190. Once this limit is exceeded the server can no longer process the data/request, so you receive the error being provided.

Unfortunately, as it is now the PageLines plugin is not compatible with our server setup due to this. This limit cannot be changed and is standard to all Apache based servers. It may be possible PageLines have a method to get around this for you, but at this time it's not related to any PHP value settings. The php.ini "POST size" setting isn't going to fix this matter(we had already increased this earlier for you), as it's not PHP causing the error. It's Apache, the web server. It may be possible the CSS error is causing the issue, but you would need to check back with the PageLine developers in regards to that. If it helps them test this further for you I have placed a file on your account which contains the failing URI:

Please Login or Register to see this Hidden Content



#6 iamtheeverydaygirl

iamtheeverydaygirl

    Advanced Member

  • Members
  • 79 posts

Posted 14 September 2012 - 06:29 PM

FYI -- I'm currently using Pagelines Framework Versis 2.2.5

#7 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 14 September 2012 - 06:40 PM

Well, we've never ever run into any post size problems before, maybe thats the limit of $4.95 a month hosting :(

#8 iamtheeverydaygirl

iamtheeverydaygirl

    Advanced Member

  • Members
  • 79 posts

Posted 14 September 2012 - 06:41 PM

One last thing from Site5 .... They believe that it could be a bug within the theme/plugin. From them, "When I take a look at the source code, they are submitting the form data via POST, however the URI is still being populated with the query string. This would only make sense if they were using a GET type of form method to send the data to the server(they should understand this if you forward this email to them). When I checked their demo site that wasn't the case. It doesn't send the data to the URI, but via POST like it should."

#9 iamtheeverydaygirl

iamtheeverydaygirl

    Advanced Member

  • Members
  • 79 posts

Posted 14 September 2012 - 06:44 PM

But it doesn't sound like it IS a post size problem.

I've been using the two together very successfully since last November. Upgrading the other day to 2.2.5 is when all these problems started.

Could it be a bug w/ in the plugin?

And do I have any options right now? Can I de-grade back down to the last version? Or change my css ANYWHERE else besides in the site options under dashboard?

I would be willing to change the hosting company -- I'm just not quite positive that that's the problem. It sounds like they have customers on pagelines, on 2.2.5 and they are NOT experiencing these problems.

#10 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 14 September 2012 - 06:46 PM

There is nothing wrong with the framework, sure try deactivating any plugins you have installed to try it. You can download the last stable version 2.1.6 i think it was from LauchPad.

#11 iamtheeverydaygirl

iamtheeverydaygirl

    Advanced Member

  • Members
  • 79 posts

Posted 14 September 2012 - 08:12 PM

My hosting site helped me fix the problem! They were able to clear out my custom code and have me start over from scratch.

#12 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 14 September 2012 - 08:42 PM

The topic was marked as resolved.





Also tagged with one or more of these keywords: Resolved, post size, url, url too long, link too long