Jump to content


Photo
- - - - -
Resolved

Transferring site from MAMP local to live

MAMP local server live

  • Please log in to reply
26 replies to this topic

#1 grintstick

grintstick

    Advanced Member

  • Members
  • 30 posts
  • LocationLondon

Posted 13 September 2012 - 01:43 PM

Hi - I'm trying to transfer my site from working on it locally using MAMP to the live site. When I do this, following correct instructions (I think), the result is as you see it on www.minidynasty.com As you can see the site has not transferred properly - the site is fully working with images and so on on the MAMP site.

Are there extra things I need to do when transferring? Do I have to do anything with image tags and so on? Help much appreciated. Adam.

#2 batman

batman

    Bat Learning

  • Members

  • 2159 posts
  • LocationBuenos Aires, Argentina
  • Framework Version:DMS
  • Country: Country Flag

Posted 13 September 2012 - 02:09 PM

Hi Adam
Your images are at folder
"YOUR SITE" / wp-contents/ uploads / 2012 / 09 (if you upload this month or 08 / 07 according the month)
You can try transfer it via FTP

#3 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 13 September 2012 - 03:31 PM

batman is right. If the images are in the wrong directories (in this case, the wrong subdirectories because of the upload times), they're not going to work on the site.

#4 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 14 September 2012 - 12:26 PM

All your images have the wrong urls

Please Login or Register to see this Hidden Content



#5 grintstick

grintstick

    Advanced Member

  • Members
  • 30 posts
  • LocationLondon

Posted 14 September 2012 - 12:41 PM

Hi - thanks for the responses. Sorry for being slow here but if they are in the wrong directories due to the date problem, what would the correct directory be? Should I just take them out of the date directory entirely, or create a new directory? thanks...

#6 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 14 September 2012 - 12:54 PM

They are not in the wrong DIRs te links to them are wrong, click the link i posted above you will see your site url is in there twice.
Did you use some kind of database replacement tool?

#7 grintstick

grintstick

    Advanced Member

  • Members
  • 30 posts
  • LocationLondon

Posted 14 September 2012 - 01:01 PM

Hi Simon - thanks for your response. So should I change this in the settings within wordpress for each image? What should the correct URL's be? Perhaps you could point me towards some documentation on it if it exists? thanks...

#8 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 14 September 2012 - 01:02 PM

How did the images get the new urls?

#9 grintstick

grintstick

    Advanced Member

  • Members
  • 30 posts
  • LocationLondon

Posted 14 September 2012 - 01:32 PM

I see what you mean with the doubled up URL's. Not entirely sure how that's happened...

I followed this for transferring from MAMP:

Please Login or Register to see this Hidden Content



and also watched this:


and looked at the wordpress codex. What do you think is the way forward? thanks...

#10 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 14 September 2012 - 01:35 PM

Yea looks like you messed up the url replacement part, so 2 choices, repair each one, or start again ;)

#11 grintstick

grintstick

    Advanced Member

  • Members
  • 30 posts
  • LocationLondon

Posted 14 September 2012 - 01:37 PM

p.s. i think the images got the new URL's possibly by me using the find and replace tool in a text editor after I exported the SQL database from my offline site. So I changed the localhost URL's to the live ones using this tool... maybe it happened there... although I just looked at the SQL file and there's no doubling up in it. hmmmmm....

#12 grintstick

grintstick

    Advanced Member

  • Members
  • 30 posts
  • LocationLondon

Posted 14 September 2012 - 01:42 PM

ok thanks... although it seems odd that the doubling up is not happening in my SQL file which is where I do the URL replace, so if I do it again I think the file will remain the same... but I still get doubled up URL's on the images. Do you think it could be coming from somewhere else other than the SQL file?

#13 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 15 September 2012 - 12:03 AM

Marking this resolved for moderation purposes....

Basically your going to have to run the replace in the SQL again to fix those urls.

#14 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 15 September 2012 - 12:03 AM

The topic was marked as resolved.

#15 grintstick

grintstick

    Advanced Member

  • Members
  • 30 posts
  • LocationLondon

Posted 18 September 2012 - 01:04 PM

Simon -
I've managed to re-do the SQL file and am now at least getting some of the images coming up correctly. However, the formatting is all over the place and each page seems to be displaying elements that were hidden in my offline version. Various style things have not come across at all, like the colour of the background, fonts and so on, so just wonder how to fix this? URL is minidynasty.com.

Help appreciated...

Adam.

#16 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 18 September 2012 - 01:13 PM

Are you editing the SQL file before you import it?

#17 grintstick

grintstick

    Advanced Member

  • Members
  • 30 posts
  • LocationLondon

Posted 18 September 2012 - 05:31 PM

Yes, I'm changing the URL's from my localhost to my live URL, but that's it.

#18 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 18 September 2012 - 05:52 PM

Right well, that url will be stored in serialized data, are you taking that into account?
You cannot edit serialized data, it breaks it.

for example, it might show it as:

Please Login or Register to see this Hidden Content

then you change banana for apple

Please Login or Register to see this Hidden Content


PHP will now load that value as NULL because the string length is wrong!, should be 17 chars, see? You cant just edit serialized data.

#19 grintstick

grintstick

    Advanced Member

  • Members
  • 30 posts
  • LocationLondon

Posted 18 September 2012 - 06:19 PM

ok understood... but in that case how do I change the URL's in the SQL file to reflect my live domain. Looking at lots of tutorials this is exactly what it tells me to do. Any ideas how to get round this?

#20 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 18 September 2012 - 06:21 PM

You have 2 choices, use MAMP with virtual hosts, and then the urls will all be the same, locally and remote or import your SQL into remote then use a search and replace plugin to unserialize, edit then reserialize the data.





Also tagged with one or more of these keywords: Resolved, MAMP, local server, live