Jump to content


Photo
- - - - -

Fix NavBar moves in Mobile View


  • Please log in to reply
9 replies to this topic

#1 The Farside

The Farside

    Member

  • Members

  • 15 posts
  • Framework Version:2.4.1
  • Country: Country Flag

Posted 24 August 2012 - 05:28 PM

I've been working on getting a new site up and running, been working on it around a week now. I've enabled a mobile view on it and the fixed navigation bar as well. When I use an iPhone, iPod Touch, iPad or an android device, there are times where the NavBar floats as I scroll and it sticks in the middle of the screen at times as well. This does not always happen. I would like to find a fix which ensures this doesn't ever happen. Not sure how to go about it though. Is there a way to make sure it stays in place 100% of the time? Also is zooming in mobile view possible?

#2 James B

James B

    Advocate

  • Moderators
  • 5126 posts
  • LocationSurrey - UK
  • Country: Country Flag

Posted 25 August 2012 - 01:58 AM

Hi parabased, So far I've not been able to replicate the problems you've experienced. But have you taken a look at the mobile menu available in the store

Please Login or Register to see this Hidden Content

If that's not an option try looking at downloading our free Browser Specific CSS plugin, this will allow you to target the specific CSS for mobile menus to implement a fix.

Please Login or Register to see this Hidden Content



#3 The Farside

The Farside

    Member

  • Members

  • 15 posts
  • Framework Version:2.4.1
  • Country: Country Flag

Posted 25 August 2012 - 03:43 AM

Thanks for the reply. I will post a screenshot from my iPad when I get a chance, it's getting late here so it'll probably be tomorrow before I get it off the iPad to here.

#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 25 August 2012 - 05:51 PM

We look forward to your update.

#5 The Farside

The Farside

    Member

  • Members

  • 15 posts
  • Framework Version:2.4.1
  • Country: Country Flag

Posted 25 August 2012 - 11:21 PM

Here it is. Sorry for the wait!
This doesn't always happen but it does appear around 50/50.
This image is from my iPad (3rd gen) device.

Posted Image

#6 Danny

Danny

    Is Awesome!

  • Moderators
  • 15084 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 26 August 2012 - 11:54 AM

Hi, I have just visited your site on my iPad and the Fixed Nav, remains fixed for me. Has this issue been resolved ?

#7 The Farside

The Farside

    Member

  • Members

  • 15 posts
  • Framework Version:2.4.1
  • Country: Country Flag

Posted 28 August 2012 - 04:17 PM

Hi Danny, It does still happen. But right now it appears to only occur when you go to type something in via comments or the forms. Once you are finished, it appears to go back to where it was. Not sure why that happens. Any ideas or suggestions?

#8 Danny

Danny

    Is Awesome!

  • Moderators
  • 15084 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 29 August 2012 - 12:13 PM

Hi Parabased, I had a colleague test this for me and he confirmed that when you fill out the comments form the NavBar sticks. Therefore, I have reported the issue for you.

#9 The Farside

The Farside

    Member

  • Members

  • 15 posts
  • Framework Version:2.4.1
  • Country: Country Flag

Posted 30 August 2012 - 05:13 PM

Thanks, Danny!

#10 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 30 August 2012 - 05:23 PM

Will just leave this open for when there are updates