Jump to content


Photo
- - - - -
Resolved

Buddypress style issues



Best Answer davemoppert , 02 December 2012 - 07:15 PM

I started over and rebuilt from a fresh wordpress install.  Don't have the problem now.  Weird, but glad it is fixed now.  

Go to the full post


  • Please log in to reply
26 replies to this topic

#1 davemoppert

davemoppert

    Super Member

  • Members

  • 149 posts
  • Country: Country Flag

Posted 22 August 2012 - 07:34 AM

I updated the Buddypress plugin from the pagelines store and now the styles are all out of whack. All the buddypress pages span the full width of the browser for some reason. Also, the buddypress options have disappeared in the pagelines settings. I can't figure out where to set up the buddypress pages in the pagelines settings. The base theme is activated, and the buddypress template pack plugin is installed. When I go to Appearance > BP Compatibility and click on reset, after I save it, I get an message that says: "You'll need to activate a BuddyPress-compatible theme to take advantage of all of BuddyPress's features. We've bundled a default theme, but you can always install some other compatible themes or update your existing WordPress theme." Did I do something wrong? Is there something new about the latest Buddypress plugin in the Pagelines store?

#2 davemoppert

davemoppert

    Super Member

  • Members

  • 149 posts
  • Country: Country Flag

Posted 22 August 2012 - 08:18 AM

I messed with the CSS to try and fix it... It is (kinda) working, but doesn't feel like the best solution... Isn't buddypress supposed to be in the .content-pad div?? cause it's not. .buddypress-page #dynamic-content { width: 940px; margin: 0 auto; } .buddypress-page #content { min-height: 500px; padding: 0px; width: 620px; float: left; }

#3 Danny

Danny

    Is Awesome!

  • Moderators
  • 16952 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 22 August 2012 - 10:59 AM

Hi, I have just installed the latest BuddyPress, PageLines Framework and Wordpress and see no issue. Therefore, can you provide screenshots and links to where you're seeing these issues please.

#4 davemoppert

davemoppert

    Super Member

  • Members

  • 149 posts
  • Country: Country Flag

Posted 22 August 2012 - 05:03 PM

I commented out the custom styles to the CSS so you can see what Is going on.

Please Login or Register to see this Hidden Content

The buddypress content spans the full width of the browser. I want it the buddypress content to only span the width of the content area. I also would like the page to include the sidebar on both sides of the content (or at least reflect the page layout mode chosen for each buddypress page)... I need some sidebar widgets to display on the buddypress pages, but for some reason it shows up underneath the content (most likely because the content spans the full width).

#5 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 22 August 2012 - 09:34 PM

Dave, you may have to run the BP Compatibility thing again to update BuddyPress and the theme together. Have you tried that?

#6 davemoppert

davemoppert

    Super Member

  • Members

  • 149 posts
  • Country: Country Flag

Posted 22 August 2012 - 09:37 PM

I updated buddypress pagelines plugin. After I did that, it broke the styles. After it broke the style, I reset the settings (multiple times) in the BP Compatibility plugin, but it did not help... Is there a step I am missing?

#7 davemoppert

davemoppert

    Super Member

  • Members

  • 149 posts
  • Country: Country Flag

Posted 23 August 2012 - 05:35 AM

Nothing is working... :( Please help.

#8 davemoppert

davemoppert

    Super Member

  • Members

  • 149 posts
  • Country: Country Flag

Posted 23 August 2012 - 05:50 AM

All the Buddypress page options are not there either. Before there were default page options for buddy press. Now there isnt.

#9 Danny

Danny

    Is Awesome!

  • Moderators
  • 16952 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 23 August 2012 - 07:55 AM

Hi Dave, Are you using any cache plugin ? Can you disable all other plugins except for PageLines plugins and BuddyPress and see if this resolves your issue.

#10 davemoppert

davemoppert

    Super Member

  • Members

  • 149 posts
  • Country: Country Flag

Posted 23 August 2012 - 04:16 PM

No. In fact, I deactivated all of the plugins and reset multiple times as well. It seems like the BUDDYPRESS pages do not follow the same page structure as Pagelines (But I thought that is what the Pagelines Buddypress plugin was supposed to fix)... I can offer login credentials if someone would be kind enough to look at the site.

#11 Danny

Danny

    Is Awesome!

  • Moderators
  • 16952 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 24 August 2012 - 11:23 AM

Hi Dave, Like I mentioned in my previous post, I have installed BuddyPress and everything is working as intended. Therefore, can you disable all non-PageLines plugins and then enable the PageLines debug mode please. You can do this by logging into your Wordpress Admin Dashboard > PageLines > Site Options > Advanced > PageLines debug. Once you have completed the above, can you reply here please, informing us.

#12 davemoppert

davemoppert

    Super Member

  • Members

  • 149 posts
  • Country: Country Flag

Posted 27 August 2012 - 06:42 PM

Hi Danny, I deactivated all of the plugins (except for buddypress) that are not Pagelines plugins. The only plugins activated are: BuddyPress BuddyPress for Pagelines BuddyPress Template Pack Pagelines Customize Pagelines Sections I activated the debug as requested. I also reset the Buddypress Template Pack again for good measure - but nothing changed :( Thanks for your help!

#13 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 27 August 2012 - 09:21 PM

Dave, shoot me a message via the Inbox at the top of this page with admin login credentials. I'll take a look.

#14 davemoppert

davemoppert

    Super Member

  • Members

  • 149 posts
  • Country: Country Flag

Posted 12 September 2012 - 06:29 AM

Any updates on this? I gotta get Buddypress fixed...

#15 Danny

Danny

    Is Awesome!

  • Moderators
  • 16952 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 12 September 2012 - 08:17 AM

Hi Dave,

Did you send Rob a PM at all ?

If so, can you send him another one as we have just switch forums.

#16 davemoppert

davemoppert

    Super Member

  • Members

  • 149 posts
  • Country: Country Flag

Posted 13 September 2012 - 11:38 PM

Yes I did. He responded a week ago letting me know he'd look into it. Have not heard anything. Any new developments? Need help.

#17 davemoppert

davemoppert

    Super Member

  • Members

  • 149 posts
  • Country: Country Flag

Posted 23 September 2012 - 11:44 PM

Please help! The Pagelines Buddypress plugin does not seem to do anything... :/

#18 davemoppert

davemoppert

    Super Member

  • Members

  • 149 posts
  • Country: Country Flag

Posted 24 September 2012 - 12:01 AM

Let me re-iterate the issue:

I have buddypress installed on my Pagelines site BUT Buddypress pages are not displaying properly.

The buddypress content spans the full width of the browser. I want it the buddypress content to only span the width of the content area. I also would like the page to include the sidebar on
both sides of the content (or at least reflect the page layout mode chosen for each buddypress page)... I need some sidebar widgets to display on the buddypress pages, but for some reason it shows up underneath the content (most likely because the content spans the full width).

You can see what I am talking about here:

Please Login or Register to see this Hidden Content



The page should have a sidebar on the left, the buddypress content, and another sidebar on the right.

I installed the buddypress compatibility plugin and ran the setup on it (multiple times) - still I get an error message stating: "You'll need to

Please Login or Register to see this Hidden Content

to take advantage of all of BuddyPress's features. We've bundled a default theme, but you can always

Please Login or Register to see this Hidden Content

or

Please Login or Register to see this Hidden Content

.".

I also installed the Budddypress for Pagelines plugin from the Pagelines store. After installing this plugin, nothing changed... I do not even see any additional settings - not really sure what this plugin does.

The wordpress installation is up to date. The pagelines theme is up to date. The buddypress plugin is up to date. The buddypress compatibility plugin is up to date. The Buddypress for pagelines plugin is up to date.

I am at a loss... I have deactivated all other plugins to troubleshoot... didn't help. Rob has looked into this issue for me and said that I have done nothing wrong with the installation, and that he is working on it, but I have not heard anything from him in a while.

I can offer login credentials for anyone who thinks they can help...

#19 meilena

meilena

    Advanced Member

  • Members
  • 62 posts
  • Country: Country Flag

Posted 25 September 2012 - 01:12 PM

Hi Dave,

I am also checking on this for you to see what we can do, hopefully I will hear something soon and can give you an update. Thanks so much for your patience :D

#20 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 25 September 2012 - 01:29 PM

I just installed buddypress, and a child theme, the template pack and its all working properly all layouts.
Actually the CSS looks better without the pagelines-buddypress plugin.

So have you tried without that activated?





Also tagged with one or more of these keywords: Resolved