Jump to content


Photo

Background image not displaying | CSS busted?


Best Answer Rob , 13 August 2012 - 01:59 AM

I'm seeing a background now, so I guess this is resolved. Glad to have helped! Go to the full post


This topic has been archived. This means that you cannot reply to this topic.
11 replies to this topic

#1 storm09

storm09

    Advanced Member

  • Members
  • 96 posts

Posted 12 August 2012 - 03:03 AM

Hi - My background image isn't showing on this website http://www.totalrisk.co.nz/ from what I could gather from this post http://www.pagelines...on-homepage/p1 is that there's a problem with my Custom CSS. So I was wondering if someone could please check it and confirm its correct. Thank you.

body{}

#primary-nav ul.main-nav li a {
font-size: 13px;
}
h1 {
font-family: "myriad-pro",sans-serif;
font-style: normal;
font-weight: 700;
}
h2 {
font-family: "myriad-pro",sans-serif;
font-style: normal;
font-weight: 600;
}
body {
font-family: "myriad-pro",sans-serif;
font-style: normal;
font-weight: 400;
}
body #content_sidebar .widget-title {
background-color: #FFFFFF;
color: #000000;
}
#sidebar_primary .widget-title {
background-color: #01538d;
color: #FFFFFF;
padding-left: 5px;
}
#feature_slider .addthis_toolbox {
display: none; important!
}
#footer a:hover {
text-decoration: underline;
}
#text-7 h3 { text-indent: -99999px; }
}

If this CSS is correct - I can then begin testing each plugin.

#2 Danny

Danny

    Is Awesome!

  • Moderators
  • 17618 posts

Posted 12 August 2012 - 10:01 AM

Hi, How are you adding your background image to your website, as the CSS you have provide above, has no reference to a background image. You're using Platform Pro 1.5.2 and not the latest version 1.5.3. Can you provide more information please, as I have also reviewed your sites CSS and see nothing regarding a background image.

#3 storm09

storm09

    Advanced Member

  • Members
  • 96 posts

Posted 12 August 2012 - 11:03 AM

Hi Danny Basically, my client called me and said their site was a mess. I've since fixed 57 broken links but the my custom css isn't working which is now my biggest issue. I added a background jpg via the media library link. The preview of it displays as per normal, but its not displaying. There's just a black background showing (Fixed Width Framework) which you can see now. I can't change the colours. They're not working. Which is why I thought there may be an issue with my Custom CSS code. I disabled/enabled all the plugins, refreshing the homepage each time with CTRL + F7 but nothing. Still black and none of the code is working as it should. I'm running out of outs here. I'll upgrade to 1.5.3 and see what that does.

#4 batman

batman

    Bat Learning

  • Members

  • 2203 posts

Posted 12 August 2012 - 11:27 AM

Hi storm
I suppose that in this you have an error
 #feature_slider .addthis_toolbox {
	display: none; important!
	}
is
 #feature_slider .addthis_toolbox {
	display: none !important;
	}


#5 Danny

Danny

    Is Awesome!

  • Moderators
  • 17618 posts

Posted 12 August 2012 - 11:27 AM

Hi,

OK, upgrade to 1.5.3 and also you have a minor issue with your custom CSS.

 #feature_slider .addthis_toolbox {
	display: none; important!
	}

As you can see above this is not valid and it should be:

 #feature_slider .addthis_toolbox {
	display: none important!;
	}


#6 storm09

storm09

    Advanced Member

  • Members
  • 96 posts

Posted 12 August 2012 - 12:35 PM

Upgraded to 1.5.3 which solved my code issues. Stoked. I changed the code you suggested above, but its showing the + above my H1 titles now. If I can get rid of that I'm good to go. This code works better for me because it doesn't place the Add This links in the slider. #feature_slider .addthis_toolbox { display: none; important! } Just have to figure out how to get ride of the red + box on the titles now and we're home free.

#7 batman

batman

    Bat Learning

  • Members

  • 2203 posts

Posted 12 August 2012 - 01:37 PM

Hi storm
You are use "AddThis" in
Basic Option you have
Choose the sharing tool to display above the post:
and
Choose the sharing tool to display below the post:
You can try with
In above select "Custom button"

#8 batman

batman

    Bat Learning

  • Members

  • 2203 posts

Posted 12 August 2012 - 01:42 PM

One more
Try to delete
 important!
And see if the code works fine still
Code CSS is
 !important
and before ";" not after.

#9 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts

Posted 12 August 2012 - 08:09 PM

Batman is correct that your CSS code is incorrect.

Additionally, this snippet may be incorrect:
 body #content_sidebar .widget-title {
	background-color: #FFFFFF;
	color: #000000;
	}
because it sets the body color to white and font color to black. It is doing this for the body, the content sidebar and widget title. That could force your background image to fail to show. Try it without the word "body" at the beginning.

#10 storm09

storm09

    Advanced Member

  • Members
  • 96 posts

Posted 12 August 2012 - 11:56 PM

Hi Rangelone & Batman, Thank you for your helpful suggestions. Rangelone: I have taken the word 'body' out of the code. It didn't change anything, but I'll keep it out to avoid the issues you mentioned. Batman: I deleted 'important!' and the code still works. #feature_slider .addthis_toolbox { display: none; } I'll also checkout that 'display above post' setting as well. Cheers.

#11 batman

batman

    Bat Learning

  • Members

  • 2203 posts

Posted 13 August 2012 - 12:03 AM

I??m glad to help you. ;)

#12 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts

Posted 13 August 2012 - 01:59 AM   Best Answer

I'm seeing a background now, so I guess this is resolved. Glad to have helped!