Archived

This topic is now archived and is closed to further replies.

  • 0

Secondary Nav "Background" Disappears or becomes transparent

Question

Posted · Report post

Upon upgrading to the most recent version of Framework, for whatever reason the background behind the secondary nav on some of my pages is no longer present, or becomes "transaparent" so I can see the background of the entire page showing behind it. You can see this in place on the following pages: http://www.ambitioninsight.com/services/ http://www.ambitioninsight.com/clients/ This makes the menu unreadable as the text is dark gray and the background of the entire site is dark blue. If it were white like the "page background" (how its supposed to be) then it would look correct. This occurred immediately after the upgrade and I can't find any other question answering this. Thank you!

Share this post


Link to post
Share on other sites

13 answers to this question

Posted · Report post

Hi, This would appear to be a bug, before I report can you confirm that you're using the following settings: Layout Editor: Static with Pixel Width Full-Width Sections Also are you using child pages for the secondary nav ? A quick fix would be to create a custom menu for these links and then go to the Page editor, then scroll down to PageLines Meta Settings and then select the menu.

Share this post


Link to post
Share on other sites

Posted · Report post

I'm using Responsive with Pixel Width. Not exactly sure what you mean by Full Width Sections, but I think yes. Yes using child pages for secondary.

Share this post


Link to post
Share on other sites

Posted · Report post

OK, thanks for confirming. It does look like it may well be a minor bug. As a fix for the time being, use the method I posted above.

Share this post


Link to post
Share on other sites

Posted · Report post

Ok thanks. I've had this happen on at least 3 of my sites running Framework. The custom menu option won't really work unless I created multiple custom menus for each section on each site. Do bug fixes get handled on new releases or something I could place on my site in a few days? Thanks again

Share this post


Link to post
Share on other sites

Posted · Report post

Hi, I will bring this to the attention of our developers but they wont (as far as I know) release a patch to fix one minor bug. What has happend in the past is that the developers provide the code to fix the issue and you simply replace it. As this fix will be in the patch, I will reply here when I get more information.

Share this post


Link to post
Share on other sites

Posted · Report post

Ok. You'll actually notice beneath the "from the blog" and Carousel sections, another gap appears that shows through. I'm assuming this is a bug as well, as nothing was done to make this happen other than upgrade.

Share this post


Link to post
Share on other sites

Posted · Report post

Its above the carousel and beneath the "Recent Post Entries" on the homepage www.ambitioninsight.com

Share this post


Link to post
Share on other sites

Posted · Report post

Hi You can try add in PageLines > Site Options > Custom Code > CSS Rules

#content .content-pad { padding-bottom: 0px !important;}

to reduce the space

Share this post


Link to post
Share on other sites

Posted · Report post

I tested the solution above and it works. ;)

Share this post


Link to post
Share on other sites

Posted · Report post

Tried it, didn't work

Share this post


Link to post
Share on other sites

Posted · Report post

Please try:

section#latest-blog-entries div.texture div.content div.content-pad {padding-top: 0px !important;}

Helpful hint: If the above solution doesn't work, you can try use Firebug to generate the CSS you need: http://getfirebug.com. Instructions on how to use for CSS customizations are here: http://www.pagelines.com/wiki/Custom_CSS.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi. I'm running v 2.4 of PageLines. Which is a few versions since this issue was posted, but I'm still seeing this issue. 

 

Is there a code work around I can do? I have a lot of child pages and creating a custom menu is going to be a PITB.

 

Thank you.

 

Joe

 

 

 

Hi, I will bring this to the attention of our developers but they wont (as far as I know) release a patch to fix one minor bug. What has happend in the past is that the developers provide the code to fix the issue and you simply replace it. As this fix will be in the patch, I will reply here when I get more information.

 

Share this post


Link to post
Share on other sites

Posted · Report post

Hi,

 

It's best to open a new topic in all case, rather than tagging onto an outdated topic.  You can always quote or reference things from previous posts.  Please open a new topic and we can pay more attention to your specific issues.

 

Thanks.

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.