Jump to content


Photo
- - - - -

Primary Sidebar shows wrong widgets


  • Please log in to reply
27 replies to this topic

#1 basmati

basmati

    Advocate

  • Members
  • 255 posts
  • Framework Version:PageLines Framework (always the latest)
  • Country: Country Flag

Posted 06 August 2012 - 08:38 PM

hi folks, i just installed another pagelines framework on a domain. now for some reason i can't edit my primary sidebar - i choose in pagelines template setup SB1 = Primary Sidebar and put a text widget inside of it - but nothing happend! Primary Sidebar only shows "Category - Archives - Calendar". Am i missing some klicks in the template setup or is this a known issue? When i pull in the "tertiary sidebar" with widgets - it works like it used to - and all widgets are displayed correctly. might be to late for thinking... any ideas on that? help!

#2 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 06 August 2012 - 09:19 PM

Check Dashboard > PageLines > Page Options and the PageLines Meta Settings on the page where the sidebar is supposed to appear to make sure you don't have it hidden.

#3 basmati

basmati

    Advocate

  • Members
  • 255 posts
  • Framework Version:PageLines Framework (always the latest)
  • Country: Country Flag

Posted 07 August 2012 - 07:48 AM

thanks - but there are no options checked for the pr. sidebar in the page options and it appears on all 10 pages i have set up so far.

#4 Danny

Danny

    Is Awesome!

  • Moderators
  • 13067 posts
  • LocationManchester, UK
  • Country: Country Flag

Posted 07 August 2012 - 09:18 AM

Hi Basmati, It is very difficult to assist you if we do not have a live link to your website. If your website is local or you do not wish to share a link, then can you provide a Jing screencast of your issue or even screenshots please of the following: ??? A screenshot of your Appearance > Widgets area, showing us that you have a widget in Primary Sidebar ??? A screenshot of your PageLines > Drag and Drop > SB1 selected, so we can see which Sidebars you have active. ??? A screenshot of your Wordpress Admin Dashboard > Pages > (select the page in question) PageLines Meta Settings > Page Setup, so we can see that the "Hide Primary Sidebar" is not checked. and any other screenshots that you feel will be beneficial to us. However, a Jing screenshot of your issue would be best.

#5 basmati

basmati

    Advocate

  • Members
  • 255 posts
  • Framework Version:PageLines Framework (always the latest)
  • Country: Country Flag

Posted 07 August 2012 - 02:03 PM

its realy strange - thinking about reinstalling pagelines - because i have not worked a lot on the frontend yet!?
the system itself had some other strange behaviors - for example: it did not hide the searchbar although the box was checked - i just had to try a few times.

& here you are:

Please Login or Register to see this Hidden Content


Please Login or Register to see this Hidden Content


Please Login or Register to see this Hidden Content


Please Login or Register to see this Hidden Content


Please Login or Register to see this Hidden Content



in case you feel a little bit lost in foreign languages - "Prim?¤re Seitenleiste" is Germormon for "Primary Sidebar" :)

#6 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 07 August 2012 - 02:49 PM

Thank you for the screenshots. Do you have content in the Text widget that you added?

#7 basmati

basmati

    Advocate

  • Members
  • 255 posts
  • Framework Version:PageLines Framework (always the latest)
  • Country: Country Flag

Posted 07 August 2012 - 03:06 PM

yes, some text. i can even pull a search widget in the Primary Sidebar - and nothing changes!

Please Login or Register to see this Hidden Content



#8 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 07 August 2012 - 03:10 PM

Can you please deactivate any active plugins you have (if any), clear your browser cache, and refresh your site to see if any widgets show up in the primary sidebar?

#9 basmati

basmati

    Advocate

  • Members
  • 255 posts
  • Framework Version:PageLines Framework (always the latest)
  • Country: Country Flag

Posted 07 August 2012 - 03:47 PM

did that before- now again - changes nothing. probably i'll reinstall pagelines and see if this cures the strange behavior. i guess this is not a common issue?

#10 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 07 August 2012 - 04:11 PM

I haven't seen this issue before. Let us know what happens after re-install (ensure that you have everything backed up properly before performing it).

#11 basmati

basmati

    Advocate

  • Members
  • 255 posts
  • Framework Version:PageLines Framework (always the latest)
  • Country: Country Flag

Posted 07 August 2012 - 06:21 PM

suddently even the secondary and tertiary sidebars show no widgets any more!

#12 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 07 August 2012 - 06:38 PM

Very strange. Did this happen after a fresh re-install?

#13 basmati

basmati

    Advocate

  • Members
  • 255 posts
  • Framework Version:PageLines Framework (always the latest)
  • Country: Country Flag

Posted 07 August 2012 - 07:19 PM

yes wp and pl and childtheme fresh installed.

#14 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 08 August 2012 - 01:27 AM

Can you go to Dashboard > PageLines > Page Options and check each of the Default templates and any other templates you're using to make sure that the sidebars are not hidden there. That's a global area similar to individual page PageLines Meta Settings.

#15 basmati

basmati

    Advocate

  • Members
  • 255 posts
  • Framework Version:PageLines Framework (always the latest)
  • Country: Country Flag

Posted 14 August 2012 - 12:17 PM

already checked all that options settings, rangelone - nothing was wrong here ... i reinstalled pagelines and now it works - like it used to be. i think that possibly because i tried a lot of different settings in the pagelines setup (sections, fixed and responsive mode, sidebars, colors) - the system got a little buggy!? sometimes - when i hit the save button the process got stucked. anyway - i let you folks know when this happens again. thanks.

#16 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 14 August 2012 - 02:53 PM

Awesome!

#17 basmati

basmati

    Advocate

  • Members
  • 255 posts
  • Framework Version:PageLines Framework (always the latest)
  • Country: Country Flag

Posted 15 August 2012 - 09:34 AM

i got it!
when i put the german .po file into the pagelines language folder - the universal SB and the primary sidebar showing wrong (default) widgets! any ideas what causes this error? i loaded the german language file from your server (100% translated).

Please Login or Register to see this Hidden Content



thanks for any help - need the de translation - and my primary sidebar :-)

#18 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 15 August 2012 - 02:10 PM

I'm not sure what the conflict could be. Does it also happen with any other .PO file (for another language)?

#19 basmati

basmati

    Advocate

  • Members
  • 255 posts
  • Framework Version:PageLines Framework (always the latest)
  • Country: Country Flag

Posted 16 August 2012 - 01:35 PM

catrina, in turkish (tr_TR.po / tr_TR.mo) there seems to be no problem - but i can't say if the translation works, because i saw no turkish phrases! please could you or someone eles check the problem with the german language file? thanks!

#20 basmati

basmati

    Advocate

  • Members
  • 255 posts
  • Framework Version:PageLines Framework (always the latest)
  • Country: Country Flag

Posted 17 August 2012 - 07:56 AM

someone please, any ideas? its realy urgend!