Jump to content


Photo

un-click home button


  • Please log in to reply
12 replies to this topic

#1 rkazantsev

rkazantsev

    Advanced Member

  • Members
  • PipPipPip
  • 95 posts

Posted 23 July 2012 - 04:32 PM

How can I un-click the home button when I am on the home page? Look at the screenshot at http://72.26.98.200/.../07/unclick.png I want it the home button to be like the "Yes" in the example screenshot...

#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 23 July 2012 - 06:28 PM

How did you add that image as the home button? Did you add that image yourself?

#3 rkazantsev

rkazantsev

    Advanced Member

  • Members
  • PipPipPip
  • 95 posts

Posted 23 July 2012 - 07:09 PM

I added the following CSS Rule in custom CSS .main_nav ul li.menu-item-home a { background: url('http://72.26.98.200/wp-content/uploads/2012/07/white-logo.png') transparent no-repeat 15px 4px !important; width: 50px; And removed the Navigation Label from Home in Menus

#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 23 July 2012 - 08:50 PM

You appear to be missing a closing } at the end of your CSS.
 .main_nav ul li.menu-item-home a {
	background: url('http://72.26.98.200/wp-content/uploads/2012/07/white-logo.png') transparent no-repeat 15px 4px !important;
	width: 50px;}
You need to add an active state element as well, making the active state for that page none, even if clicked. See this for additional information: http://www.w3schools...ss/css_link.asp

#5 rkazantsev

rkazantsev

    Advanced Member

  • Members
  • PipPipPip
  • 95 posts

Posted 24 July 2012 - 02:37 AM

I have the } in my custom css forgot to paste it.... Sorry.... So I simi get what is needed with a:active just not sure what code is exactly needed to disable only the home button from being clicked

#6 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 24 July 2012 - 02:44 PM

What other custom CSS do you have?

#7 rkazantsev

rkazantsev

    Advanced Member

  • Members
  • PipPipPip
  • 95 posts

Posted 24 July 2012 - 03:19 PM

Here is my current custom CSS .main_nav ul li.menu-item-home a { background: url('http://72.26.98.200/wp-content/uploads/2012/07/white-logo.png') transparent no-repeat 15px 4px !important; width: 50px;} .main_nav li a{ padding: 10px 15px; color:#eee; text-shadow: #000 0 -1px 0; border: none; border-right: 1px solid #444; -moz-box-shadow: inset 0 0 5px #888; -webkit-box-shadow: inset 0 0 5px #888; box-shadow: inset 0 0 5px #888;}

#8 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 24 July 2012 - 03:24 PM

 .main_nav li a{
	
	padding: 10px 15px;
	color:#eee;
	text-shadow: #000 0 -1px 0;
	border: none;
	border-right: 1px solid #444;
	-moz-box-shadow: inset 0 0 5px #888;
	-webkit-box-shadow: inset 0 0 5px #888;
	box-shadow: inset 0 0 5px #888;}

^ What happens when you remove this code and view the site?

#9 rkazantsev

rkazantsev

    Advanced Member

  • Members
  • PipPipPip
  • 95 posts

Posted 24 July 2012 - 05:26 PM

I removed the code (No Change) weird I had fixed an earlier issue with a line under the menu by changing the padding from 6px to 10px ( i may have changed it in the style sheet. But I have removed that code

#10 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 24 July 2012 - 05:42 PM

Hm, okay, you can put it back. I'm not sure where that "click" effect is coming from for that home button. Has it always been this way? Even when you just installed the theme?

#11 rkazantsev

rkazantsev

    Advanced Member

  • Members
  • PipPipPip
  • 95 posts

Posted 24 July 2012 - 06:50 PM

Yes it has always been this way (clicked) if you click on the cloud button the Home/logo button is un-clicked

Here is the comparison from bugzila

"Un" Clicked code

}
.main_nav li.current-menu-item a {
box-shadow: 0 0 8px #000000 inset;

}
.main_nav li a:active, .main_nav li.current-menu-item a {
background: url("images/sprite-nav-bg.png") repeat-x scroll 0 -70px #F5F6F7;
box-shadow: 0 0 5px #000000 inset;
}
.main-nav .current-menu-ancestor a, .main-nav li.current-menu-ancestor ul a, .main-nav li.current_page_item a, .main-nav li.current-menu-item a, .main-nav li.current_page_parent a, .sf-menu li li, .sf-menu li li li {
background: none repeat scroll 0 0 #E7E9EC;
}
.main-nav .current-menu-ancestor a, .main-nav li.current-menu-ancestor ul a, .main-nav li.current_page_item a, .main-nav li.current-menu-item a, .main-nav li.current_page_parent a, .sf-menu li li, .sf-menu li li li {
background: none repeat scroll 0 0 #E7E9EC;

Clicked Code


}
.main_nav li a:hover {
background: url("images/sprite-nav-bg.png") repeat-x scroll 0 -35px #F5F6F7;
box-shadow: 0 0 5px #666666 inset;
}
.main-nav li a:hover, .main-nav .current-menu-ancestor .current_page_item a, .main-nav li.current-menu-ancestor ul a:hover {
background: none repeat scroll 0 0 #EDEEF0;

}
ul.sf-menu a:focus, .sf-menu a:hover, .sf-menu a:active {
outline: 0 none;

#12 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 24 July 2012 - 07:12 PM

Try adding this code:
 .main_nav li a {
	box-shadow: 0 0 0 0px;}


#13 rkazantsev

rkazantsev

    Advanced Member

  • Members
  • PipPipPip
  • 95 posts

Posted 24 July 2012 - 07:24 PM

That didn't do it but I tweaked your code a little and fixed it :) Here is what I used (Thank You Catrine) .main_nav li.current-menu-item a { box-shadow: 0 0 0 #000000 inset; }