Jump to content


Photo
- - - - -

Site is very messed up


  • Please log in to reply
55 replies to this topic

#21 davecfm

davecfm

    Super Member

  • Members
  • PipPipPipPip
  • 106 posts
  • Country: Country Flag

Posted 19 July 2012 - 02:00 PM

OK, I now have access to my WP dashboard however I'm still unable to activate Pagelines PlatformPro 1.5.3. It's listed under themes but a similar error message pops up when I try to activate. In fact all options in the wp dashboard give me this same error message. Warning: Invalid argument supplied for foreach() in /hermes/bosweb/web138/b1387/ipg.decummingscom/davec/wp-content/themes/platformpro/includes/class.layout.php on line 187 Issue setting layout a Fatal error: Cannot use string offset as an array in /hermes/bosweb/web138/b1387/ipg.decummingscom/davec/wp-content/themes/platformpro/includes/library.functions.php on line 235 Not sure

#22 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 19 July 2012 - 02:05 PM

Okay, do you have any plugins activated? If so, can you try moving the plugins in your plugins folder on your site to your desktop (just temporarily to remove them) and see if the error messages still show up?

#23 davecfm

davecfm

    Super Member

  • Members
  • PipPipPipPip
  • 106 posts
  • Country: Country Flag

Posted 19 July 2012 - 02:31 PM

I backed up all plugins to my desktop and then deleted them from host. Still not working though. Should I try to copy and paste the new php files listed in the error message directly to my host file manager?

#24 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 19 July 2012 - 02:39 PM

You can try that to see what happens and let us know.

#25 davecfm

davecfm

    Super Member

  • Members
  • PipPipPipPip
  • 106 posts
  • Country: Country Flag

Posted 19 July 2012 - 02:45 PM

That didn't work. Nuts! Since I've made so many changes should I restore my site and try re-installing PlatformPro 1.5.3 again?

#26 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 19 July 2012 - 02:50 PM

Try it again and upgrade your WordPress install if you don't have the current version.

#27 davecfm

davecfm

    Super Member

  • Members
  • PipPipPipPip
  • 106 posts
  • Country: Country Flag

Posted 19 July 2012 - 02:54 PM

OK. Right now I cant upgrade wordpress because I get the error message. Very, very strange. I'll have another go at it.

#28 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 19 July 2012 - 02:57 PM

Yikes, if that doesn't continue to work, try re-installing WordPress manually but make sure you have your database backed up so you don't lose anything.

#29 davecfm

davecfm

    Super Member

  • Members
  • PipPipPipPip
  • 106 posts
  • Country: Country Flag

Posted 19 July 2012 - 03:24 PM

I restored my site and the data in my host file manager returned but the site still shows the error codes. I deleted PlatformPro from the themes folder and updated wordpress to it's newest version. I then tried to re-install PlatformPro (a version I downloaded from my launchpage, my products page) and the error code is still there. I feel like I'm downloading the wrong version of PlatformPro. Do you have a link for the clean version I need? Thanks

#30 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 19 July 2012 - 03:38 PM

Can you post a screenshot of what you see on your Launchpad screen? The zip file for the latest version should be there so I don't think you have the wrong version.

#31 davecfm

davecfm

    Super Member

  • Members
  • PipPipPipPip
  • 106 posts
  • Country: Country Flag

Posted 19 July 2012 - 03:57 PM

Posted Image

#32 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 19 July 2012 - 04:23 PM

Dave, You need BOTH PlatformPro and PlatformBase. Think of Pro as the engine and Base as the chassis. Without the other, neither will get you anywhere. Make sure your OLD version of PlatformPro is renamed as suggested earlier. Once you FTP the folders to wp-content/themes you should see wp-content/themes/platform/pro and wp-content/themes/platformbase. Go then to Dashboard > Appearance > Themes and activate PlatformBase. Also, in Themes, it will give you the current version number. PlatformPro should be 1.5.3 and PlatformBase should be 1.4.1. If you get errors with that, then the problem isn't Platform, but something with the host. Possibly a server error. Let us know.

#33 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 19 July 2012 - 04:26 PM

BTW, if you need help with PlatformPro or Base, the docs are located at http://www.pagelines.com/docs

#34 davecfm

davecfm

    Super Member

  • Members
  • PipPipPipPip
  • 106 posts
  • Country: Country Flag

Posted 19 July 2012 - 05:10 PM

I like the car analogies! Should I still have my wp-content/themes/"PlatformPro_Old" in my themes folder? (minus quotations) or should I keep it saved to my desktop as my personal back up? Currently it is on my desktop. I download BOTH PlatformPro and Platform Base and tried to activate Platform base (which I never had prior). I get the same error message as always: "Warning: Invalid argument supplied for foreach() in /hermes/bosweb/web138/b1387/ipg.decummingscom/davec/wp-content/themes/platformpro/includes/class.layout.php on line 187 Issue setting layout a Fatal error: Cannot use string offset as an array in /hermes/bosweb/web138/b1387/ipg.decummingscom/davec/wp-content/themes/platformpro/includes/library.functions.php on line 235"

#35 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 19 July 2012 - 05:39 PM

A developer looked at this and mentioned that your database might be corrupt, although I'm not sure how this could've happened. You might need to repair the tables in your database (a fix is described here: http://chrisadams.me...orrupts-on-you/).

#36 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 19 July 2012 - 05:40 PM

Looks like the database entry that stores the settings is corrupted. Do you have access to phpmyadmin on your host?

#37 davecfm

davecfm

    Super Member

  • Members
  • PipPipPipPip
  • 106 posts
  • Country: Country Flag

Posted 19 July 2012 - 06:30 PM

I do have access to phpmyadmin on my host. I've been there before...it's like a different world.

#38 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 19 July 2012 - 06:38 PM

OK well in wp_options table there are 2 rows for PlatformPro they are: pagelines-settings and pagelines_template_map You can find them by searching for %pagelines% If you delete or rename pagelines-settings it should regenerate it next time you load wp-admin.

#39 davecfm

davecfm

    Super Member

  • Members
  • PipPipPipPip
  • 106 posts
  • Country: Country Flag

Posted 19 July 2012 - 07:36 PM

If I delete? Should I delete both Pageline_settings and template_map or just settings? Also, My host is looking at the problem right now and I expect to hear back from them in the next couple of hours; should I continue with this or wait? Will it mess them up?

#40 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 19 July 2012 - 09:10 PM

just rename the row then