Sign in to follow this  
Followers 0

Site is very messed up

56 posts in this topic

Posted · Report post

Hello, Without changing anything on my website, it is now horribly messed up. I contacted my host to see if it was on their end. It was not. I updated my version of wordpress and now pagelines is no longer my theme. When I try to activate the pagelines theme I receive this message: Warning: Invalid argument supplied for foreach() in /hermes/bosweb/web138/b1387/ipg.decummingscom/davec/wp-content/themes/platformpro/includes/class.layout.php on line 187 Issue setting layout a Fatal error: Cannot use string offset as an array in /hermes/bosweb/web138/b1387/ipg.decummingscom/davec/wp-content/themes/platformpro/includes/library.functions.php on line 223 Can anyone help please? Thanks, Dave

Share this post


Link to post
Share on other sites

Posted · Report post

Dave, Did you have any customizations in PlatformPro? If so, where are they located?

Share this post


Link to post
Share on other sites

Posted · Report post

Ragelone, Not sure I follow. Customizations in what sense? Certainly have custom css, etc.

Share this post


Link to post
Share on other sites

Posted · Report post

I think rangelone also means customizations in the theme (any additions to the functions.php file in PlatformBase, for example - that is, if you were using it).

Share this post


Link to post
Share on other sites

Posted · Report post

I don't remember touching any of the php files. That's not to say I didnt...I just don't remember. I made the site last year. I'm sure that answer doesn't help. Sorry.

Share this post


Link to post
Share on other sites

Posted · Report post

Ahhh, hm. Did you at least have PlatformBase installed? There's a chance that some changes (maybe not too many) were made in there.

Share this post


Link to post
Share on other sites

Posted · Report post

Is PlatformBase the updated to the theme from a few months ago?

Share this post


Link to post
Share on other sites

Posted · Report post

PlatformBase is the child theme for PlatformPro. I'm not sure what update to the theme you're referring to (unless you mean PageLines Framework, which isn't an upgrade to PlatformPro, but a separate framework).

Share this post


Link to post
Share on other sites

Posted · Report post

Pagelines Platform is what I have....Version: 1.5.2

Share this post


Link to post
Share on other sites

Posted · Report post

Okay, so you probably didn't make any customizations since you don't have PlatformBase (and customizations in the code in PlatformPro is advised against). Have you tried installing a fresh version of PlatformPro (it's recommended that you install 1.5.3)?

Share this post


Link to post
Share on other sites

Posted · Report post

Haven't tried to install 1.5.3. How would I update when I'm unable to activate the the original?

Share this post


Link to post
Share on other sites

Posted · Report post

Would I need to re-purchase?

Share this post


Link to post
Share on other sites

Posted · Report post

You don't need to re-purchase since it's an upgrade. Is a a download for it available on your Launchpad account? You can move the original out of your WordPress install and onto your computer using FTP so that you don't lose it and you'll be able to install the upgrade as a test to see if the problem persists.

Share this post


Link to post
Share on other sites

Posted · Report post

Where would I find my launchpad account? Sorry for the amateur questions...I am completely lost in all of this and am very worried I've lost my site. Would a site backup/ restore from my host be wise? I could go back a a few days.

Share this post


Link to post
Share on other sites

Posted · Report post

Is there anyway I could pay someone from pagelines to fix this? I just read the theme may be corrupted? http://www.pagelines.com/forum/discussion/14111/serious-issue/p1 I don't know where my "launchpad" is and my wordpress dashboard is not usable with the original error message appearing for most functions. I put so much work into my site and the thought of losing it makes me sick to my stomach. Please help!

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Dave, You can access your PageLines Launchpad here - http://www.pagelines.com/launchpad/member.php Simply login, download Platform Pro which will be version 1.5.3 and then using your favourite FTP client, navigate to: /wp-content/themes/platformpro/ Rename this folder to something like "old_platformpro" ~ without quotes. The upload the new platformpro you have just downloaded, from your launchpad. Once the upload has been completed, login to your Wordpress admin dashboard > Appearance > Themes and then active Platform Pro (the new one, you just uploaded). This should resolve your issue.

Share this post


Link to post
Share on other sites

Posted · Report post

Hi Danny, I started to do what you recommended above. I re-downloaded PlatformPro from the "your products" page of my Launchpad, unzipped, and then uploaded the new file to themes folder using FTP. All seems well (not sure I actually downloaded version 1.5.3 though) I still cannot enter my wordpress.org dashboard. I cant even get to the log in screen. http://davec.fm/wp-login.php Thanks

Share this post


Link to post
Share on other sites

Posted · Report post

It says in the errors that the install is still the old PlatformPro install. Can you try logging into the new PlatformPro install?

Share this post


Link to post
Share on other sites

Posted · Report post

I noticed that too. How do I log in to the new? What URL would I use aside from http://davec.fm/wp-login.php?

Share this post


Link to post
Share on other sites

Posted · Report post

Since old PlatformPro is the theme you have activated, that's why the log-in screen pops up for that one instead of the new one, so there isn't any other log-in screen to use. Try just removing the old one from your site (using FTP) by moving it temporarily to your desktop and leaving the new install of it there then try accessing the log-in page again.

Share this post


Link to post
Share on other sites

Posted · Report post

OK, I now have access to my WP dashboard however I'm still unable to activate Pagelines PlatformPro 1.5.3. It's listed under themes but a similar error message pops up when I try to activate. In fact all options in the wp dashboard give me this same error message. Warning: Invalid argument supplied for foreach() in /hermes/bosweb/web138/b1387/ipg.decummingscom/davec/wp-content/themes/platformpro/includes/class.layout.php on line 187 Issue setting layout a Fatal error: Cannot use string offset as an array in /hermes/bosweb/web138/b1387/ipg.decummingscom/davec/wp-content/themes/platformpro/includes/library.functions.php on line 235 Not sure

Share this post


Link to post
Share on other sites

Posted · Report post

Okay, do you have any plugins activated? If so, can you try moving the plugins in your plugins folder on your site to your desktop (just temporarily to remove them) and see if the error messages still show up?

Share this post


Link to post
Share on other sites

Posted · Report post

I backed up all plugins to my desktop and then deleted them from host. Still not working though. Should I try to copy and paste the new php files listed in the error message directly to my host file manager?

Share this post


Link to post
Share on other sites

Posted · Report post

You can try that to see what happens and let us know.

Share this post


Link to post
Share on other sites

Posted · Report post

That didn't work. Nuts! Since I've made so many changes should I restore my site and try re-installing PlatformPro 1.5.3 again?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0