Jump to content


Photo
- - - - -

HTTPS Issue


Best Answer Simon_P , 17 July 2012 - 07:49 PM

 add_filter( 'pless_vars', 'make_ssl_vars' );
	add_action( 'pl_force_ssl', '__return_true' );
	
	function make_ssl_vars( $vars ) {
	
		$vars['plSectionsRoot'] = str_replace( 'http://', 'https://', $vars['plSectionsRoot'] );
	        $vars['plRoot'] = str_replace( 'http://', 'https://', $vars['plRoot'] );
		return $vars;
	}
Go to the full post


  • Please log in to reply
9 replies to this topic

#1 jbstansell

jbstansell

    Member

  • Members
  • 27 posts
  • Country: Country Flag

Posted 17 July 2012 - 07:24 PM

I'm having trouble with https today, although I might have had this problem (without knowing about it) since upgrading to 2.2.1 a couple of weeks ago (I'm now I'm up to 2.2.4). My https is showing the dreaded redline through it. Is this a Pagelines problem or do I need to look for a solution elsewhere? For what its worth, I'm using the plugin Wordpress HTTPS to force https on certain pages.

#2 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 17 July 2012 - 07:47 PM

Yes the css is compiled without ssl, because as far as wp is concerned your site is non_ssl You will need to add some php to the customization plugin, if you have it installed.

#3 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 17 July 2012 - 07:49 PM   Best Answer

Please Login or Register to see this Hidden Content



#4 jbstansell

jbstansell

    Member

  • Members
  • 27 posts
  • Country: Country Flag

Posted 17 July 2012 - 09:20 PM

Thanks, but that didn't work for me. I copied your code and pasted it directly into the "Pagelines Customize" plugin. What do you suppose I did wrong?

#5 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 17 July 2012 - 09:36 PM

Into the functions.php of the plugin? is the plugin active?

#6 jbstansell

jbstansell

    Member

  • Members
  • 27 posts
  • Country: Country Flag

Posted 17 July 2012 - 09:50 PM

Color me confused. The plugin is active, and it's called: pagelines-customize/pagelines-customize.php The comments to this say: /* * * DO NOT PUT PHP IN THIS FILE!!! * * Please see file functions.php in this archive. * */ I frankly don't know what that means or where I'm supposed to look. Help?

#7 oplopanax

oplopanax

    Newbie

  • Members
  • 1 posts
  • Country: Country Flag

Posted 21 April 2013 - 07:22 PM

Did you guys resolve this? I am having the same trouble; throughout the pagelines code there are hard coded references to http:// which cause issues in all three major browsers when you log into the site using SSL -- in IE 10 my current error is 

 

 
CSS3117: @font-face failed cross-origin request. Resource access is restricted. 
fontawesome-webfont.woff
CSS3117: @font-face failed cross-origin request. Resource access is restricted. 
fontawesome-webfont.ttf
 

 

in Chrome it is 

 

 

The page at

Please Login or Register to see this Hidden Content

displayed insecure content from

Please Login or Register to see this Hidden Content

.

Please Login or Register to see this Hidden Content

The page at

Please Login or Register to see this Hidden Content

displayed insecure content from

Please Login or Register to see this Hidden Content

.

Please Login or Register to see this Hidden Content

The page at

Please Login or Register to see this Hidden Content

displayed insecure content from

Please Login or Register to see this Hidden Content

.

 

There's a similar one for Mozilla.

 

I added your filter into the functions.php for the child theme rather than use the customize plugin, with some effect (far fewer of these hard http links) but these are stubborn.



#8 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 21 April 2013 - 07:30 PM

Hi,

 

Did you update permalinks?

 

By any chance did you adjust the .htaccess to reflect the https?



#9 Simon_P

Simon_P

    Messer

  • Administrators



  • 8388607 posts
  • LocationDevon
  • Framework Version:2.1.1
  • Country: Country Flag

Posted 21 April 2013 - 07:31 PM

The filter AND the action?

Is your site SSL or are you using a plugin 'hack' to get one page SSL?

 

Whats the url of your site?



#10 beardedavenger

beardedavenger

    Unicorn Wrangler

  • Members

  • 1219 posts
  • Country: Country Flag

Posted 06 May 2013 - 10:35 PM

Nice. Worked perfectly.