Jump to content


Photo
- - - - -

I have "Add Comment" but it doesn't do anything


  • Please log in to reply
10 replies to this topic

#1 shantig

shantig

    Newbie

  • Members
  • 9 posts
  • Framework Version:2.1.1

Posted 13 July 2012 - 06:13 PM

I don't know how I did this but each of my blog pages contains a "add Comment" link right under the title but it doesn't do anything. I would like to have the site default be 'No Comments' and then pick and choose which pages and posts have comments. Please advise which steps I should take to accomplish this. Thanks

#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 13 July 2012 - 06:33 PM

What are your metabar settings? Also, do you have the comment section enabled in your single post template settings?

#3 shantig

shantig

    Newbie

  • Members
  • 9 posts
  • Framework Version:2.1.1

Posted 13 July 2012 - 09:08 PM

Hide comments in the actual posts are not checked.

I have attached a screen shot of Pagelines>Meta>Blog Page>Page Setup>Individual Page Section Control

Posted Image

#4 batman

batman

    Bat Learning

  • Members

  • 1741 posts
  • LocationBuenos Aires, Argentina
  • Framework Version:DMS
  • Country: Country Flag

Posted 14 July 2012 - 01:59 AM

Hi Go to Site Option > Blog and Posts and you see Configure Full Width Post Metabar and Configure Clip Metabar You can see in "more info" the short codes You have the words "Add comments" after On [post_date] something like this: By [post_author_posts_link] On [post_date] ·Add Comment if you want " # Comments" you need add [post_comments] and looks: By [post_author_posts_link] On [post_date] · [post_comments] I believe you need a new shortcodes to do you like (default be 'No Comments')

#5 batman

batman

    Bat Learning

  • Members

  • 1741 posts
  • LocationBuenos Aires, Argentina
  • Framework Version:DMS
  • Country: Country Flag

Posted 14 July 2012 - 02:34 AM

I believe you need a new short code to do you like default be 'No Comments'
By default [post_comments] is 'Add Comments' when it does??t have, and 'the number Comment' when it have comments.

#6 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 14 July 2012 - 04:03 PM

Thank you batman

#7 shantig

shantig

    Newbie

  • Members
  • 9 posts
  • Framework Version:2.1.1

Posted 24 July 2012 - 05:40 PM

I am sorry but I do not understand what you mean. I think you are talking about the section in the attached image:

Posted Image

It contains the default Pagelines Framework code. I know because I just reset it to default. I just want to allows users to post comments on specific posts and pages. This is a very standard thing right?

#8 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 24 July 2012 - 06:09 PM

If you need to change "Add Comment" to "No Comments" you'll need the base theme to make the change in one of the template files: http://www.pagelines..._the_Base_Theme

#9 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 24 July 2012 - 06:17 PM

When you create a post, you have to tell wordpress in the post editor page to disable comments and trackbacks.

#10 shantig

shantig

    Newbie

  • Members
  • 9 posts
  • Framework Version:2.1.1

Posted 24 July 2012 - 06:47 PM

OK I have read through http://www.pagelines...the_Base_Theme. I have made a couple of styling changes in the base theme and a lot of changes in the style.css but I have made no changes to functions.php. When I crete a post, there is only the option to "Hide" comments. Checked or unchecked, this option has no effect. There is something that is universally hiding all comments. Can you please provide me with a definitive list of all of the ways one might hide/show comments?

#11 Simon_P

Simon_P

    Messer

  • Administrators
  • 8388607 posts
  • LocationDevon
  • Framework Version:2.0
  • Country: Country Flag

Posted 24 July 2012 - 07:02 PM

ok, first off, WordPress controls whether comments are enabled on a post or page. There are two places to control it, globally on the wordpress discussion settings and on the seperate post/page edit screen, click 'screen options' and tick the comments checkbox and a new option area will appear to turn the comments on or off. The 'Hide Comments' checkbox you were referring to only hides the comments template, it does NOT turn comments on or off, just whether to show them or not.