Jump to content


Photo
- - - - -

Custom CSS class for Box clone


  • Please log in to reply
3 replies to this topic

#1 seecue

seecue

    Member

  • Members
  • 15 posts
  • Country: Country Flag

Posted 13 July 2012 - 05:29 PM

Site is not live -- I am developing on local server. Home page: have cloned Boxes in the content area. Have entered a custom class for Boxes 2 in the page meta. (news_boxes) Have entered custom css for this class in PageLines customize plugin. .news_boxes { border-bottom: 1px solid #000000; padding: 10px; } .news_boxes h1 { font-size:100%; color: #0c3f6e; } Custom CSS not showing up, and Firebug not indicating that the custom class has been applied. I have screenshots I can send. Any thoughts? Thanks for the help.

#2 catrina

catrina

    Advocate

  • Members
  • 12345 posts
  • LocationCalifornia
  • Country: Country Flag

Posted 13 July 2012 - 05:42 PM

Try adding !important declarations at the end of the attributes. Example:

Please Login or Register to see this Hidden Content


Can you please post the screenshots?

#3 seecue

seecue

    Member

  • Members
  • 15 posts
  • Country: Country Flag

Posted 13 July 2012 - 07:10 PM

It appears that the custom class "news_box" has been appended to the pagelines class "plgrid". So the style is applied to the box group, not the individual boxes. So, in trying to add a background color (green) to the boxes, the result can be seen in the enclosed screen shot...

Posted Image

#4 Rob

Rob

    One Smart Egg

  • Members
  • 13575 posts
  • LocationEast Coast, USA
  • Framework Version:The Latest, of course
  • Country: Country Flag

Posted 13 July 2012 - 07:58 PM

The CSS element must be box-specific if you want it to apply to individual boxes. Such as news_box-1 and news_box-2, otherwise, if all the boxes use the same element, the browser reads that all the boxes use the same element, so it applies it to a higher level... in this case, the box group.